Project won't save - Storyline 2

Getting a different error nearly every time.

Cannot access part because parent package was closed.

Cannot access a closed stream

Store must be open for this operation.

What gives? I can't re-save it as a new file. I'm screwed. About to lose half a day of work here. Any help? We've had this for less than a week, and never had (major) issues with Storyline 1, like this. Saving on C drive. Windows 7. 

Please get back to me asap.

187 Replies
Annette trial account Backs

Hi Ashley,

I followed your instructions to check my version.  I have the most current update 4: 1501.717 which is also what is shown when I go to the update page. 

I also tried dumping my temp files per the instructions provided.

Still having same issue. 

I'm attaching a screenshot and the ppt file I imported.

Thanks,

Annette

 

addendum:

The problem must be something specific to the file.  I tried to go back to storyline 1 and open an existing file to see what happens.  It opened storyline 2 instead.  I then opened an existing Storyline2  file, renamed it, and saved it.  No problems.  Then I tried to open the problem file that I had not been able to save.  I received a message saying it is corrupt or created in earlier version of storyline.  I'm attaching that file now.  The only things I did in this file that I don't often do are 1) imported PPT slides and 2) used an E-Learning Brothers template in the PPT.  I had not yet added audio or video to the file.

 

 

Ashley Terwilliger

Hi Annette,

Thanks for checking into those items and sharing the file here. I imported this into Storyline 2 Update 4 on my system and it did seem to take a bit longer than I'd expect but it did successfully import the project without any errors and I was able to save it as well. Can you take a look at my attached copy here? 

Are you seeing this error with all Powerpoint imports or saving all project files even just new projects in Storyline? To test this out, just try a one slide project in Storyline to see how it saves or try saving the copy I've shared here with the imported PPT. 

If you're seeing the error across multiple set ups I'd ask for you to go through the repair steps detailed here. 

Annette trial account Backs

Hi Ashley,

I am so happy you were able to work with the file!  I was able to open and save it to my hard drive.  I tried starting another new project using imported PPT slides and it worked fine for opening and saving.  The only substantial difference between the two files is that the problematic one used a template from another learning source and the one that worked used an old MS PPT template.

I did encounter another glitch, however.  The recording audio function stopped on the new presentation when I was nearly finished.  After about 2 hours of trying different ideas (checking devices, shutdown computer completely, changing recording devices, etc.) I finally was able to get it going again.  I have no idea why it stopped working.

Having the failing to save problem makes me a little concerned about losing future work.  What suggestions do you have to prevent it? 

Annette

Ashley Terwilliger

Hi Annette,

I'm glad that one worked for you - it did import very slowly as I mentioned, so that template may be the problematic element. You'll want to confirm that all project files are saved locally and adhere to the file naming/path guidelines as detailed here. 

Storyline 2 also has the auto recovery feature that you could enable to ensure that users can continue to access the files if for some reason Storyline freezes or crashes. 

You may also want to implement a method such as the ones described here to create back ups of your files. 

In regards to the screen recording function - did it stop recording or did it stop the import? The screen recording can only accommodate up to 2 hours of recording. 

Please let us know if you need any additional help. 

Amber Starfire

Hi, also am dealing with these same errors/issues all the time. And it's not specific to any particular file -- happens with all of them. I am using Windows 7 Enterprise. 4 GB memory, 32-bit operating system. Even if I close all other applications and there is apparently enough memory, as shown in the Windows Task Manager Performance tab, the files will not save.

  • The files have all been created in SL2
  • The files all have videos in them
  • Some of the files have software simulations
  • The problem occurs whether I save locally or on a network drive.
  • It occurs pretty reliably if I make more than 2 or 3 changes to an existing file, and if I don't save immediately after fine-tuning a video/software simulation

My workarounds:

  • I pretty much have to save after every change I make.
  • After every 10 changes, I save a backup version so I always have 2 files in case 1 gets corrupted.
  • When I get the error message, I force quit the program. I can usually open the recovered file, save, and pick up again after I figure out what I lost.

This process really slows down my work flow, so let me know when you have a fix.

Monique Donahue

I am periodically experiencing exactly the same issue as Amber. Currently this is only happening with one course where I have screen recordings. It most often seems to be a problem when I am fine-tuning a screen recording. I've been resorting to the same workarounds as Amber, and it slows me down tremendously.

I am using the latest Storyline 2 update and I always work locally on my files. 

Leslie McKerchie

Hi Monique!

If you are only having difficulty with one project file, you may want to consider importing into a new project to see if this eliminates the issue.

I would also consider a repair to be sure that your software is running correctly, and as mentioned above, if you need us to take a look you are welcome to reach out directly to our support team.

Amber Starfire

Hi Leslie, yes I am. And as stated above, it happens regardless of whether I'm working locally or not (though I do most of the time). And it has happened on multiple projects and computers. I always thought it was a problem with our computers here, but after reading the above I'm convinced that SL has a bug. For now, my workarounds are working, but it's really inefficient.

Do you think it might have something to do with cached or available memory when saving?

Cynthia Manika

I've had this issue with both version forever.  Remedy - get ooooodles of RAM. Save often. The longer between saves the more chance of it happening. At the first sign of trouble even with other things seeming the least bit goofy, like the font jumping size, anything - I close the app., restart my computer, then start with a new project, apply the saved player and import the old - then the goofiness is gone for a while.  I find it worse around major updates in OS.  Good Luck!

Barb Erfurt

None. Fortunately, I had a backup copy of my project, which I moved into
my desktop (from an external hard drive) and which operated properly. I
just wanted to report that I had this experience in case it mattered in
some way as you investigate the issue. Incidentally, before the failure to
save was the failure of the full project to preview. Hope you get it
solved. Clearly, a lot of people are losing weeks worth of time. I was
lucky that I only lost about 5 hours worth.

Ashley Terwilliger

Hi Barb,

Thanks for the update and I'm glad you had a back up file. This thread is a bit older, but Update 5 of  Storyline 2 did deal with a few of the issues associated with saving and you'll also want to make sure you are working off a local drive, as working on a network/shared drive is known to cause issues with Storyline or Studio files. 

elearningbytes .co.uk

"The project file could not be saved, cannot access a closed stream"

 

I found that I got this message if I imported video whilst the position and size window was still open.

Also the position and size window displayed strange and incorrect information regarding the size and position of the imported video.

I found that if I close the window after resizing, import another video and then reopen the window it displays the correct data, and more importantly I do not get this strange, and incorrect, error message and most importantly I can save my file.

Katie Coulston

Just had a new error when trying to save: "The project file could not be saved. CompressLengthMismatch" Any insights as to what this might be from? The project has imported ppt slides and added audio, but was working fine until I opened the file today and tried to add a hyperlink. It was a final ask of the team I'm working with, otherwise the project is finished and due today, and now I'll have to recreate it if I can't get it fixed. Any help would be much appreciated!

Ashley Terwilliger

Hi Katie,

I only remember one kind of recent thread with that specific error message, and in that case importing it into a new file resolved the behavior.  

Additionally  consider these preventative measures to protect your project files:

1) Save and publish projects on your local hard drive. Working on a network drive or external USB drive can cause erratic behavior.
 
2) Save incrementally. If your app has an AutoRecovery feature, take advantage of it. If not, save a new version of your project every hour or so with a new file name each time. If a file becomes corrupt, you'll still have a working version available.
 
3) Install Dropbox. Snapshots of changes in your local Dropbox folder are kept for 30 days. If a file is damaged or deleted, you can restore a previous snapshot: https://www.dropbox.com/help/11/en.
 
4) Don't leave the app open and unattended for long periods of time. Some users have reported file corruption after leaving their apps open overnight. It's possible that a malware scan or disk backup could run because the machine is idle, making your app vulnerable to crashing.
Jane Sullivan

Well having read all the other posts about this issue leaves me really nervous about the situation I am experiencing. I am getting an error message that "Project file cannot be saves - Parent container closed". I am using SL2 and the file has numerous videos. I am working on a mac with fusion to let me work on the pc side. I have tried to save this file numerous places: on my hard drive, on an external 2T drive and on a cloud drive...nothing works...Help. I have spent half a day on this file!

Jean-Guy  Boulay

Hi Jane, don't take this as gospel because its just a stab in the dark. Occasionally I have issues with the project publishing old content. This has something to do with the Backup system that storyline uses. You can either disable that backup option (I don't recommend it though), or you can go into the backup temp folder and delete old backups to make room. The folder is located here: C:\Users\<name>\AppData\Roaming\Articulate\Storyline. You should see a bunch of .tmp files there.  You can copy those .tmp files to another drive if you feel uncomfortable with deleting them.

My theory is that it might refresh your save file and allow you to save. 

Note since the update I haven't had the issue. I think it was directly related to the amount of videos in project.

Wish you luck.

Christie Pollick

Hi, Jane -- I am so sorry to hear of the issues you are experiencing and I would certainly recommend trying the suggestions that Jean-Guy has offered to see if you find improvement. And if issues persist and you would like to work directly with our Support Engineers, please feel free to use this form and you will be reached via email after your case has been reviewed.