Quiz review: Unable to move to next slide

This is occurring in Storyline 3. I just upgraded from Storyline 2 and it wasn't an issue there.

My quiz is set up to include a Review Quiz button on the Results slide. Each quiz review slide contains a button that the learner can click to review the topic covered by that question. The button's action displays the relevant slide in lightbox format.

When I click Review Quiz, then click a button to review a topic, I'm unable to proceed to the next slide in the review. (When I click Next, nothing happens.)

If I review the quiz without clicking any of the topic review buttons, navigation works normally.

I hope this makes sense. The attached screen shot may help.

Thanks,

Jennifer

12 Replies
Jennifer Williams

Randy (or anyone else who wants to look): I "gutted" my course to remove screen captures and uploaded it here. The content doesn't make sense anymore, but that shouldn't matter for testing purposes.

To see the issue, follow these steps:
1. Preview the course.
2. Take the quiz.
3. On the Results slide, click Review Quiz.
4. On the review slide for the first question, click the "Click here to review this topic" link to display the lightbox slide.
5. Close the lightbox slide and click Next to attempt to go to the second review slide.

Thanks!

Randy Hill

So I am thinking this is a bug within Storyline. For some reason when the lightbox gets activated, it takes the system out of review mode but keeps the buttons turned on. It is odd. I tried everything I know to get it to work, but could find nothing. One thing I did notice, obviously hitting previous resets it to be able to work, and for some reason question 2 when you hit next after the lightbox is open, it will go to the previous slide. I tried changing the resume or reset settings for both the slides and the layers but to no avail. I would bring it up to Articulate as a bug unless someone else comes across something. 

Katie Riggio

Hi there, Jennifer. Thanks for sending in your file to our team for a closer look!

My teammate, Hazel, is carefully testing this behavior, so keep an eye out for a follow-up email from her soon. 

Thank you both for bringing this to our attention, and I'll follow the case to share any relevant insight here!

Michelle Mata

Is there a solution to this issue? I created a submit button for the learners to answer the quiz question and removed the PREV/NEXT buttons. When reviewing the quiz, we're not able to advance without clicking submit again (which is odd since we're in review). Is there a Review Quiz slide master that can be edited. I rather not have the Prev/Next native icons or text on the slide. When they are on the screen, a learner can advance the question without answering it. 

Joe Tansengco

Hi Michelle, 

Sorry to hear that you ran into a similar issue.

Would you be willing to share a copy of your project file here or in private through a support case so we can test the behavior you are experiencing? 

You also mentioned hiding the PREV/NEXT buttons in the player from your learners. During review mode, are you trying to add custom buttons that will only be visible when a learner reviews a quiz? Or are you trying to control/limit the navigation in another way?