Submit Button Not Working -- HELP!

I copied and pasted an activity slide from a previous module that I did in Storyline 1.  I'm now working in Storyline 2.  The slide has a Submit button, along with a trigger to submit the activity when the button is clicked. The form has a Correct and Incorrect response. However, when I click on the button, nothing happens. I even tried getting rid of the built-in button and creating a new one with a trigger, and that doesn't work either. Can anybody help me figure out what I'm doing wrong? Thanks!

9 Replies
Ridvan  Saglam

Hi Samantha, 

It happened to me two or three times before, I couldn't figure it out either. However, it works when you add a new question. So, I added a new matching question and copied your question and settings. It works now. I added the story file, can you check it if it works for you?

Samantha Knapp

That works, but now I have another question. On the "That's Not Right" layer, I have it set to return to the main slide when you click the Continue button. I also have the settings so that it will return to its initial state, which it does, and I have on the form unlimited attempts. However, when it returns to its initial state, it won't let me drag and match. Any idea how to fix that? All these settings may not be exact, but that is what I changed them to on my end.

Leslie McKerchie

Hi Nicole and welcome to E-Learning Heroes. 😊

Thanks for reaching out and sharing that you are having the same issue.

Is this happening on all of your slides?

I want to take a look at your project file to investigate what's happening with your permission. You can share it publicly here or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.

Teresa Vanderpost

Hi Leslie and everyone else, I think I may have done something similar where i disconnected the submit button from the incorrect/correct layers.

This was an existing course, and the previous designer had used multi response for just one response quiz types, so I went in and fixed them all and I just copied the layers for feedback from the original questions, but now only Q4, 5, 7, 8  and 9 give me the layers, but when I did this I did it the same on all of them and when I hit retry it also takes me back to Q1 but with the answer displayed.  I think I broke it but no idea how to fix it.  As I looked at Q4 that works but don't see anything different.  Appreciate any help.

https://360.articulate.com/review/content/ea9d8206-bb06-4a36-8482-43fe12b4dec2/review

In the menu, I put the Begin quiz slide and the quiz questions in there in case you want to quickly jump down.

 

Thanks, hoping it is an easy fix, but i just can't figure it out