Trigger copy and paste doesn't always work in Storyline 2

Around eight times out of 10, the trigger copy and paste in Storyline 2 works fine. But as you can see from the attached video, sometimes it doesn't work at all. The only fix is to go to another slide, come back, and try again. Is anyone else having this problem?

15 Replies
Emily Ruby

Hello Charles!

 

Sorry that you are experiencing this. I tested C/P a few triggers in Storyline 2 and was not able to reproduce the issue.

Please make sure you are working locally as described here. Also you can try importing the file into a new file and see if this corrects the issue.

You can also try preforming a repair of Storyline.

Ashley Terwilliger

Hi Charles,

Thanks for sharing the video here. I tested copying and pasting triggers and didn't see the same thing happening. You mentioned if you change slides it starts to work again? Can you check that you're working on local project files as described here, and also is this only happening in one slide or one file? Are you able to share a copy of it here with us? 

Charles Thompson

Hi Ashley and Emily,

Thank you both for your quick replies!

I always work from a local file (one of the offending slides is attached). And I've done a repair/clean installation of Storyline 2 already, using the BAT cleanup file.

Storyline 2 continues to bedevil me with little UI issues like this one, issues that come and go (and yes, it's very random with every file, including those natively created in Storyline 2). This particular one doesn't happen often, just enough to drive me crazy. I also have another issue with copying a trigger, then it pastes a totally different trigger, using either the keyboard shortcut of CTRL+C and CTRL+V or the Copy/Paste Trigger buttons. 

I'm seeing all sorts of Storyline 2 bug reports in the forums, so I know there's additional work to be done (and while I actively report what I see, I still think it's remarkable how reliable the program is overall).

One thing I know for sure is that none of the UI problems I'm having with S2 happen with S1. Plus, any issue that happens to me on my main desktop PC (such as Autocorrect not remembering any custom entries) also happens to my second installation of S2 on my laptop.

Outside of the widely-reported bug with the quiz review not working on custom quiz slides, the main features of the new app work very well. I anxiously await the next update.

Emily Ruby

Hello Charles!

 

I am sorry that you are experiencing these issues. I did open your file and was able to copy and paste the triggers successfully without any issues. I also imported it into a new file, and was still able to copy and paste multiple times.

 

If you already tried the repair, and you continue to have issues, you could reach out to our support team for further assistance.

Rebecca Fleisch Cordeiro

Hi All,

Just wanted to let y'all know that the C/P issue illustrated in the video by Charles also happens to me. Yes, working locally. Yes, new/old files. As he said, it's intermittent and doesn't seem to happen for any rhyme or reason. I"m thinking others may be experiencing this as well, so wanted to add my voice.

Probably a tough fix, since it's hard to replicate "on demand."

Greg Hagar

Yes, this issue does exist. Occasionally too, a copied trigger will appear, but it will not actually work on the new slide/layer - the trigger must be deleted and then recreated from scratch. There is no apparent rhyme or reason for either behaviour from what I've observed (although I've experienced the latter issue most recently with triggers related to media on a slide/layer).

Greg Hagar

Hi Leslie,

Sorry no example - fixed it and moved on!

I was having some trouble with a copied trigger and this thread seemed related. Just thought I'd let people know that this does occur and that, assuming the copied trigger is configured correctly,  there really is no "troubleshooting" to do beyond deleting and recreating the trigger from scratch (not copied). 

If it happens again perhaps I'll submit.  Thanks.

Crystal Horn

Hi there, Cheryl.  Welcome to 360!  Are you having some inconsistency with copying/pasting triggers in Storyline 360?

If you're able to reproduce this behavior, would you mind sharing a quick Peek of when it happens on your end?  I want to make sure we can document it properly if it's an issue!