Video play/pause toggle on click

Hey Everyone,

I have embedded a screen recording video on a slide, and would like to disable the default pause/play function that occurs when the user clicks on the video. The only work around that I have found is covering the video with a hotspot. Is there a way to disable this feature? Thanks in advance for any advice/input.

28 Replies
Kerry Payneward

Hi Steve and Ashley, thank you for your replies.

Steve-

 Thank you for the suggestion, but I still need to be able to sync the video to the timeline. Looks like I'll either have to leave it as is or go the hotspot route.

Ashley-

I have the player controls disabled. What I am referring to is when the user drags their mouse over the slide, specifically over the embedded video and clicks. It will pause the video if it is still in play, or replay if the video has already completed. I have the video set to remain on the timeline for the length of the entire slide.

Thanks again for the suggestions.

Christine Hendrickson

Hi Kerry and welcome!

The best method I've seen for this is to cover the video. You don't really need to use a hotspot, but you certainly could.

In the past, I've recommended creating a shape and covering the area - then make this shape transparent. 

The reason I prefer the shape is because you won't get the cursor change that occurs when you're hovering over a hotspot.

I hope that helps!

Best,

Christine

Ashley Terwilliger

Hi Maureen,

Is the audio within the video or is it a separate file? Typically the hotspot or shape would need to cover the entire video - and if the audio is a separate element,they wouldn't be linked. I may not be understanding your set up either - so it may help if you're able to share a sample slide here with us. 

Adam Yerger

Hello,

I know this is an old thread, but for the sake of anyone searching this topic, a good solution to this is to add the video to your base layer, and then create a new layer that is set to appear when the timeline starts.

  • On the new layer, ensure that you have disabled the "Hide other slide layers", "Hide objects on base layer", and "Pause timeline of base layer".  
  • Next, make sure you have enabled the option "Prevent the user from clicking on the base layer".

This should allow your video to play in the background on the base layer, and disable the native "play/pause" when a user clicks directly on the video object.  If you have other items that need to sync or work with the video layer, it would probably be best to keep them on other layers (not the base layer).  

Adam

Alejandro Chavez

Just now had the same issue, and i find another solution based on Ashley comment,

I changed the video options,

In the options bar, i changed the option "Play video" to "From trigger", this disable the option to click the video, so you cant stop it with a click,

Altough you need to add a little trigger to start the video, in my case, i need the video to start at the begining of my slide so i add the following trigger,

To start the video when the timeline of my slide starts;

In case you need to start the video at certain time you can use the trigger when "Timeline reaches" and set the time, so i guess its a 3 solution.

Sorry for the bad english have a great day.

Blake Mohler

Hi -

If you put a square over the video to try and block the user from clicking it as suggested, you can't set the fill to "no fill".  You instead have to pick any color and set the transparency to 100% using the Format Shape option.  THAT will fix the problem for you, and I find it to be simpler and faster than trying to set up triggers, layers, or hotspots.

Good luck!

Douglas Harriman

I'm a fan of the transparent, solid fill shape on top solution and would add that if you use it, make sure to also hide the video from accessibility tools, since without that, someone using keyboard navigation could still tab to the video and hit enter to play/pause it. And if you had wanted to alt tag the video so screen reader users knew it was there, just alt tag the transparent shape instead.

Hiding the video from accessibility tools isn't necessary with Adam's layer solution, as the Prevent users from clicking on the base layer setting also essentially hides everything in the base layer from accessibility tools while that layer is open.

Marian Lewis

For  newbies like me: When putting the shape on the slide, right click on the shape and select "Format Shape" this is where you will see the option to change the transparency.

This is the only thing I have found that will work. Even a layer seems to allow me to start and stop the video and that really interferes with any other objects I have on the screen, as everything falls out of sync.

Thanks Blake!!!