360 degree Images

Me and the team are really enjoying playing around with the new Beta feature in SL360 - importing 360 degree images and planting hotspots, markers etc linked to website, videos, quizzes and so on. It really opens things up for a great learner experience.

We are however having issues with the mobile view - seems some of the interactions are a tad glitchy & unresponsive. Fine on desktop though.

It could be something we're not doing right so we'll be taking a closer look and maybe post some pics, but I just wonder has anyone else discovered any issues using the new feature on mobile?

8 Replies
Lauren Connelly

Hi Paul!

Thank you so much for sharing this with us! I want to gather more details to share what you're running into with our team. It sounds like you're viewing the course on a mobile device, and the 360-degree image is glitchy and unresponsive. However, it sounds like the 360-degree images behave properly on a desktop.

Are you publishing the course for Web, LMS, or Review 360? Also, are you viewing the course on an Android or iOS device? Lastly, are you viewing the course on Chrome or Safari in the mobile environment?

Thank you for taking the time to share these details with us!

Paul Laville

Hi Lauren,

No problem, many thanks for jumping in :)

Firstly, we love this and so do the clients we've showed it to - so please continue developing it!

To answer your questions, here goes:

We're viewing on iOS (iPhones running iOS 14.6) using Safari in the mobile environment.

The 360 degree image is actually fine - it sweeps around beautifully and the tags work ok except that occasionally on the mobile view, you'll touch one of the markers or hotspots (seems to be random or different each time)  and there'll be a sound like a brief burst of static, as though one of the audio files is trying to play and then stopping abruptly (this doesn't happen on the desktop view).

On a couple of visits an embedded video froze the course on playback, although this hasn't happened since yesterday. Again, only in mobile view.

One of the hotspots in the 360 image links to a standard slide with a simple button on it (to activate a short quiz), and it's actually this (the button) which is unresponsive on the mobile player. We tried changing the linking hotspot on the 360 image to a marker but it made no difference.

We then deleted the slide containing the 360 image and saved the quiz and its intro slide as a separate file. In this case the button activating the quiz worked fine on mobile view.

We've tested on Review 360 and on SCORMCloud - same mobile issues on both.

Link to the full course containing the 360 image on Review is HERE

Link to the standalone intro and quiz minus the 360 image is HERE

Hope that helps!

Paul

Paul Laville

Hey Tyler,

No problem. Here is the full Storyline file.

Just by way of some feedback for development - it'd be great if there was the ability to add audio when clicking a marker/hotspot to create a button click or achievement sound. I know you can workaround this by adding an audio layer that would achieve the same effect but it's a thought perhaps.

Also - do you guys have any plans to create a 360 where a user can 'walk around' a central image, like perhaps one of the cars in our test - and/or rotate it on screen with hotspots & markers? That would be incredible if so.

Give me a shout if you have any further questions and please keep me updated as to how you get on with investigating the mobile issue.

Kind regards,

Paul

 

Tyler Braddick

Thanks, Paul!

I can replicate this, and it does look like it's related to having the label alongside the trigger in mobile. As a workaround, you can remove that "Hazard" label and have it just jump straight to the slide it works without any issue. 

I'll get this issue logged with our team. We always appreciate feedback to enhance our tools, and you can submit any feature requests here!

I appreciate your help!

Tyler

Leslie McKerchie

Hi again, Paul!

Great news!  We just released another update for Articulate 360 and included a few important fixes you'll see in the release notes.

The item you'll be interested in is:

Fixed: Triggers on markers and hotspots in 360° interactions could cause a course to lock up on mobile devices.

Just launch the Articulate 360 desktop app on your computer and click the Update button for Storyline 360. Details here.

Please let us know if you have any questions, either here or by reaching out to our Support Engineers directly.

John Cottiss

Hi Leslie,

I seem to be having exactly the same problem with markers/hotspots not displaying text or showing hidden layers when used on a Android mobile device (works fine on a desktop).

Please can someone look into this for me (currently using latest software)

Thanks! :)