360 not creating new result slide variables

Hi

I am working on a project with 4 separate quizzes and graded result slides from the Journey template.

When inserting a new graded result slide (for quiz 2, quiz 3) etc. Storyline is not automatically creating the new set of variables, however, the use counts continue to increase.

i.e., Results.PassPercent, Results.PassPoints, Results.ScorePercent, Results.ScorePoints remain the only variables in use rather than a new set being created: Results.PassPercent_2, Results.PassPoints_2 etc.

Storyline is also not prompting/detecting the original/existing variable set when inserting the new result slides as one would expect.

Assistance would be appreciated.

Thank you

Joshua Bull

15 Replies
Steve Lemme

I have spent days uncovering what appears to be the same issue. Each time I add a results slide it seems to reuse the variable and not increment it. I have been searching so many threads and just found this one that sounds like the same problem I am having with Articulate 360. I have a simple file I should be able to share so you can experience the anomaly for yourself. 

Steve Lemme

Not that I was aware of, but I did start using Results templates later. Prior I was only doing copy & paste . I have a simple 3 slide interaction for two different personas. After 3 slides for the first persona, I have a result slide and all I wish to display is Results.scorepercentage which works. Then when you go through the next 3 slides for the 2nd persona and perform the results slide, I get all sorts of different results. It appears I need to have a Results_1.scorepercentage for 1 persona and then a Results_2.scorepercentage for the other. By the way I have 2 other personas still left, so need a Results_3.scorepercentage and Results_4.scorepercentage it appears. Yet there seem to be no way to create such "protected"? variables manually. However have been able to obtain a Results_2 by way of import.....

I further took a new project from scratch and viola each time I add a results slide it asks if I want to have it add another variable - wow wish I had seen that working previously or documented somewhere well. So, now I have further isolated that the results variable functionality is going wonky when you copy & paste or even when you import from another project. My past software product management skills are kicking into high gear now...

Leslie McKerchie

Hello Mark and welcome to E-Learning Heroes :)

Sorry to hear that you've run into an issue with this as well. 

Are you using Content Library results slides? We did have an issue with this, which has been corrected in a previous release.

Quizzes weren't scored correctly when the same Content Library result slide was added to a course more than once. Now Storyline asks to create a new set of variables each time you insert the same result slide, resolving the conflict.

Launch the Articulate 360 desktop app on your computer and click the Update button for each application. Details here.

Please let us know if you have any questions, either here or by reaching out to our Support Engineers directly.

I know you mentioned the latest version and if you are still experiencing difficulty when adding a result slide (pretty sure it will not retro correct your variables), please reach out via the link above so that we can take a closer look.

Mark Barham

Leslie,
Thank you for your response.
I am not using Content Library results slides.
I imported a Powerpoint and had to update the results slide from the Powerpoint version to a new Storyline version
that included logic for looping through content if the student failed the quiz.
I resolved the issue by deleting the old Powerpoint results slide and importing a new Storyline results slide from another Storyline project.
I still had to duplicate the slides in order to get the system variable to be created.
I updated all of my apps on 9/5/2017 before attempting the new Storyline project.
I am fine now but just wanted to report the incident.
Thank you,
Mark Barham