Audio not playing in Chrome

I am having issues with getting audio to play on my project in Chrome.  I am using Storyline 3.30.19518.0

I know there are issues with auto-play, so it is currently set up where the audio plays when you trigger it with a button.  This is working fine in Internet Explorer.  In Chrome, when you trigger the audio, you can see that the timeline has started, but I'm not getting any actual audio.

This is one of my first Storyline projects, but I tried republishing a project one of my predecessors did and I'm experiencing the same issue.

16 Replies
Katie (Gokhshteyn) Riggio

Hello there, CPI. Happy to help!

First, smart move to check out this article that explains everything you need to know about Chrome's autoplay policy. Let's investigate why the audio isn't playing as it should in Chrome! 

I created a test slide with a similar setup to yours in Storyline 360 (Update 31) and then published it to Review 360. When clicking on the button in Chrome 76, the audio plays. 

Do you run into the same problem in my published output here? Also, is the course hosted on a web server, Review 360, or a learning management system?

John Nield

I am having a similar issue, however video audio plays OK, but the audio I have added to slides play’s fine in preview but not once published, this affects all browsers Edge, IE 11, Chrome and Firefox. I want the audio to auto play on slide load, I have recorded the audio using Windows voice recorder and even converted the files from M4a to recommended format wav 44khz, but still will not play.

Lauren Connelly

Hello Nikisha and John!

Luckily we know why this happening. 

Early in 2018, Google stopped autoplaying audio in Chrome 66. This change broke a lot of web content, such as e-learning courses with audio introductions. The internet community cried for help, so Google temporarily rolled back the policy, giving everyone time to update their content.

With the release of Chrome 70 in October 2018, Google stopped autoplaying audio again. And this time, the change is permanent.

With that, there are browsers that we recommend.

John, would you mind sharing how you are publishing your course?

Nikisha Watson

Thanks for the response. I do not feel that this is related. I have some courses that work and some that do not. They are all published in the same way with the exact same settings. The audio works in SL preview and in Review 360, but not in the published output. The audio is not on the first slide. I've attached the files for further review. Thanks.

Ashley Terwilliger

Hey, John! Glad you found a solution that works for you! Keep in mind, some browsers have started to block the autoplay of media and our team has implemented a fix to assist with that. 

Anni, 

It sounds like you may be running into something else entirely. I'd love to have you share a copy of the .story file with our team so that we can take a look at exactly what's going on under the hood. Can you share with our Support Team

Christabel Nazareth

Using all the wonderful advice above, I'm closer to resolving a similar problem, but not there yet. My module starts with video and using the trigger to play media when timeline starts, it works fine in Edge.  When I use the same trigger in Chrome, the autoplay starts but there is just a frozen screen with no audio but there's movement in the progress bar at the bottom.  If I press the start button, the video starts playing, but it is not in synch with the progress bar and so the video stops mid-stream when the end of the bar is reached.  It then jumps to the next slide and plays the rest of the module just fine.  Also the replay is fine.  Can you help? I've attached the file.

Also, I've tried working around this issue by inserting a slide before the video. This works in Chrome but is clunky. Sometimes it will work fine in Edge, but at others times the wheel literally keeps spinning.

Leslie McKerchie

Hello Christabel,

Thanks for sharing what you are running into with your published project and for sharing the file so that we could take a look.

I published your course and uploaded to Tempshare and it's working as expected in Chrome. 

Here is the published output. (File removed per customer)

  • Do you see an issue with my published output?
  • What version of Chrome are you currently using?
Christabel Nazareth

Thank you for responding. Leslie.

Did you publish to the web?

Your output is fine  when I view it in Edge.  In Chrome, I get a grey screen with a button.  When I click the button, the video starts playing and everything is fine.  BUT I don't want anyone landing on a grey screen.  How can I get rid of the grey screen?

Chrome is Version 76.0.3809.132 (Official Build) (32-bit).

Also, can I ask you to delete my file in my previous posting when you are done working with it? 

Many, many thanks for all your help, Leslie.

Leslie McKerchie

Yes. I published to the same settings last used in the file you shared with me, Christabel.

It was published to the web.

The play button in Chrome is the expected behavior:

Learners using Chrome 66+ will see a play button when they launch or resume a course with a video on the first slide. Clicking the play button starts the course and allows the video to play.

You can read more in this article.

I've edited my post above to remove the published output for your file as well as removed it from my computer.

If you need your file removed above, please click 'Edit' below your reply and remove the attachment.

Johnnie Thayer

Wondering if there's any update on this. We're having audio problems as well - using Storyline 3, same way we've always published/zipped and uploaded. Audio will drop after the slide starts, the progress bar continues, the actions on the slide continue, just no audio and only in Chrome or mobile (off of the app for the LMS). We've found one or two things that seem to be happening, but nothing consistent and it's happening on almost every course at least once. We have to republish several times (no changes to the course) and it just suddenly works. No rhyme or reason. It's making it VERY frustrating. 

Using only IE is not an option - our learners are using different versions and we can't consistently ensure the course will mark complete. :-(

Leslie McKerchie

Hi Johnnie and welcome to E-Learning Heroes :)

Thanks for reaching out and explaining what you are seeing in your published course.

It sounds like you may be running into a different issue.

With your permission, I'd like to take a look at your project file to investigate what's happening. You can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.