Audio not working for HTML5 output in Chrome using Storyline 360

Hi all,

Very recently switched over to Storyline 360 and I am having issues with audio playback in Chrome. For some slides, audio does not play and I need to move the seekbar back to the start of the slide to get it to work.

Publishing the exact same project using Storyline 3 causes no issues and audio plays perfectly.

Anyone else experiencing this issue?

Cheers, Lloyd

 

 

89 Replies
Yair Iluz

Hi Ali, I'm experiencing the same problem as well with Storyline 360. 
I am having issues with audio playback in Chrome in my first slide - contains background music. For this first slide, the audio does not play and I need to click next and then back to the first slide  to get it to work. 

Please assist with this issue.

Thanks, Yair

Alyssa Gomez

Hi Lorraine and Yair! 

I took a peek into Lloyd's case, and I saw that our Engineers were not able to recreate the problem he was seeing. Lloyd did report that having the videos play using triggers instead of automatically (Play Video: When Triggered > Play Media: When timeline starts) seemed to resolve his issues.

If you're still having trouble with this, share your file with our team here, and we'll help you troubleshoot!

Megan Creegan

I'm having this issue. In order to get my audio to work on certain slides, I need to scrub the seekbar. Adding a trigger to get audio to play does not work either. I have a support case open and so far it's being reported as a bug. 

The only fix for me at this point has been to publish to Storyline 3. I'm curious if anyone else is still experiencing this issue so we can help Articulate get to the bottom of this problem.

Hannah Wool

Hi there, 

I don't have Storyline 360, I'm using Storyline 2 and as of two days ago, this is the exact same thing happening to me when I publish. The story I successfully published before this started happening, has the issue when I try and publish it now as a test. It has been fixing itself randomly on some slides and not on others. I've tried re-installing SL2, importing into a new story, importing new audio, testing working slide audio on non-working slide audio and no success. 

I just wanted to add to here as it doesn't seem specific to just convert from SL3 to SL360. I've submitted a ticket, waiting for a response.

Thanks! 

********************************************************************

UPDATE: 

Thought I would share my progress here just in case it helps someone else. I found what the problem was and managed to fix for all slides except for one that works locally but uploaded to my server, doesn't work. For me, the problem was stock videos beginning at the very start of the timeline. I shifted them to start .05s in and that let the separate audio layer play fine. I also noticed it was throwing a console error: 

Uncaught (in promise) DOMException: The play() request was interrupted by a call to pause().

This disappeared after I done the above. I'd be curious to hear if anyone has fixed it and how. This has taken me over 2 days of wasted time trying to figure out what was going on. Hopefully, my solution may help someone else. 

Thanks!

Alyssa Gomez

Hi Hannah,

Thanks so much for submitting your file to our team, and I see that you've been working with my colleague Victor. I'm really sorry you spent so much time troubleshooting this issue! Happy to hear you finally got it sorted out.

If you have any more questions, don't hesitate to reach out here or to Victor in your case. 

Hannah Wool

Hi Alyssa, 

Thanks for following up. The final issue I encountered with this is it all works fine locally but when I upload it to my web server to show the client thru a link, the first slide audio is still not playing. I pushed the stock video up to 0.75s and added a little screenshot of the video to the beginning so there is no blank before it starts. Not sure why the issue is only on the server now. If I remove the stock video entirely, audio plays fine locally and on the server. Hopefully, Victor can help me solve that final problem. 

I'd just like to thank you all for being so responsive. This is the first time I've encountered issues with stories and come here to this community and am being assisted so quickly, so thank you. :) 

Megan Creegan

Hannah, just curious if you are using Storyline on your Mac. I'm still encountering these issues. Articulate noted it as a bug, but I'm wondering if these issues are only affecting Mac users. I'm almost tempted to buy a Windows machine (I really don't want to) to see if my issues go away.

Hannah Wool

Hi Megan, I'm using it on Windows thru Parallels virtual machine on my Mac. I'm only having this issue with one story out of the 11 I'm currently editing. It could be worth sending it to someone here who only has a Windows machine to try publishing it on to see if that is the issue. One of the support guys is currently testing out my story so I'll be sure to update you all when I know more. Hopefully there is some final resolve! :) 

Megan Creegan

Thanks Hannah. I am also using Windows through Parallels on my Mac. It started with one project for me too, and now it's affecting several. It seems to be random.

Articulate, I'm wondering if this is a pattern. If this issue is being reported by all Mac/Parallels users.

And in case you suggest it, yes, I work locally and followed all the steps in the recommendations if you are using a Mac :)

Hannah Wool

That is curious, I'd be interested to see if it is a pattern.  Yes, I forgot to mention, just one project it happened and then I tested with a previous successful publish—the day before—and that also had the audio issue on some slides. Some slides randomly fixed themselves and the other few I had to shift the stock video forward like I mentioned above.

Yes, I'm working locally and then I just upload it to my web server so the client can see it before I send them the final HTML files. I'm just hoping that the last 4 stories I have to edit, are ok! fingers crossed! I'll let you know what Victor comes back with!

Hannah Wool

I heard back from Victor at support with the following (summarized) response: 

I'm done reviewing your project and we were able to replicate the issue. This error happens when there are multiple media files (audio and video) on the same slide. Especially if the video file is muted (Slide 1.1). I've reported is a possible software bug.

From here, I’ll meet with my team to take a closer look so we can determine next steps. Sometimes my team catches errors in my logic and we don’t have a bug after all. Of course, if that’s the case, I’ll let you know!

Depending on priority and risk, some bugs can be fixed quickly, while others take longer to resolve. I’ll let you know as soon as we have an update on this issue. Thanks so much again for letting us know about this, and I’m sorry if it’s slowing you down.

Meanwhile, I'm currently implementing possible workarounds to your project to alleviate this behavior. I'll be sending your the updated project file shortly.

********** UPDATE *********

Support has given me a partial solution by putting the audio on a separate layer and using a trigger to show the audio layer when the timeline starts. However, when I pause, the audio still plays so I'm seeing if there is a way it can sync pause with the base layer.

I posted updates on the following thread regarding SL2 too as someone was having the same issue here: https://community.articulate.com/discussions/articulate-storyline/audio-not-playing-on-some-sl2-slides?page=2#reply-491653 I don't want to clog up repeating my fix/workaround but I figure it may help people on both threads. 

************* FURTHER UPDATE AND FIXED!!! *****************

Whilst I was waiting for Victor to get back to me on the above pausing the separate layer. I decided to work from his advice on my existing problem story:

This error happens when there are multiple media files (audio and video) on the same slide. Especially if the video file is muted (Slide 1.1)

I removed the audio from my stock video outside of SL2—I used VLC (https://www.guidingtech.com/52911/mute-audio-use-vlc-youtube-video/)—then re-imported that video in and hid the old problem video—with the sound muted—still kept the workaround of starting the video ~0.75s in. It works perfectly locally and uploaded to my server! Such a relief!!!!

I hope this can help other people!

Danielle Schisler

Thanks for pointing me to this thread, Hannah!

I'm having the same problem with the project previewing fine locally, but when I put it on our web server or SCORM cloud, the audio doesn't play on the first slide. 

I thought it was an issue with slides that had video, as the first few courses this happened on started with videos that had separate audio tracks. However, my most recent course that I'm experiencing the audio issue with, the first slide has only a couple static elements. This is the one that I tested your fix of pushing the audio back to 0.75s, and that fixed it. I've yet to try it on the courses where I have videos on the first slide.

Again, this was not an issue that was occurring before I made the mid December update. And these aren't all brand new courses - some are courses that worked fine when published before that update, and now are having audio issues... so it's a mystery.

And in case you and Megan were wondering if this was a Parallels/Mac issue, I'm running 360 in Windows 10 on a PC.

Hannah Wool

This started happening to me after my SL2 requested my serial number randomly and wouldn't accept it on Monday. Support issued me with another one and I reinstalled the program also. It is very odd. Some slides had fixed themselves for me. I'd initially started with 9 slides with audio issues then it went to 4 then I did the fix I mentioned—shifting the video to start ~0.75s in—and then I just couldn't get the first slide to fix until I edited out the muted audio from the stock video. Hopefully, if you go and try doing my video workaround on your slides with video, you should be covering it all :-)

Thanks for the info on PC vs. Mac. At least we know its both platforms and not isolated to just Mac/Parallels. 

Good luck!