121 Replies
Ashley Terwilliger-Pollard

Hi Lee-Ann,

Ah, sorry it seems I read your first post wrongly. If you have it set to not pause the base layer the audio should keep playing unless there is something else there stopping it. Without seeing your file it's hard to say what that could be, but you're welcome to share an example with us here using the "Add Attachment" button.

Additionally, I also wanted to let you know that responding via email includes your signature here so you're welcome to visit this forum page to edit the post and remove that. 

Lee-Ann Williams

I was able to get the music to play throughout by having the layers auto-advance when each timeline ends. In my original file, you launched the first layer by clicking a button. I don't see any reason why that would turn off the sound (there's no Stop Media trigger associated with it), but now it works.

Ashley Terwilliger-Pollard

Hi Lee-Ann,

When you click the "View" link or the title of the post within the email you'll be brought back to this page. Once on here your post appears on Page 5 which you can navigate too using the arrows at the bottom of the page. 

I'm glad you figured out a way for it to work for you, and if you'd like us to take a look at the file you can either visit the forum page to upload it or you can send along to our Support Engineers using the link here. 

Wendy Farmer
veronica bianay

bonjour la communauté! ai besoin de votre aide pour pouvoir mettre de la musique de fond sur mon module. J'ai réussi sur mon fichier html et html5 donc ça fonctionne sur Mozilla mais pas sur EI.

Quelle est la marche à suivre ? merci à vous

Translation for folks who can help Veronica

Hello community! I need your help to be able to put background music on my module. I succeeded on my file html and html5 so it works on Mozilla but not on EI.

What is the process? thank you

Hi Veronica

you don't say if you are using SL2 or SL360 or what version of IE you are using.

Here are the browsers that are compatible for viewing content:

Storyline 2

Adobe Flash Player 10.3 or later, and one of the following browsers:

Windows: Internet Explorer 8 and later, Microsoft Edge (latest version), Google Chrome (latest version), Firefox (latest version)

Mac: Safari 7 and later, Google Chrome (latest version)

Windows: Google Chrome (latest version)
Mac: Safari 7 and later, Google Chrome (latest version)
Mobile: Safari in Apple iOS 7 and later, Google Chrome (latest version) in Android OS 4.1 and later

Storyline 360

Windows: Internet Explorer 10 or later, Microsoft Edge (latest version), Google Chrome (latest version), Firefox (latest version)

Mac: Safari (latest version), Google Chrome (latest version), Firefox (latest version)

Mobile: Safari in Apple iOS 8 or later, Google Chrome in Apple iOS 8 or later, Google Chrome in Android OS 4.1 or later
Windows: Internet Explorer 8 or later, Microsoft Edge (latest version), Google Chrome (latest version), Firefox (latest version)

Mac: Safari (latest version), Google Chrome (latest version), Firefox (latest version)


veronica bianay

rectification je suis sur une version de IE (couche sécurité de mon entreprise ) donc soit une version IE8

j'ai codé mon fichier HTML :

<audio preload="auto" autoplay loop autobuffer>  

     <source src="Travel_Memories.mp3" />

     <source src="Travel_Memories.ogg" />


et cela ne fonctionne pas ! merci pour votre aide

Alyssa Gomez

Translation for the community:

Correction: I am on a version of IE (security layer of my company) therefore either an IE8 version.

I have encoded my HTML file:

<Audio preload = "auto" autoplay loop autobuffer>      

<Source src = "Travel_Memories.mp3" />      

<Source src = "Travel_Memories.ogg" />      

</ Audio>

And it does not work! Thank you for your help

We do not support Javascript coding, so hopefully someone from the community can chime in and assist here!

Ashley Terwilliger-Pollard

Hi Rajesh, 

What version of Storyline were you using, and which version of the background audio shared? The original was a workaround created by my colleague Emily, but since it's a modification of the published output it's not something I can help with.

If you were using the code someone else shared here you could reach out to them directly using the "Contact me" button on their profile to see if they can help! 

Best of luck! 

Ashley Terwilliger-Pollard

I saw your other post here Ken, and it looks like you may have this working somewhat now? 

Christine has changed roles here at Articulate and doesn't get back into the forums as often as possible. I'd recommend sharing a copy of your .story file in that other discussion so that folks in the community can take a look and help you with this custom set up! 

Marco Lara

Hi, in my case im using storyline 360 and the index i use to play the course on the LMS is index_lms_html5.html and the script insides it's very different that the story.html   any suggestions on how to play music in whole course using storyline 360 and index_lms_html5.html

Cant belive that has passed many years since this suggestion and still didnt include this feature. its nothing from the other world. Adobe Captivate since CS5 have this feature, and it works pretty well. What happen Articulate?, Im so dissapointed

Amitty Gray

Yikes. Even Power Point has this feature. Come on guys...get with the program already! I hate to say it, but between not being able to play continuous audio (client request #1) and the wonky fonts in Internet Explorer (biggest client only has IE with no permissions to edit settings) - I'm about ready to look for a different authoring tool.

francois gernigon

Bonjour, je viens de l'univers FLASH et découvre Storyline. Très compliqué pour moi de passer d'un 4x4 à une berline. Je rencontre pas mal de problème de "Crash" pour des soucis de variables, calques mal ou non utilisés. Mais à part l'animation très limitée, c'est vraiment le son qui manque cruellement de facilité d'utilisation. Et bien évidemment la possibilité de fonds sonores multiples par l'utilisation d'une banque sonore dans le projet directement. Merci d'avance à ceux qui ont la solution. Protégez-vous bien...

Brad Kney

This is clearly an old thread, but it helped me.

I placed the following code just under the <body> tag of the story.html file.

<audio src="mymusic.mp3" preload="auto" autoplay loop></audio>

I placed mymusic.mp3 in the same folder as the story.html file.

This worked for Edge and Chrome, but not for Firefox. I changed the settings for Firefox - opened the 3 parallel line button - I think that's call a hamburger - clicked Options, then Privacy&Security, then changed Autoplay to "Allow Audio and Video" - and this worked.