Moving rollover issue in multiple choice questions (Storyline)

I have seen an answer to a post similar to my problem, but it's not solving the issue. On the multiple choice questions, sometimes an answer "jumps" when rolled over.

I have gone into the edit states and fixed this, however, even after fixing it still occurs. I'm guessing this is because of the shuffle feature, moving the answers into different spots. But even making sure there is plenty of room for each answer, and spacing them properly, and even adjusting the states to make sure they are set up perfectly, it still happens.

Any other ideas besides simply editing the states so they match up?

Thanks!

Jeff

16 Replies
Christine Hendrickson

Hi Jeff,

I'm not sure which issue you're referring to on the forums, but it sounds like an issue I saw with a drag and drop question with the shuffle feature enabled.

Not sure why this would happen with a multiple choice question, though. Are there any differences between the answers? Font size, etc.?

Any chance you could share the .STORY file here? I'd be happy to take a peek.

Thanks!

Jeff Clay

Hi Christine,

I've finally figured out the issue. I think the problem was that instead of creating a new slide, I was duplicating a question slide and just changing the text. (I was using a certain template for the question slides, and it seemed easier to just duplicate the slide I had). Since I was just changing the text, that doesn't change the size of the text box itself.

For example, if you had an answer that was originally two lines, and the new answer is only 1, the size of the text box will stay the same. So you need to adjust the text box in each state so that it's exactly the same. And since you can't copy/paste from state to state in a question slide, you need to manually adjust each state so they're identical. Otherwise, you will get that "jumping" when either rolling over or clicking the radio button on an answer.

The moral of this story is....don't duplicate question slides....just add a new slide as normal.

Jeff

Christine Hendrickson

Hi Jeff,

Thanks so much for the update and the details!

While that's what I expected to hear, I'm glad that you were able to figure this out and get it working. That makes sense, now, I wasn't quite sure what would've caused that. I'll be sure to keep this in mind, in case someone else runs into the same issue.

Thanks again for sharing the solution!

Christine

Linda McCroft

Hi everyone,

I came across this thread as I had the same problem - however  I've found it's because I was copy pasting new answers into the screen view. When you copy paste into form view the roll over works fine.

To correct the questions already programmed I have had to cut the answer from screen view and then paste into an unused box in form view - by toggling between screen and form view a few times it gets rid of the spaces from where I cut the question out and it all works perfectly.

I know this is two years old but thought I'd post as  you can still use question as a template but remember to paste into form view.

Hope this helps someone as I was about to re-do all 26 test questions when I had this thought.

Linda

Henrik Clausen

I've also had some very annoying situations with states in multiple choice / multiple response, and still have to some extent: When I increased the size of one answer box (the box, not an individual state), some states would not change along with the resize, and/or the box in some states would resize along with the main one and become too large.

Also, resizing the answer boxes in individual states does not snap to guidelines or the width of the quiz in the slide, making exact adjustment more tedious than it should be. Finally, "Make same size" is not available from the Alignment menu :(

What I aim for is very simple: All answers should align nicely inside the quiz box, in all states. It would be VERY useful if Storyline had some ways to make this as easy as aligning slide elements.

And yes: This is related to copy/pasting existing slides. We have quite a few template elements in these slides.

Henrik Clausen

Let me get back to this, because the issue appeared again in two new projects I started, where I imported a selection of quiz slides from our template, and then copied some of them internally in the new projects. The response option states in the template are fine, but get severely messed up when imported / copied in the projects where I need them.

A secondary compounding problem is that the tools for getting all state shapes nicely aligned in size and position are lacking. including snapping to guidelines/other shapes being inactive and alignment tools not being available.

This is dreadfully buggy and inconvenient :(

Henrik Clausen

I'll get a more complete example when I have time to dig it out - also, I'm suspecting that more than one issue (bug) exists here.

First, my Grid & Guides settings. They are almost like yours, the only difference should not be important - screenshot enclosed.

Then, when I move a quiz, then snap it back with Ctrl-Z, some of the response options have their shapes resized - see the other two screenshots.

The worst problem, however, is importing quiz slides from our template. The quiz response shapes have sizes that are a mess, but not entirely random. I'll get examples of that later.

Alyssa Gomez

Hi Henrik, thank you for that update. I was unable to reproduce that behavior in a new Storyline 360 file, so I'm interested to take a look at your file if you don't mind sharing it here.  If you’re able to share here in the forums you can include it by utilizing the Add Attachment button at the bottom of the reply window, or if you need to share privately you can send it along to our Support Engineers here. They’re accessible 24/7, and if you want to let me know the case number I can follow along.