Publishing Time for a Video

I am trying to publish a SL course as a video (mp4) and it is taking forever! I have 6 slides, and on one slide a 90 second video. The total time for all six slides is about 2 min, 16 seconds. It has been publishing now for almost an hour. The message reads "Encoding Video - 1.6 Untitled Slide - 2:16." I have tried this three times and it gets stuck right here. Any ideas?

Thank you!

18 Replies
Alyssa Gomez

Hi Kristin!

We've heard similar reports from folks that the publish as MP4 feature takes a while, especially when the course contains a large number of audio or video files. An hour is certainly a long time to wait! 

If you're already on the latest update of Storyline 360 (3.20.16814.0) and the publishing process is still running at a snail's pace, share your original project file with us here. We'll take a closer look to see if we can spot the issue!

Ashley Terwilliger-Pollard

Hi Kristin,

I'd start by checking that you're on the latest update of Storyline 360, build 3.20.16814.0 and that you're publishing the video to a local path on your computer (such as the C: drive). 

If you're still running into trouble on that update, do you have any slides that loop, For example, having the last slide set to jump to the first slide when it ends? That has caused issues with publishing to video. 

Our Support Team is also happy to take a look at your file and test it! 

Leslie McKerchie

Hey Leslie,

Thanks for chiming in and sharing what worked for you as that could certainly be helpful for users.

I did want to mention that Ashley mentioned checking to be sure you are on the latest update as we show that we corrected an issue with publishing to video taking longer than expected :)

All the details on the newest version, as well as the history of updates, can be found here.

Crystal Horn

Hi Robin. We fixed an issue where Storyline 360 was failing to publish to video when a slide with a timeline shorter than 5 seconds contained an exit course trigger.

Please let me know if you are already on the latest update, or if your setup doesn't match that description and you're still seeing this issue!

Wayne Judd

Hi, I've been having the same issue and do have a last slide which loops back to the beginning. Ashley mentioned there is an issue with this last year so does anyone know if that has been resolved. I also have quite a lot of zooming on the slides and am wondering if this may be causing things to seize up?

Leslie McKerchie

Hi Wayne,

Thanks for reaching out and sharing what you are running into with your course.

Is your video on the slide master? If so, that's similar to what we've seen reported and the workaround is to add it directly to the slide.

If not, then with your permission, I'd like you to share your project file with our support engineers to investigate what's happening. You can share it privately by uploading it here. It will be deleted when troubleshooting is complete.

Vincent Scoma

Hi April,

That is a long time for a course to be publishing! To make sure I am on the same page, is the course being Published to a Video File? Does this happen to other courses you try to publish? Publishing times can vary based on course size and the media included, but typically only by a few minutes. 

Please keep us posted and let us know if you have any questions! 

Lauren Connelly

We released another update for Storyline 360 (Build 3.52.25156.0) today, which included a fix for the bug where projects with screen recordings took an exceedingly long time to publish as a video file.

Update Storyline 360 in your Articulate 360 desktop app to take advantage of the newest fixes and features.

If you have any questions, you can reach our team in this discussion or in a support case.