Storyline is not recognzing the MP4 format

I'm trying to import an MP4 video into storyline and when I select it I get the following error.

"Disc2.mp4" does not appear to be a supported video format. Please select a video from one of the supported formats. (See attached screen shot)

I'm not sure why it won't recognize an MP4 file since this is the preferred file format. Is it a bug in Storyline? I made sure I was importing the MP4 from my local drive and not from my network or external drive. Any help would be appreciated. Thank you

28 Replies
Rutwin Geuverink

Hi Stacy,

MP4 allows both native audio streams (encoded to a standard defined as part of MPEG-4) and private streams (those not part of the MPEG-4 specs). However, there's very little support among software and hardware vendors reading private streams. As a result, if your MP4 file contains audio in a format other than AAC there's a good chance your player won't be able to read it.http://www.afterdawn.com/glossary/term.cfm/mp4

Most likely the mp4 file in question contains a non-supported combination of audio and video - What is the source of your mp4 file?

You could try to convert your file to a more compatible MPEG-4 format.

https://cloudconvert.org/ (just select from mp4 to mp4)

Hope this helps,

Rutwin

Ashley Terwilliger-Pollard

Hi Pharah, 

Do you receive the same type of error message when inserting it? You mentioned using Camtasia as well - is that where you're creating the MP4? If you're able to share that here we could take a look at inserting it to see how it behaves?  If you can share it publicly you can send it along to me here. When I have problematic MP4 files, I typically use a tool such as  Handbrake to convert them and ensure they're using the right codec. 

Jessica Milligan

I have just experienced the exact same issue with Storyline2.  We have a video tech on staff that rendered off a total of ten videos all with the same settings but the first one will display the same error message as above.  The other nine clips go into Storyline 2 and play just fine but the first is popping up errors. 

I have downloaded it onto my local hard drive multiple times, saved and restarted Storyline and it still seems to pop up the same message.  Is there a size limit for videos?  It is the biggest off all the files I'm working with.

How can a MP4 rendered off with the same settings work for nine videos but then fail on one?

This is not a situation where the settings are incorrect due to the ten videos being batched.  I also can't post any of the work here as the total project size will be close to 10GB and the video in question is about 3GB.

Leslie McKerchie

That is a large file. I've not heard issues with this in particular, but again, I have not encountered a video or project file this large.

Are you able to check the video file in a new file to see if it works?

Did you attempt the convert that Ashley mentioned above?

Is there anyway this could be a smaller file perhaps or you can link to it on a server and add as a web object?

Jessica Milligan

Hi Leslie,

I did try to put the file into a blank New Storyline file and it would not load there either. 

I have not tried to alter that file due to the fact that all the other files rendered with the exact same settings at the exact same time work just fine.  I can rule out any issues with the production of the file.  The file also plays perfectly when launched straight from my desktop so there is no corruption.

Due to the confidentiality of the file and the content therein, there is no way to break down the file and we are not comfortable putting it on a server. 

Are there file size limits?  What would cause one video to have issues but not the other identical nine (except for file size) within Storyline 2?

Leslie McKerchie

I'm not sure that we have specific limits listed, but viewing a file this large if you were to get it uploaded and published would be difficult as well I imagine.

I would invite you to check out a related thread here about best practices.

Hopefully if someone in the community has any advice or experience, they will chime in here.

Jessica Milligan

We overcame this error message by compressing the file using Final Cut Pro to below 2 GB.  There seems to be a size issue with Storyline 2 for MP4s above 2GB. 

*Fixes attempted were to download the video onto local drive three times and to render the video using the same settings using Final Cut Pro.  None of these worked until we set compression levels below 2.8GB

Hope this helps future users when they encounter this error message :)

Rachel Crabtree

Interesting I have this issue with Storyline 360.  Converted a WMV file to MP4 via Adobe Media Encoder.  Now it states that it is an unsupported format.  It is quite a large file, which I understand if there was issue, but with an error it is unsupported???  I will look over the troubleshooting tips here - thanks!

Rachel Crabtree

Thanks for the suggestion - I imported the original .wmv file and exported as an MP4 double checking that the audio settings were AAC.  Unfortunately Articulate still doesn't recognize it as a supported format.

I think it may be related to how big it is (41min long).  Also I am using Storyline 360.

Katie Riggio

Hi, Rachel. Thanks for your update, and do keep us posted with how you go with those solutions!

I'm also curious to know if Gerry's pro-tip to bring your .WMV into Replay 360 > Publish it as a video file > Then, insert that generated .MP4 into Storyline 360 will help resolve the error for you. Another approach could be to use Handbrake to convert your file – a free video converting tool we like to use: https://handbrake.fr/

Lastly, in case you and your team are interested: Our team keeps all files confidential, and they can even sign an NDA if that makes things easier! Just let us know. 😀