Text entry field - new error since last update

Hello,

We have many courses that require learners to input their names before beginning the module. There is a text entry field with the following code:

"Set LearnerName equal to the typed value When the control loses focus".

Then we have a "Confirm" button, with the following code:

"Change state of Error (a warning message) to Normal When the user clicks (Confirm) IF LearnerName is equal to (blank).

Change state of Next Button to Normal When the learner clicks (Confirm) if LearnerName is not equal to (blank)"

This has been working well for years. However, since I updated Storyline 3 to the latest release, the variable LearnerName does not register if I click Confirm (when published). I have to click somewhere else on the screen before clicking on Confirm (even if pressed multiple times).

I have attached a sample.

 

***EDIT: I can also confirm that courses published before updating Storyline 3 still work properly. Only courses published after updating present this error.

18 Replies
Leslie McKerchie

Hello Cyndy,

Thanks for reaching out and sharing what you are seeing in your project along with a sample .story for us to take a look at.

I noticed that you've published to CD. Is that the method that the content will be distributed to your learners with?

What browser/environment are you running into this issue? I was able to recreate the behavior, but only when viewing the output in IE11. Is this what you are experiencing as well?

cyndy ryder

Hi Leslie,

Thanks for looking into this. We have 2 methods of deployment: LMS on IE11 with HTML 5 (we are publishing with Flash backup right now as we transition away from flash) and CD version for our learners who need to download and view offline.

We don't upload to the LMS until the updates to the modules have been approved and they are still in testing, partially due to this error. 

I tested on the SCORM cloud and it works properly in Chrome but not IE11, which is what we need to work, along with the CD .

Leslie McKerchie

Thanks for those details Cyndy. I was able to track down when this behavior changed and get it reported to our team as a software bug.

I wanted to share some information on how we define bugs and how we tackle them when they occur.

This conversation is attached so we can update you here when we can.

Herminia Esqueda

I think I am having the same issue. I have a set of five text entry boxes where the variable is equal to the typed value. I also have some calculation triggers that run when the user clicks "Update".  All of the variables are updating except the last one. All variables were updating when the calculation triggers were based on the "Next" button. However,  my users want to be able to come back to the screen and see what they entered. In order for it not to redo the calculation triggers, I moved all the triggers to an "Update" button. If I tab or click anywhere on the screen before I click "Update" the variable updates. If I go directly from the last text entry box to "Update" the last variable doesn't set.

Herminia Esqueda

Here's my four slides. Click "Update" on the first slide. The second slide is the one with the issue. The last number entered will not update the variable, unless I "tab" or click somewhere outside the entry box.  Here is an example of the numbers I entered: 6000, 8000, 5000, 4000, 1200, 600. Do not "tab" after the last number. Click "Update". Close the pop up box on the third slide. Notice that it does not report any numbers in the "Leave" row. It should read 600 minutes in the second column and 10 hours in the third column.  

Becca Levan

Thanks for reaching out and sharing your file, Amanda! 

I tested this out in IE11, and I see the same behavior you described where the text entry value doesn't carry over. Things worked as expected in Chrome and Firefox for me.

From here, I've enlisted one of our support engineers to help troubleshoot and opened a support case on your behalf. One of my teammates will reach out shortly!