Variables not working in SL360 course

Mar 17, 2020

Hi there, 

I have 6 variables in a course, none of which are working for me. They do display and work properly for other co-workers. 

I have deleted and re-added them all, re-saved a new version, published for web and tested in both IE and Chrome - and still no variables work.

My SL360 is showing as up to date. Please advise,

Thank you,

Tara Muir

15 Replies
Walt Hamilton


I think I may have bad news for you. What I think is happening is that when Enter is pressed, it initiates two built-in actions. One is to change the focus from the Text input box (which would populate the variable), and the other is to jump to the next slide. These two race each other to see which happens first. For any slide, or combination of computer and browser where the variables work, the lose focus has won. For those that don't work, the jump has won, because once the jump starts, all other actions are halted and not initiated. The fact that they work for some of your co-workers, indicates to me that the problem is not with the design or creation, but is most likely machine-specific.

None of them worked for me, without artificial encouragement. Watch the video, and you'll see what I mean. On the  Question 3 slide, and the one immediately following it, I put a reference box to see if the variable is populated.

The first time through, I type and press enter. Neither reference box shows a content for the variable.

The second time, rather than press enter, I press tab, until the skip navigation message shows. When it does, the input has lost the focus, and the variable is populated. Then, when I press enter, it jumps, and the variable is shows as populated on the next page.

The third time, I type, then click the Next button I added to that slide. Its trigger is jump to next slide when user clicks Next. What actually happens is that the trigger is initiated when the button is released, not when it is down. In the video, I clicked and held, which allowed me to move the cursor to show the variable contents. The variable was populated when the button was down, because focus was lost, and when the button was released, the jump was initiated.

Watching the video,l I am absolutely certain that the problem is that the jump starts before focus is lost. I have no idea of how to fix it. I tried everything I could think of to create another action that would be transparent to the jump process, yet claim focus first long enough to populate the variable. I tried things like changing states of objects, showing layers, firing other actions, but none of them could intercept the process before the jump long enough for focus to be lost. Those that did completely stopped the jump and needed another action (like the Next button) to effect a jump. Looking at the design, I'm pretty sure you don't want to have to put a Next button on the slides.  If you have to go that route, the Submit and Continue buttons you are using would fit the theme, and would work,

So I'm afraid all I can do is to identify the problem. The only solution I have is that there needs some way to get the learner to tab, or click something.

Tara Muir

Hi Walt, 

Actually it's looking like a possible bug with the latest version of SL360. Because all of these variables did work without any of the experiences/interactions/racing that you are mentioning. 

Leslie M (above) opened a support case and they have replied to me that;

"After reviewing your file, I was able to replicate the same issue you're encountering even on the new file I've tested.

It seems like the Text Entry variable reference is not showing when the Text entry key is expanded, and the Enter key is used to submit the interaction.

The issue is happening in the last two versions of Storyline 360 - (3.37.21614.0 and 3.36.21289.0), and working in the previous version 3.35.21017.0.

I’ve logged it as a possible software bug."

Which would also explain why the variables work for my co-worker and not for me. So, will wait and see.




Walt Hamilton


Thanks for sharing that here.

This comment is intended for tech support, rather than you. If they are serious about fixing this, they need to look at it as a timing issue. Reading the comment,

"It seems like the Text Entry variable reference is not showing when the Text entry key is expanded, and the Enter key is used to submit the interaction."

makes it seem as if they think the variable is being populated, but not displayed.  A quick test '(change state of object if variable = blank' on the next slide) shows that is not the case; the variable never receives a value.

Priyanka Rastogi

Hi, I am facing a similar issue with the latest version of SL. Looks like the bug still needs fixing. It was never the case in the earlier versions that I worked with.

As soon the user presses the 'Enter' key after keying in their name in the text variable box, the variable does not get populated..

The support did help me with it yesterday (probably hard coding it) and shared the modified file with me, but I still can't replicate the same at my end in spite of the umpteen trials.