Videos wont play automatically

I have several scenes in a story that the user clicks an icon and a layer is shown.  On the layer is a video that is set to play automatically.  But the videos require the user to click to play rather than starting automatically.  As I have no user controls showing there is no why they know to do this.

How can I get the video to play automatically when the layer is revealed?

I am publishing for web and the videos are in MP4 format.

27 Replies
Martin Dean

I too have this problem.

The video is set to play automatically in a layer and behaves correctly in PREVIEW mode, however, when published and deployed to the web; does not.

I discovered that by shifting the video along the layer timeline by 1sec (with AUTOMATICALLY PLAY still selected) rectified the problem.  

Perhaps this gives it 'time to think' - seems to work whatever the reason

Cheryl Vercoe

Hi Ashley,

I am using Storyline 360 and IE 11. I did find a solution for my problem though, which was that my MP4 videos weren't playing in my Storyline in IE. They played in Chrome perfectly, but IE was unable to play them all. Basically, after a troubleshooting many different avenues, I found that by publishing to Flash with HTML fallback, all of my videos played. Due to the fact that everyone in my organisation uses IE, I had to find a solution as our LMS and all integrated systems are tied to IE.

Flash setting

(My Storyline contains 20 short videos on slide layers. Initially, only half of them played whilst the others just had a black screen with no audio. I tried renaming and replacing all of the videos, moving the videos away from the start of the timeline, adding triggers to play media at start of timeline, Publishing to Web, CD, LMS, etc. As the videos are all MP4s, I considered converting them to a different format but that would have taken more time and would have expanded the size of the video files.)

If anyone is experiencing the same issues, I would recommend publishing to Flash with HTML  fallback as part of their testing. Another thing to check if using IE is making sure that the ActiveX filtering is turned off.

Thanks for getting back to me. :)

Martin Dean

Hi Everyone - this is Martin.

I seem to remember that although I had set 'PLAY AUTOMATICALLY' on a video in a layer, it did not behave correctly.  I did move the video to start at the 1s point on the timeline and that seemed to rectify the problem.

My guess is that the layer is opening and the PLAY AUTO command is being sent before the video is loaded.  The delay seemed to give the layer the chance to sort itself out then the auto play worked. 

This was a while ago now so I cannot really remember which project this was.  Am happy to try to re-create the problem and the solution.

 

Rais Omar

Hi everyone,

I'd like to share what I've done. 

http://raisavenue.com/demo/ravtest02-SL2/story_html5.html (SL2)

http://raisavenue.com/demo/ravtest01/story_html5.html (SL3)

Total of 4 videos on a slide - 1 on main and 3 on layers. Each video layer plays automatically at start of the timeline.

Normally, for html5 versions, when you hit the replay button, all 4 videos will play - video and audio overlap.

I've managed to create a workaround. I'm still testing this. So any feedback is greatly appreciated.

Thank you.

Sean Jackson

Hi Ashley,

I am having a problem with my Vyond created video playing on my first slide in Articulate Review (timeline moves - but video isn't playing).  I have moved it out 1 second, I have added a trigger...I am stumped.  I am using Storyline 360, publishing to HTML5.  Once I jump to the next slide and return, it then will play.  Any ideas?

Martin Dean

Hi Russ
I just tried inserting three different Vyond videos into a new file and they all worked perfectly (Play Media |Timeline starts)

I presume you are inserting the media from a file and not playing it in from Vyond (or Beyond!)?

Does this happen with other Vyond videos (I would try making another really quick one and seeing if it is that.)

Sorry not to have better news.

M

Kim Rushbrooke

I have said it once, and I will continue saying it again and again.  The articulate community are awesome.  I was having issues with a (mp4) video not automatically playing in the LMS.  Came to this page and noted a fix.  Did the fix, deployed the package to the LMS again -- works a treat.  Thank you very much everyone.  You make me look good.

Kim

Brent Robison

I just started using Articulate 3. I'm on Chrome 73 and have tried the 3 HTML5 publishing options. After publishing, neither video nor audio will play automatically when a slide timeline starts. I have tried adding 1 or 2 seconds before the media begins, and I've tried adding a player trigger to force the start. I've had to revert to Articulate 2 and start over on a couple of video-based courses. But on another course that is not possible. On this one there is no video but the audio won't play until the second time the slide is played. I don't have time for this. Can anyone help?