When I preview my project it works as designed. After publishing it to mp4 format it doesn't play past what would be the first slide.

Feb 07, 2022

I hope someone can assist me with this. I want to create a short video clip without interactivity. The first time I tried making the course, I had multiple layers on a slide. When previewing it worked as designed. But after formatting it to video, it stopped after the first layer.

So, I took all the layers and made them on separate slides. Again, it plays correctly in preview mode, especially when I choose 'Entire project', but not after publishing. The timeline seems to run for the duration, but it doesn't advance to what would be on the next slide.

Thank you,


6 Replies
Maria Costa-Stienstra

Hi, Teena.

Thank you for reaching out!

If you designed the project without interactive features, it should work as expected when published to mp4. 

Since this is not your experience, would you be able to share your file either publicly here or privately through a support case so we can take a closer look at what's going on and help you troubleshoot?

Maria Costa-Stienstra

Hi, Teena. 

Thank you for sharing your .story file!

I experienced the same behavior as you described when exporting to video, so I went ahead and opened a support case with our engineers so we can investigate this further. You'll receive an e-mail from our team soon!

As for the text-to-speech feature, I'm not aware of any current plans to update it, but you're welcome to submit a feature request to our team through this link.

Thaddeus Ashcliffe

Be careful of timing when exporting as video.  You can't rely on user interaction to advance.  I once accidentally wanted some looping for a simple animation.  What I got was a never ending loop that I only caught when I noticed that it was still rendering an ever longer video for what should have been a 20 second animation.