Error uploading Rise course to SABA

Hi - I have a client that uses SABA cloud, and they can't upload one of my courses. They get an error stating "Invalid content. Invalid manifest XML. Forward slash, Ampersand, left angle bracket or  space in beginning or end in the identifier is not permitted." I looked in manifest XML, and don't see any of those characters. They do report that they've been able to upload a Rise course before.

Any ideas on how to resolve? I tried republishing, and that didn't work.

Thanks, Steve.error message

16 Replies
Crystal Horn

Hi there, Steve. Do you know if there are any PDFs or other assets that have symbols in the file name? We recently released a fix for an issue we had with file names, but you may need to remove and re-attach the file if you added it prior to the fix.

Let me know what you think! We can also have a closer look at the output if you share it privately with us here.

Steve Jones

Heard back from my client. They found a file that had name starting with a symbol (-).   This is a file name assigned by Articulate Rise when I publish the course. The client changed the file name to remove the symbol and was able to upload it to their SABA LMS successfully. 

Is there a way to prevent Rise from assigning file names that start with a symbol?
Is there a way to find all the instances of a file name in all the output created when publishing in Rise?

Crystal Horn

Thanks for the follow-up, Steve. We found an indication that some LMS servers won't accept that symbol as the first name of a file. I'm going to meet with our team to see how we can improve the file encoding during the publishing process to avoid this issue. I don't expect an immediate change, but we'll keep you posted.

If you suspect this issue in other output, you can unzip and open the output folder, and look in the scormcontent > assets folder. I arrange the files in that folder by name so that any files that start with symbols will be listed first. The assets will also be listed in the lmsmanifest.xml.

I'm sorry the file naming caused this issue for you!

TJ Dziedzinski

I know this is an older post but it helped me. I am testing a new Rise course and I am finding that it is randomly naming assets with dashes as the first character still. Saba obviously doesn't like this and will throw an error when uploading it. I can get around it by changing the filename in the manifest and the asset folder but now I am dealing with those files being broken links or images. Not sure where else I need to change the filenames.

Based on this post it seems like your encoding was updated to address this. Has something changed or is this a new issue?

Evelyn Jackson

Hi Crystal - our client also has a SABA LMS and we are getting the same error message

 

Could I please share here as I am really unclear of how to edit the unzipped files (if that's what I need to do) - we ave multiple versions of this module in 5 different languages so I need to get it sorted and understand what I need to do for each one...many thanks

Chino Navarro

Hi, everyone.

I have some great news to share!

We just released the fix for the issue about being unable to upload a Rise 360 SCORM package into an LMS when an asset file has a symbol in its filename.

Since Rise 360 is a web app, there's nothing to install! New features and fixes are available immediately.

Please let us know if you have any questions by posting here or by reaching out to our Support Engineers directly.