RISE: Cannot embed video from Media Platform

I have an issue with embedding video from our corporate video repository, Media Platform. It does not let you play it inline, it only lets you click to open a new window.

I have a quick screencast of the issue, here: 
https://mfrm.box.com/s/w3ku0ljqd8p3c5tjcz0dudrypk1rj7tz

I've raised the question with Media Platform support, but was wondering if this is something you guys understood why was happening, and could help. 

Thank you!

24 Replies
Mike Olivieri

Hi Rebecca,

The reason this does not currently work is because Rise can only embed URLs from certain media hosting sites (full list here). We are currently working on a solution for your problem, which will allow you to use the full iframe embed code and play any content in Rise. You can expect this very soon. We'll keep you updated. 

Lee Millard

Michael and Rebecca,

I am having the same issue as well. I went to the site you posted and I see Kaltura is listed as one of the media hosting sites. I've tried multiple embed options. So far, Iframe is  the one that at least gets me to the same spot Rebecca got to, but I need to click on the text for the video to pop up in a new window. Any suggestions Michael? Thanks!

Mike Olivieri

Hi Lee,

Is your video hosted on the kaltura.com domain and publicly available?  If so, you should be able to enter the URL in a Rise Embed Lesson. Here's a screenshot of a that case - http://drops.articulate.com/mGtv/1srgtaS6

If you could provide the link to the video I can take a closer look. 

Lee Millard

Thanks Michael for taking a look!

We have an account with Kaltura. I believe I checked the correct settings to make this URL accessible publicly. This is the tiny URL Kaltura generates for the custom player. Let me know if I need  to grab the URL from a different spot. Thanks!

https://www.kaltura.com/tiny/u180o

Christoph Krieger

I can share a demo video.

I could manage to embed now but it opens in a new window when i click on the video.

Embed as iframe opens new window:

<div style="position:relative; padding-bottom:56.25%; overflow:hidden;"><iframe src="//content.jwplatform.com/players/1sLVC7VE-m1Y0RljD.html" width="100%" height="100%" frameborder="0" scrolling="auto" allowfullscreen style="position:absolute;"></iframe></div>

 

Embed with script does not work:

<script src="//content.jwplatform.com/players/1sLVC7VE-m1Y0RljD.js"></script>

Ashley Terwilliger-Pollard

Hi Christoph,

We shipped a fix this weekend Rise for the issues folks were having with how the embed code may not be respected for the iFrame element - so you should be ok with your code now in Rise if you were to use the follow:

<iframe src="//content.jwplatform.com/players/1sLVC7VE-m1Y0RljD.html" frameborder="0" scrolling="auto" allowfullscreen style="position:absolute;"></iframe> 

And then that cute kitten will appear. :) 

Let us know if you have any other questions!