XLIF translation did not import in Articulate Rise

Nov 21, 2018

We followed the instruction on how to import translations found in "https://community.articulate.com/articles/rise-translate-your-course".
Steps we followed is as follows:

a) Duplicate the course in Rise;

b) Go to Settings in Rise > Export XLIF File;

c)  Open the Exported XLIF file in Notepad++ (Text Editor);

d) Open provided translated XLIF file in Notepad++ and copy all content to the exported English XLIF version.

e) Then we go back to the Settings in Rise and import the translations back.

However "Import failed: Translation file doesn't match this course." appears after importing.

Below is a sample clip of xlif translations provided.

<xliff xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="urn:oasis:names:tc:xliff:document:1.2 http://docs.oasis-open.org/xliff/v1.2/os/xliff-core-1.2-strict.xsd" xmlns="urn:oasis:names:tc:xliff:document:1.2" xmlns:xhtml="http://www.w3.org/1999/xhtml" version="1.2">
<file original="course" datatype="plaintext" source-language="en-US" target-language="es-us">
<trans-unit id="title">
<source>English text</source><target>Texto en inglés</target>
<trans-unit id="description">
<g id="zzu2BdVk7k5pDG92" ctype="x-html-p">This quick course will introduce you to the topic number one.</g>
<g id="zzu2BdVk7k5pDG92" ctype="x-html-p">Este curso rápido le presentará el tema número uno.</g>


Please advise on the correct way of importing translations back to Rise? Are there demo videos available to follow that you can provide? Or did we missed anything?

34 Replies
Crystal Horn

Hello, Tejas. I tested exporting an XLIFF from a course, making a small change to the course title, and then importing the translated XLIFF back into the course. It accepted my translated XLIFF.

To be clear, you'll need to export the XLIFF from each duplicate of the course. XLIFF files must be uploaded back into the course from which they came. When you make a duplicate, the IDs will change for the XLIFF.

I hope this helps!

Juan Jose Gracia Roche

Hi all,

I have been able to successfully translate XLIFF files in the past (last month) but today I am not able to import back any translations.

I have even tried to:

1. Duplicate

2. Export XLIFF

3. Import the same XLIFF with NO changes

But I am always receiving the "Import Failed" message.

Has anything changed in the past few weeks?

Thanks in advance and best regards,

Lea Agato

Hi, Juan Jose! I'm sorry to hear you're seeing this issue with your Rise course translations. I tried the steps you followed, and I didn't encounter an "Import Failed" message. Can you confirm if this happens every time you try to import translation file for any of your courses? Also, have you tried using a different browser when translation your Rise course?

Christopher Santos

Hi Chris,

When you export an XLIFF file, it will contain a tag called <source>.  This will contain the text in the original language.  After being processed by a machine translator, it will also include a <target> tag that will contain the text in the translated language (as shown below):


If you only have the <source> tag and edited the text to the target language, you can still import the XLIFF file successfully back to Rise, but nothing will change.

It's possible to manually create the translated file that will contain the target language.  But you'll need to be familiar with all the tags involved (not just the <source> and <target> tag pairs).  For best results, it will be best to use translation software.

This sounds like what is happening based on your description.  If not, can you open a ticket with us and include a copy of the exported XLIFF file and the file you are trying to import?  We'll investigate your issue and delete your file as soon as we are done.