Answer choice always goes to hover state in review mode

Aug 17, 2022

We're having an problem with a multiple choice question when the learner is finished with the course and reviewing their answers. For some reason in the first question, no matter what answer you choose, in review mode answer D is changing states to hover. We've gathered that it happens when the user hovers over the answer choice for a few seconds, it appears that if it's scrolled over quickly the issue doesn't appear. We've been able to recreate the issue with answer choice B but have seen most consistent issues with answer choice D.

This interaction uses the Storyline graded multiple choice template so there are not unnecessary triggers or layers built into the slide, it also leaves us with few options or ideas of things to try to fix the issue since most of the work is being done within the software. We have tried the following to no avail:

  • rebuilding the question as a freeform pick one question
  • taking off the fade in animation from the answer choices
  • separating the introductory content of the slide from the question itself
  • deleting the hover states of each answer choice and creating new ones
  • duplicating the slide and deleting the original
  • putting a blocker on answer choice D that is triggered to hide when the user hovers over the other answer choices (this worked but is very clunky and definitely not an ideal solution, we were also still able to cause the same behavior to happen to answer choice D when employing this idea)

Beyond this we are at a loss of what to try, we may attempt just building it again from scratch but are concerned that if we cannot get to the root of the issue it may just appear again in another question slide. It seems like there is something wrong within the code, but again, we cannot access that.

Has anyone dealt with an issue like this? And if so, have you come to a good solution?

The affected slide is 1.11 which is called "Assessment" in the attached file.

9 Replies
Jose Tansengco

Hi Emily,

Sorry to hear that you ran into this snag. I was able to replicate the behavior on my end as well after completing the assessment and reviewing your quiz.

I went ahead and created a support case on your behalf so our support engineers can take a closer look at what's happening. Your case is in good hands, and someone will be reaching out to you shortly! 

Jose Tansengco

Hello Kali,

Sorry to hear that you ran into this issue. We've identified a bug that causes the hover state of an answer choice that is activated to get stuck when in quiz review mode or when revisiting the slide. We'll let everyone subscribed to this thread know as soon as a fix is released for the bug. 

A workaround that we've identified is to avoid placing the review button on the same level as the answer choices. If you're willing to share a copy of your project file here or in private by opening a support case, we'll be glad to test the workaround on your project file and share the edited project file with you. We'll delete it after we're done testing! 


Adam McLean

I have experienced this issue as well. This seems to occur when the button that activates the quiz review is in the same position as one of the answer choices on the first question. Before the quiz review layer is shown, there is a split second where the mouse pointer triggers the hover state. I worked around this by placing a hotspot (with hand cursor turned off) over all the answer choices and setting it to .25 seconds in the timeline. This blocks the hover state from being triggered, and it is so short that it's not noticeable to the user when taking the quiz. It may not work in every application, but it worked for me while we await a bug fix.