Articulate 360 Couldn't load issue

Hello everyone,

Most of the users are facing error like articulate 360 login issue. articulate 360 giving "Couldn't load, there was a problem connecting to Articulate 360. Please check your internet connection and try again." error. Due to this error, so many users are unable to login to their account.

I also faced this kind of issue. But, I resolved this by doing some RND. If you face this problem, please try the below solutions. Maybe it will helpful to you.


1. Download and install an updated articulate 360 app.
2. Reset your internet connection. Disconnect the internet and connect again.
3. If you are using a mobile network, restart your phone and connect again.

Above scenarios are helped me to resolve this issue. Please reply here if it is also worked for you. So that, many users will try this.

11 Replies
Leslie McKerchie

Hi Karthikprasad,

Thanks for contacting us and sharing that you're running into a similar issue. I see that you worked with our support team back in May, but we did not hear back from you. 

  • Were you able to get up and running then?
  • What is the specific error that you're experiencing?
    • Are you able to log in via 360.articulate.com
    • Are you able to login to the Desktop Applications?
    • What error are you seeing?
Katie Riggio

Hi Anil,

Thanks for writing in!

Referencing Karthikprasad's scenario, our team recommended using a different network connection and checking the affected computer's Windows profile.

Since you already tried a different network, this is a great opportunity for our Engineers to step in! I opened a support case on your behalf, so an email should be in your inbox.

See you there!

Rob Brownfield

I am facing this issue today. 
The company I work for have remotely installed the software and at first I got a "Installing Articulate 360, please wait". The progress bar sat at 0 for 20 minutes or so.
I now get the "problem connecting to....." message.
I have an Articulate account, I can log onto Articulate.com, I can open Rise and Review from the dashboard, but when trying to open Storyline, I am told to log-in (already logged-in) and it takes me to the "Couldn't Load" screen.
I cannot download the Desktop App direct due to security policies for the company I work for, it has to be done remotely.