Can no longer turn the video compression off with new Storyline 3 update...

I recently uploaded the most recent Storyline 3 updates. My published projects are now playing better within the browsers. However, now the customization setting is defauted to 'automatic'. In the past, I had to set this setting to 'none' because my videos would have a better quality when played within their published HTML5 format. Although I understand that Storyline does not like for people to control this setting, it is very inconvenient for it to still be there and for me to not have the option to turn it off. My videos have already been compressed prior to inserting them into my project. Compressing them again causes them to appear grainy and unfocuses. Please help!

44 Replies
Stephanie Curry

Well, it's been a couple of years and it's still not fixed.... Still a problem for me too. The funny thing is I can take the same video into a new SL file and it wont be compressed. One time I was even able to import these slides with uncompressed videos from the new SL into the existing one and it worked. But, that same technique is no longer working. So, I guess I'm suppose to import all of the slide from the old one, into the new one and hope for the best. It doesn't appear to have anything to do with codecs, because logic would say that if that were the case it would NEVER have allowed you to not to compress the video. And this isn't the case. So, not sure what the bug is, but yeah...It's frustrating. I would love to see this fixed as well. Hope you find a work around. Would be curious what creative solution you find to make this work. 

John Wylie

It is sad , and very frustrating that it has not been fixed. I have had to rebuild so many projects due to this , and there is no rhyme or reason as to when it will or won't allow you to no apply compression. Come on Articulate , can you at least make the default to not compress videos on slides ? I was looking forward to 'bending their ear' about it at the DevLearn Expo this year , but that does not look feasible. :(

Leslie McKerchie

Hi Stephanie and John,

We do still have an open issue specific to the compression field becoming disabled when replacing a video via Edit Video > Change Video option. Is this what you are experiencing as well?

If not, please share your video file and/or .story file so that we can take a look. With your permission, you can share it privately by uploading it here. It will be deleted when troubleshooting is complete.

In addition, John, you can always bend our ear right with your ideas and suggestions.

Sharon Bildstein

For me, it happens EVERY time if I select the video and right click and select the "replace" option...the new video will then have compression option greyed out.  My workaround is that I can delete the video from the slide and reinsert the new/updated video and compression option is enabled so I can select None.  I thought the new video had to have a different name, but that's not actually the case.  The downside to my workaround is I have to then re-associate any related triggers.  But this workaround consistently works.

Domenick Chiddo

New user of Storyline 360 here. I just had the same problem described in this thread.

I had replaced a video on one of my slides with a new version that had been re-edited in another program (I right clicked on the video object in Storyline and selected the option to replace the video). The updated version of the video in Storyline would not allow me to leave it uncompressed as the original video had been. The issue was not caused by the type of MP4 compression as mentioned above (baseline, main, high) -- the new version of the video used the same compression type as the original -- nor was it edited inside of Storyline.

I tried deleting the video and reuploading it, but that did not work (once Storyline recognized that it was the same video as before, it automatically compressed it and would not let me uncompress it). The solution that worked, which I got from this thread, was the following:

(1) Delete the video, save the file, and close the file.

(2) Then, open a blank file and upload the re-edited video into the blank file. Select the "none" option to leave it uncompressed.

(3) Finally, open up the original file, copy the video object from the blank file, and paste it into the original file.

Hopefully this solution works for others.

William Hach

My video is x264, Main and compressed with HandBrake.  I have tried all of these work arounds (deleting video and re-importing, importing into a new file, etc.) and it STILL has compression grayed out.  Video looks great before inserting into Storyline 360 - looks like crap after inserting into Storyline.  The only question I have, besides when is this going to be fixed, is where are the TEMP files that should be deleted?  I have deleted My Articulate Projects files but still no help. I need to publish 9 courses with these videos ASAP!  Someone please help!!!

Lauren Connelly

Hi Carl!

I'd like our Support Engineers to troubleshoot this issue with you! Since our Support team is available 24/7, submitting a case is the quickest way to find help. Please use the link below to upload your project. We'll let you know as soon as we receive the file and will reply with our findings.

Sharon Bildstein

I recently just finished a project with SL and a lot of little Vyond videos.  I didn't have this problem at all when I follow this process:  Don't "replace" a video, delete it and then insert the new video.  Each time I was then able to turn compression off, no problem except the need to repoint triggers to the new video.  But if out of habit I accidently forgot and "replaced" the video, I would then have to copy all objects to a new slide (not duplicate the slide) and insert new video, then I could turn off compression.  So in my mind, it's utilizing the "replace" feature that greys out access to the compression controls.

Yesenia Arroyo

I've had this issue for over a year sporadically and seemingly without reason like many on here, but I use Camtasia to produce my videos so thought I'd share what just worked for me after struggling for the past 2 days to get this done. 

Storyline 3 File: 

  • My course has a story size of 720 X 405

Original Video (Showing compression error): 

  • Camtasia settings when publishing show the following: 
    • MP4 file
    • Embed Size: 852 X 480 
    • Video Size: 1280 X 720
    • H.264 profile: Baseline

New Video (Without compression error): 

  • Camtasia settings when publishing show the following:
    • MP4 file
    • Embed Size: 720 X 406
    • Video Size: 1280 X 720
    • H.264 profile: Main

After republishing the video with the new settings all I did was remove the original video file that wouldn't let me adjust compression and imported the new file and I was immediately able to change compression from "Automatic" to "None". 

I don't have any true understanding as to why this worked as I'm used to using default settings when I publish. My theory is that the embed size was larger than the Story size which is why it wouldn't let me get by without compressing. 

Hope this helps anyone using Camtasia. I'd be curious to know if changing publishing settings like embed size to match story size works for anyone else using other programs. 

Ashley Terwilliger-Pollard

Thanks, Yesenia for sharing those details. I'm glad to hear it resolves the situation for you and I hope it helps others.

Our team continues to investigate an earlier issue reported here where the video compression setting disappears when you edit a video by swapping for a new one. We'll keep folks posted on the status of that as we have updates! 

Robert Turchick

the course I am working on has 49 videos totalling 3 hours!!! I compressed in Media Encoder  to a reasonable rate and was able to turn off automatic compression in SL but the total course is 8gb. I need to get it under 5gb for Review 360 which my team uses. SO I tried shrinking them by ONLY adjusting the bitrate off the original preset I used in Media Encoder, and now I can't turn off compression in SL. I tried replacing the original file, deleting the original as well as creating a new slide. I tried restarting the program as well as restarting the computer. Viewing properties on the files the ONLY difference is 6kbps/sec vs 2.5kbps. This is quite ridiculous after how many people have complained. Really wish you would come up with a detailed working specification for video compression other than "Main, Baseline, High" which is one of a dozen settings used to determine video compression. BTW, mine are High...which according to your specs should work!

Domenick Chiddo

I'm circling back to this thread a year later because the problem still has not been fixed in Storyline. I recently exported a course, and as I was reviewing it, I saw that all the videos were blurry. Immediately, I knew what was wrong: I had forgotten to change the default video compression setting from Automatic to None for each video in the course. When I went back to Storyline to edit the settings, I saw that the Compression drop-down menus were grayed out. Basically, once Storyline compresses the videos, it is does not allow you to restore them to their uncompressed format. I tried deleting the videos and replacing them, as mentioned in my previous post, but that work-around no longer works. Storyline recognizes the videos from before and automatically compresses them, even if you change the video file names and try to insert the renamed videos into Storyline. 

I did find another work-around this time. I put the video files into Adobe Premiere Pro and re-exported them as new files. Then, Storyline allowed me to insert the new videos without compression because it didn't recognize the re-exported files. This process was a huge pain and took a lot of time, especially because I had the videos edited into a montage in Storyline, so I had to redo the timing of the videos in the timeline. But this work-around might be the best option.

So, there are two issues that Articulate should address: 

1) There should be more video compression options in Storyline. The automatic compression option is essentially unusable because the videos become blurry. I imagine that Articulate makes this option the default in order to conserve their server space by reducing file size. However, because the resolution becomes so low with automatic compression, the uncompressed option is the only feasible one. If Articulate added some happy medium options between hi-res and and low-res, they would get more people to use compression and would actually save more server space. Also, automatic compression should not be the default option since it seems to be a "destructive" edit that does not allow the user to restore the unedited video.

2) The bigger issue is that Storyline locks each video into a low-res compression when a course is exported. Forcing users to find work-around solutions to fix their videos after this irreversible compression adds hours of work and rebuilding. 

I hope Articulate can fix this issue soon!

Thank you.

Matthew Boakye

I was facing the same video compression issue but this is how I manage to resolve it.

The process is very tedious but I got what I was looking for. 

My final project needed to be a SCORM file as I was going to host it on a LMS. After publishing the project, I went into the source file. You could ZIP it and extract it into a folder as well.


Step two.
Inside the the source file, I went into the content where all the media (videos, picture and audio are saved) I have to painful allocate all the video files and replaced them with the original videos on my PC.

Note: You have to maintain the names of how articulate saved the files.


Step 3.
You can now ZIP the folder containing the source file and then host it on your LMS. 


Ryan Brown

I have found this to be inconvenient for a while and finally did some real digging.

In Camtasia I was publishing to Base and it was not working. My embed size in Camtasia was smaller but my video size was bigger than the story size.

I followed some of the tips in Yesenia's post including:

1.) Make sure embed size is smaller than storyline size

2.) Make sure video size was not larger than storyline size (I set it to be equal to)

3.) Published as Main in Camtasia

This combination of changes 1, 2, and 3 allowed the infamous Compression drop down to un-grey and let me change it to None

Charlotte Bibby

I am also hitting the 'replace video' bug where it doesn't allow you to change the video compression... super frustrating. Yes, my videos are all exported with the 'Main' profile.

Fastest workaround I've come up with so far:

1. Import the video from file as a NEW video into the slide.
2. Delete the new video you just inserted.
3. Now use the 'Replace video' functionality and this time it will allow you to change the compression setting to 'None'.

This means you can maintain all the triggers, animations, timings, etc. without having to recreate them all over again.

My guess is that it's only reading the file settings correctly when you import the file using the new video option, but then caches them so they're available for the replace video function to work correctly afterwards.