68 Replies
Crystal Horn

Hi there, Cristina. I'm seeing that using the play/pause button on the seekbar does not make the captions disappear. I noticed that clicking directly on the seekbar, however, did make the captions disappear. Here's a short screencast of what I mean.

Does this match what you're seeing? I'm going to document this behavior so we can investigate a more consistent experience whether using the play button or clicking on the seekbar.

cristina eleuteri

Hi

No, my problem is always that caption disappear when timeline is paused, as it happens since the July update was made (if I'm not wrong).

So I have to work with an outdated version to see what I want and I attach to you (made with Storyline_Perpetual_Release_3.3.15007.0 kindly sent by your staff in September 2018).

I don't want have visible seekbar and I had  the right way to obtain!..then there was an update and all has changed.

 

Leslie McKerchie

Hi Cristina,

Thanks for explaining what you are seeing in your course with the video to demonstrate.

I created a similar example and my closed captions are staying in place just like you've displayed:

With your permission, I'd like to take a look at your project file to investigate what's happening. You can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.

cristina eleuteri

Hi Leslie,

thanks for your interest. I have to keep working and producing scorm these days and I can't risk re-installing a version that doesn't get me what I want.

yesterday I uninstalled the version with the latest update and re-installed Storyline_Perpetual_Release_3.3.15007.0
As soon as I can stop working with this old version (it works very well) I run the update again and send you the file.

Thank you

cristina eleuteri

I'm ready and I send you my story. 

I finally understood! The problem is the custom red button I use to pause the video! Now I know that if I delete it the captions work correctly. Too bad though, because in the old upgrade a few months ago the button worked perfectly.
I'd like to know why.

I send my file privately by uploading where you wrote in last mail.

Thank you

Crystal Horn

To update this discussion: 

We have an issue where opening a layer that is set to pause the timeline of the base layer will also hide the captions. If base layer objects (like a video with CC) are not set to hidden on the slide layer, the captions should continue to display. They are not, however.

I've documented this behavior so we can investigate a fix. Thank you, Cristina, for pointing it out!

Vincent Scoma

Hi Christian,

Thank you for reaching out and sharing what you are experiencing! I am sorry that you are running into this snag. I do want to mention that the issue was resolved in Update 22 for Storyline 360. Since you are on the latest update, if you can share your file with me, I am more than happy to help! 

You can share files in this thread using the Add Attachment button, or you're always welcome to share the file privately here. We'll let you know our findings and will delete it after having a closer look! 

Ren Gomez

Hi Bobby,

I'm sorry to hear you're experiencing this issue! It looks like we have a bug reported for both Storyline 360 and Storyline 3 where:

Clicking on the seekbar when paused makes captions disappear.

It is currently in the early stages of review based on our How We Tackle Bugs article. To help you plan, it's unlikely to be fixed in the next couple of updates, but I'll be sure to jump back in here with any updates.

bobby garcia

Thanks for the response, Ren. However, just to clarify, I'm not having an issue when pausing and clicking seekbar - that seems to be fine. It's when I click the seekbar AFTER the slide reaches the end of the timeline; pressing Play again does not show the captions. I suppose it might not be an actual "bug" as I can click the Replay button at the end of the timeline and it operates fine. Just pointing out an instance that I came across. Thanks again!

Lauren Connelly

Hello bobby!

Thank you for sharing these extra details! I've tested this on my end and I'm still seeing the captions when using the Play button and the Replay button on the seek bar.

Here's what it looks like on my end:

Are you using any triggers or variables that determine the behavior of the captions? I can see where triggers and variables might be the issue. Let me know if you want me to take a look at the slide with the video and captions on it. 

bobby garcia

Thanks for the video, Lauren. No, I'm not using any triggers or variables that impact the captions. Here's a video to show what I'm getting.

As you can see, I turn the captions on and it plays fine. At the end of the slide, clicking PLAY does nothing, I have to click on the seek bar then press PLAY... but I lose the captions. Clicking REPLAY does the trick, but I also found that if I click the seek bar and press play ,then I lose the captions, dragging the seek bar to the beginning brings the captions back.

Lauren Connelly

Hello bobby! 

Thank you for sharing the video! From the video, it looks like maybe the seekbar is causing the inconsistencies. I want to bring in our Support Engineers so that we can continue troubleshooting. Do you mind uploading your project to us? Here's a secure upload link. We'll notify you as soon as we receive your file.

bobby garcia

Apologies for the delay in response. My team decided to simply move forward with what we have and we've been doing so. The crazy thing is, less than a couple of months later, it started working as intended - when the slide ends, I can click anywhere in the scrubbar, press play and the captions show correctly. Thanks for your time and efforts.