Missing Fonts (according to Storyline) but Fonts Exist in System

When opening my colleague's Storyline file, I get a message box (attached) telling me that the fonts listed are not installed on my PC.  They are.  I can see them in my fonts list and they are also in my Fonts folder.  Once in Storyline, I can even select the font claimed to be missing from the Fonts menu. The problem is that it does not render it consistently or correctly.  Is this a common problem and is there an easy solution?

91 Replies
Ashley Terwilliger

Hi P, 

Have you tried in a brand new file? I'm wondering if there is a lingering element in that older file? You could also look at importing the existing file into a new .story file to see it that resolves the odd behavior. 

Also, Looks like your email signature came through when you replied via email! No worries, this Peek video will show you how to remove it. 

Ashley Terwilliger

Hi Dejan,

Are the fonts truly missing? If so, that error message is doing it's job!

If you can clearly see the fonts - I imagine "Aint nothing fancy" sticks out - and you're still getting that error message after updating to the latest Storyline 3 fix can you share a copy of your project (even just a couple random slides) and the font files? 

Dejan Batic

Hi Ashley,

 

Thank you for your comment.

 

I figured out what the issue was: the fonts got installed under slightly different names.

 

The font "Aint Nothing Fancy" became "DK Aint Nothing Fancy" and the font
"GoodDog" created two fonts: "GoodDog Cool" and "GoodDog Plain".

 

Problem solved.

 

Thanks.

 

Randall Sauchuck

I am seeing the same "missing fonts" issue.

I was recently forced to migrate a course I built in SL2 to SL3.

When I open the course in SL3 the dialog box shows that fonts that I know for a fact are installed as "missing". I can still open the SL2 version with no dialog. In SL3 these listed fonts still display normally onscreen and are available from the font selection drop down. However any attempt to preview the course replaces the "missing" fonts with gibberish characters.

Finally, if I publish the course the fonts appear as normal.

 

Ashley Terwilliger

Hi Randall,

The issue was fixed in the latest update of Storyline 3 as shown here in the version history.  When we experienced the issue before, it was only the pop up/prompt that folks saw and the fonts appeared normally on the screen, while previewing and in publish.

It sounds like you're seeing something a bit different if the text is garbled on preview - could you share a copy of your .story file with us? 

Randall Sauchuck

The problem seems to stem from the fact that I had both TrueType and OpenType versions of the conflicting fonts (Gotham). I uninstalled them and reinstalled 1 version (OpenType) which seems to have fixed it.
Still, it is annoying that the old version of the software can deal with this issue but the new one cannot.

Ashley Terwilliger

Hi Randall, 

First, I wanted to let you know that it looks like your email signature came through when you replied via email! No worries, this Peek video will show you how to remove it. 

As for the issue you're seeing - I do see another note about a specific issue with the Gotham font. Could you share a copy of your project file with our Support team so we can take a look at confirm if it's the same issue? You can upload it at this link.

Sjoerd de Vries

We still have this issue after migrating from SL2 to 3. In SL2 the font choosen was "CentraleSans Medium" and in SL3 it is looking for "Centrale Sans Medium".

When I look at the slides it has selected the text with the correct "CentraleSans Medium", so somewhere in the presentation there must be a wrong reference.

However, I published to MS Word to search for a missing font "Centrale Sans Medium" and it was not there. Didn't other users also indicate that the font name was spelled a bit differently (in this case with spaces)?

Sjoerd de Vries

Thank you Wendy, I could not find that and I search on the forum and got an answer that this was not possible. Might be useful to check this nice feature!

However, it becomes odd. I uninstalled SL3 and installed SL360 instead. Now I do not get messages of the missing font. The issue was that the message displayed it was missing "Centrale Sans Medium" while the font is "CentralSans Medium". So in Storyline it looks correct. Now the message is gone.

I noticed a reply that this was fixed in a new build, but I did not expect that the SL3 build is different from the SL360 build. It's ok if that is the case, but that might be something to mention.

Leslie McKerchie

Hi Sjoerd! The updates between Storyline 360 and Storyline 3 are not 1:1 nor are they on the same timeline, so this could happen for sure. 

The missing font error has been corrected in both versions though:

Storyline 360

Storyline 3

Now I'm curious if your software may not have been up-to-date after your findings/feedback here.

Kymberleigh Bray

Hi Ashley,

I've opened up my Storyline 360 projects this morning and ALL of them now display the error message to tell my my fonts are missing. If I ignore the message and proceed to the slides they are all completely out of whack. The titles and body text have all changed to a different font and my projects have hundreds of slides, so I'm panicking slightly!!!

Even if I do the 'find and replace fonts' I would need to go back over entire projects to ensure it's changed it all correctly. This would take hours and hours, and it's not a case of simply making this change as I've manually inserted different weights to some of my fonts etc.

I'm pulling my hair out, as the error tells me fonts are missing when I know they're not. I've checked again and again and I'm certain I do have the fonts installed.

I have the latest version of 360 and have no new updates available.

Can you please help!

Many thanks,

Kymberleigh