MP4s not playing in Storyline Course

I have a course with several videos in the slides. The course worked perfectly before the April SL release. Since then there are several (but not all) MP4 videos that will not play in the course once published. 

I have a ticket in with Articulate. They have not been able to offer any solutions. (I am unable to host and embed the videos as a workaround.)

Does anyone have any ideas on ways I can troubleshoot this? So far I've tried reinserting videos, and that didn't solve the problem. 

I need to find out what the non-playing videos have in common that is causing them to not play in Chrome. 

Any troubleshooting ideas would be greatly appreciated!

So far on my list would be to rename, reinsert as a different video format, and check to see if the file size is a common factor for the videos that won't play. 

28 Replies
Dawn Russ

Hi Traci,

Did you find a fix to this issue? I am experiencing the same thing. I have a package of modules, 2 that were published after the SL update. The MP4 videos in those two modules will not play. The videos in the 14 modules published previously play just fine.

 

Any suggestions are appreciated. Thanks, Dawn

Leslie McKerchie

Hey Dawn,

Not sure if Traci is still subscribed here, but it looks like she worked with our support team and found that uninstalling Quicktime was the solution that worked.

So, seems very specific to her environment.

  • What version of Storyline are you using?
  • How are you publishing and sharing your file?
  • Could you share your .story file for us to take a look?

If you cannot share your file here in the forums, you are welcome to share privately with our team here.

Dawn Russ

Hi Leslie, I installed the latest SL3 update and tested the module on the Articulate test server (HTML5/Flash setting)...successful. An internal project issue has delayed my ability to upload for test on my company servers, so I do not have a answer yet. I'll send another update after I can test on our servers. Thanks.

Katie (Gokhshteyn) Riggio

Yikes! So sorry you've also come across this problem, Colin.

In Dawn's case, it sounds like installing the latest version of Storyline 3 and testing in a different environment might have helped.

Mind if we have a close look at your Storyline 360 .story file to see how it behaves in SCORM Cloud? Additionally, are you experiencing this in all browsers or a particular one?

Katie (Gokhshteyn) Riggio

Hi, Colin. Yikes, that sounds like you might have reached the file upload limit on your account. 

No worries, as I can lend a hand! Could you share your unpublished file with me here? I don't believe the edition type would cause the video playback issue, but I'll give it a test in my SCORM Cloud account and let you know what I find! Feel free to either add the .story file as a comment by using the Add Attachment button in your reply or send it privately via this link!

Great question about the various formats, by the way! Here's a handy resource on the different versions of SCORM: https://scorm.com/scorm-explained/business-of-scorm/scorm-versions/

Katie (Gokhshteyn) Riggio

Good morning, Colin!

Confirming receipt. ✔️I just sent you some next steps in your case; we can continue our conversation there if you'd like! I'll also post any valuable insight here, as needed, for those following the discussion!

..and that's certainly excellent food for thought! Did you know: we have an entire guide dedicated for deciding to publish for Tin Can API. Additionally, the folks at Rustici Software offer their two cents here: https://xapi.com/why-adopt/ 

Hope that helps in the decision making process! I'll also let other community members talk about their experience with using this API and how it benefits them!

Craig Robinson

Videos also now not playing on ipads using Safari. These courses are located in Oracle's LMS. Republished dozens of training modules in July, and they were working correctly at that time, tested on both ipad and PC. These courses still work correctly in Google Chrome and Internet Edge on my PC.

Any ideas?

Ashley Terwilliger

Hi Teresa,

Thanks for sharing your file! I took a look and noticed a few things that are likely tripping you up. 

  • The video was not set to appear on the timeline of slide 2.1 until about 35 seconds in. I adjusted that to appear at 1 second (in the second version I shared below)
  • The video was also set to play when clicked and launch in a new window. That was working in the version of your course I tested in Edge and IE11 after uploading to SCORM Cloud. 
  • I did change it to start playing upon the slide starting and within the Storyline window. Take a look at that example here. 

Let me know if you can test out those two links - both were working normally on my end in IE11 and the second link works as expected on an iOS device. 

Ashley Terwilliger

Hi Craig,

What version of Storyline are you using to publish? I'd want to make sure you're on the latest version too - Storyline 2 Update 13, Storyline 3, build 3.5.16548.0 or Storyline 360, build 3.20.16814.0

Also, one other thing to note is that Apple no longer allows videos to autoplay by default in Safari 11, learners now see a play button when they launch or resume a course with a video on the first slide. Clicking the play button allows the video to play as expected. Learn more here.

Colin Farrellly

Hi, Just a few work around I was given,

I just ensured the video was fully insided the slide and it worked

- Set the slide size to default; 720x540 (4:3)

- Reduce the video width and ensure that it is less than the width of the slide size

- Adjust the video width size to about 998 or smaller

- Turn video compression off

 

Katie (Gokhshteyn) Riggio

Good morning, Craig!

Thanks for giving the suggestions Colin shared a try. Thanks, Colin! Those workarounds are for a reported issue where HD videos do not play when viewing content on IE11 on a Windows 7 PC in particular setups

Here's the link to share your project with us privately. We'll try to reproduce what you're seeing in a similar environment to yours and let you know what we find. Looking forward to helping!