Removing or Hiding the Previous/Next Buttons?

Hi There! I'm using Storyline to put together a (really cool) museum-style interaction that will play on a touch screen computer at a historical site! I'd like to essentially make the interaction play full screen at 1280X720, so I've gone in and set all of the player elements as transparent.  Here's my question: I have gotten rid of everything but the previous and next buttons- how do I turn these off?

Thanks!

105 Replies
e medina

Maneli B said:

Hi Steve, 

I've removed the Next and Prev buttons from the player and added my own custom navigation buttons. Now on question slides when I go back using my custom buttons the Prev/Next buttons appear on the player. Is there a way to hide those as well?

Thanks

I am having the same problem as Maneli. Is there currently a solution for this?
Christine Hendrickson

Welcome to E-Learning Heroes, E!

I just had a discussion yesterday with another community member about this. Are you using a custom "Submit" button on your question slides, or are you using the default player's "Submit" button? Try creating a custom button and disable the default one. When you submit and return to the question slide, the player navigational buttons should remain disabled.

If you have any trouble with this, let me know!

Thanks,

Christine

e medina

Hi Christine,

I am using a custom submit button in my question slides, I disabled the submit and Pre/Next button in each of the slide. The only way it keep the default Prev/Next button disabled when I go back is if I set each slide to "reset to initial state" but It is not a good solution to do this. 

Any idea why the prev/next button keep coming back? is that a bug or is there anything I can do?

Thanks

Christine Hendrickson

Hi E,

You're using a custom "Submit" button and they're still showing up? Do you have the default buttons enabled on any other slides in the course? If so, that may be what's happening.

Are you able to share the .STORY file here? I'd be happy to check it out and see what's happening.

Thanks!

Christine

Maneli Badakhshan

Phil, I agree with you. I wish there was a way to disable them. The review quiz is active in my project and I see the next and previous buttons when I am reviewing the quiz. 

The other thing is that I have a mastery test that has presentation slides spread out in between questions and while reviewing the quiz the next and previous buttons are displayed on all the question slides but not the presentation slides. So learner can't go back if she gets to any of the presentation slides during the review mode.

Steve Flowers

If I remember correctly, if you add custom prev / next buttons to your question slides and control the visibility with a variable, the built-in buttons do not appear since there's already a slide trigger on the slide.

1) Add custom back / next buttons (default to hidden) to your slides along with your submit (might be best to do this in the master slide for the questions)

2) Add a variable (inTest = true)

3) For each slide (or master) add a trigger to show the custom prev / next buttons if inTest=false.

4) Also add a trigger to hide the submit button if inTest=false;

5) On your results slide, set the inTest variable to false

This'll make your submit go away and the prev / next appear during the review. It should also suppress the appearance of built-in navigation, provided you have them unchecked in slide properties as well as the player.

Phil Mayor

Steve Flowers said:

If I remember correctly, if you add custom prev / next buttons to your question slides and control the visibility with a variable, the built-in buttons do not appear since there's already a slide trigger on the slide.

1) Add custom back / next buttons (default to hidden) to your slides along with your submit (might be best to do this in the master slide for the questions)

2) Add a variable (inTest = true)

3) For each slide (or master) add a trigger to show the custom prev / next buttons if inTest=false.

4) Also add a trigger to hide the submit button if inTest=false;

5) On your results slide, set the inTest variable to false

This'll make your submit go away and the prev / next appear during the review. It should also suppress the appearance of built-in navigation, provided you have them unchecked in slide properties as well as the player.


Thanks Steve, if that works I owe you a pint of your favourite poison

Ronny Salmeron

Hi Christine, 

I experiencing a very similar issue right now.

I am using a custom Submit button in my true/false, multiple choice, drag-and-drop etc questions slides (feedback in slide layers), I have disabled the defaults submit in each of the slide (I'm using custom Prev/Next buttons). The only way it keeps the default Submit disabled when I go back to revisit a responded question is if I set each slide to "reset to initial state" but It is not a good solution to do this. 

Any idea why the default Prev/Next buttons are coming back after revisiting the question slides? Additionally, the default Next button does not navigate to the correct logical slide - instead, it jumps to a random slide in a previous section of my project.

Seems to be a bug in Storyline, please help!

Ronny 

Ashley Terwilliger

Hi Ronny and welcome to Heroes!

Christine has taken another position within Articulate and doesn't get in the forums as often. Steve and Phil may be subscribed to this thread, but are you able to share your .story file here with us so that we can look at everything you have set up? If you'd prefer to share privately you can send it to our Support team here. 

Ashley Terwilliger

Hi Ronny,

I see that Jayem was able to reproduce the issue, and they're looking into a fix within Storyline. In the meantime, he suggested the following: To workaround this issue, make sure that all the built-in controls at the bottom of the player is disabled. So far, all of the controls on your project is disabled, except for slide 1.95 where the Previous button is still checked. Once you unchecked this and preview the project, it seems to work. 

If you have any other questions about this, feel free to reply to the email Jayem sent you and let us know if you need anything else!