States not changing when triggered - latest update?

Feb 01, 2018

Hi!

I am having trouble since the latest update of SL360. The states on my buttons are not changing when triggered. In one instance I have 3 text boxes changing states at 47 seconds. The states don't change at 47 seconds and the seekbar stops at that time but the audio continues. When I remove the trigger to change the states, the slide runs fine. 

In another instance, I have buttons on a menu changing states to "completed" when timeline starts, after the learner completes each section. The buttons are not changing states at all.

Thank you!
Brooke

15 Replies
Alyssa Gomez

Hi everyone!

There was an issue in a recent update with Storyline 360 with states that could cause some features to fail in HTML5 output. For example, slides might not load, hover states might not work, or drag-and-drop submit buttons might be unresponsive.

Yesterday, we released a fix for this issue in another update, and you can install that update by following these steps.

If you're still having trouble after updating to Build 3.12.14647.0, please share your file with us! You can attach it in a new thread comment or share it privately here. 

Kaman Leung

I updated on Feb 1 and is still having the same problem. This is also happening on Preview as well as after Export in HTML5.

I seem to have found a temporary fix that's worked for me. I had to completely remake all my variables to fix the triggers not firing problem. As for the button states not changing, I ended up making 2 separate buttons layered on top of each other, where the top button is hidden, and the bottom button, when clicked will trigger the normal state of the top button. A bit of a pain, but it'll do what I need for the time being.

Alyssa Gomez

Hi Kaman,

Sorry to hear the Storyline update didn't fix your issues! Would you mind if I took a closer look? It could be there there is a different bug lurking in your file, and I want to make sure we identify that so we can begin looking at a fix.

You can attach your file directly right here. Thanks!

Leslie McKerchie

Hi Sherri,

Thanks for reaching out and letting us know that you're running into a similar issue.

It looks like Ray has chimed in to share a solution that worked for him. If it's just a single slide in a single course, I'd go with his method.

Does the issue happen in any course you are working on or just this particular one?

If it's happening in any/all files, you should conduct a repair of your software.

Ren Gomez

Hi Carol,

Thanks for reaching out. To help us understand, what exact trigger are you using to change the state of the button? 

Are you comfortable with sharing your .story file for testing? You can share it publicly here, or privately with our support engineers. We'll delete it when we nail down what's going on!

Eric Schaffer

Ren,

This seems to follow. I had four pictures in my presentation. As I clicked on then the state would change from normal to visited. I'm trying to finalize this project and a suggestion was made to add one more picture. Well now nothing works. I removed all triggers to restart from scratch. The new picture is the only one that will change states even with out a trigger. 

TIffany Marcus-Hanks

Hi, I am having trouble changing the state of one of the buttons in a results slide i have created.

I have added a trigger that get users to view results after 2 attempts at the quiz (it needs to be limited) by cicking the same 'retry button' and the trigger works, but i also want the state of the button to change at the same time to say 'review results'.

I'm not sure what i am doing wrong.

Thanks