Articulate Review not loading

Hello,

I am having an issue with Articulate Review not loading in my browser. It might load up for a few seconds, but will drop again. I've tried in Chrome, Edge and Firefox, and am getting the same result.

When I open the page, I get the dots loading, but nothing else.

I've cleared my browser cache and cookies, but it's still not working.

I checked my IT department, and they reset my network connection, so the page should load.

Sometimes, a message will appear saying that my computer is office, but it isn't.

Is reason why this is happening? 

Thanks.

 

 

41 Replies
Lauren Connelly

Hello Jane!

Sorry for the trouble this is causing! I just tried to access Review 360 on my end using Chrome, Edge, and Firefox. Each browser loaded Review 360 as expected. Do any of your colleagues have a similar issue when accessing Review 360 on Chrome, Edge, and Firefox?

Good call to clear the browser cache and reach out to IT! You may need to add these websites to your allowlist to access Review 360.

Aukalen M

This is an issue that has been ongoing for quite some time...  It happens randomly some days it works fine, and some others it doesn't.  Today for example it took me 30 minuties of trying to get it to load... (After 10 minutes I gave up, left the screen opened and left, it was loaded when I came back 20 minutes later) 

I have also tried everything mentioned by OP and having the same issue to no avail.  In general Review is very slow to load the contents when there are a lot of courses.

Another problem I noticed is that right click / copy from the thumbnails screen has been disabled now :-( 

To summarise, these are the current issues I found:

  • SLOW to load main screen when there are quite a lot of courses.
    Suggestions to improve this interface:
    • Make a new category called 'Unsorted' that will capture ONLY modules that are not within any folder and make this to be the main default screen instead of 'All Content'.
      This will make the default main screen to load faster for people that have many courses.
      This will also help us see if there are any modules that have not been moved to their specific folder. 
    • Modules inside specific folders can be loaded ONLY when the folder is clicked. 
    • Add a search field to the folders section:
      So we can search for folders without having to wait for all the thumbnails to load.
  • Bring back the right click / copy to the thumbnails section.  It's quicker and easier than the share option and it copies the link with the module name as well, instead of the cryptic link path.

Thank you for considering these improvements. 

Jane Kuo

I've removed courses that I didn't need the review links for and it was working for a while.

Now it's back to loading with the 3 dots and nothing comes up.

I don't know why this is happening. I checked the Articulate status page, and everything is working fine.

When I was working from home, it would load but I was getting the '...course is processing and will appear when ready' message. Once I came back to the office, the course loaded fine.

The site was working fine up to now so there are no blocks on my work network.

This is getting really frustrating as I use this site all the time to get review links as part of my job!

Is there anything you can suggest to get this working?

Leslie McKerchie

Thanks for sharing what you are experiencing as well, Aukalen.

I did want to address the right-click options in Review 360, and these should be working as expected now. Please let us know if you're still seeing an issue with this.

I've opened a support case on your behalf so that you can work with a support engineer on the slowness, and you should be hearing from someone soon.

Jackie Bartus

Jumping in with the same experience.  I keep getting the 'your computer seems to be offline' message and then the three dots start dancing....I've been waiting for almost 15 minutes.  I'm not having any issues with Rise loading, nor am I having any issues with other sites loading.

Edited to add:  I can add SL blocks to a Rise course with no problem.  I can also get to Review using a link from a review comment, but if I try to go back to the Review menu to select a different course, I get the same issue as above - it just sits and nothing loads.

Andrea Koehntop

Hi Jackie! I apologize for the issues you are experiencing with Review 360 not loading in your browser. 

I have a few follow-up questions to begin troubleshooting:

  • Is this issue happening in a specific browser, or all browsers?
  • Have you tried clearing your cache? Here's how to clear the cache in most browsers
  • Does this happen in all projects you try to open in Review 360, or does the issue seem to be isolated to one project?

If those troubleshooting methods don't solve your issue, could you share your file publicly with us here or privately in a case? We will delete it from our system when troubleshooting is complete. 

Jackie Bartus

Hi Andrea!  I mainly use Chrome, so I haven't tested any other browsers yet.  I did clear my cache and it's not for a particular project, The whole Review dashboard won't load so I can send share links to colleagues.  

I'm also now having issues getting any project to publish to review.  It goes through the standard publish process (compressing images, etc.) but then when it gets to the Uploading Course screen, the blue bar loads almost immediately all the way to the end like it's done, but then it just sits there.  Sometimes I get the 'error publishing' dialog but most of the time it just sits there on the Uploading Course screen.  I've tried a couple of different courses with the same result.  

I checked the status and nothing seemed amiss today.  I was able to publish projects with no issues earlier today.

Joe Tansengco

Hello Everyone!

As mentioned by my colleague, we first recommend making sure that your network is setup to allow connections to Articulate 360's endpoints. We are currently not seeing any connectivity issues with the Review 360 tool, so any loading issues might be isolated to certain organizations. 

A quick test that you can do on your end is to test if only certain courses are not loading properly.

  • If only a select number of courses do not load, then the issue becomes project specific
  • If all courses are affected, then it is most likely network restrictions that are causing the loading issues.

In both cases, we suggest reaching out to our support team for the next steps of troubleshooting. 

Maria Costa-Stienstra

Hi, Brian.

I'm sorry to hear you're unable to access your Review 360 link when logged out!

We're currently investigating this issue, which appears to be intermittent. You can stay up to date on our progress and subscribe for updates on our status page:

Articulate Status

I'll also come back to update this discussion when a fix is in place!