Articulate Review not loading

Hello,

I am having an issue with Articulate Review not loading in my browser. It might load up for a few seconds, but will drop again. I've tried in Chrome, Edge and Firefox, and am getting the same result.

When I open the page, I get the dots loading, but nothing else.

I've cleared my browser cache and cookies, but it's still not working.

I checked my IT department, and they reset my network connection, so the page should load.

Sometimes, a message will appear saying that my computer is office, but it isn't.

Is reason why this is happening? 

Thanks.

 

 

41 Replies
Andrea Koehntop

Hi Holly!

I apologize for the issues you are with Review not loading in Chrome and Edge browsers. 

If you have already tried clearing your browser cache and that has not resolved your issue, please ask your IT department to make sure the following network endpoints are open:

Can you reach out to us through a support case if that doesn't solve the issue? We are here to help!

Aukalen M

There is a recurrent issue with the Articulate review server.  I suspect it is not consistent as it might have to do with server load.

It's strange that staff participating in these forums haven't been informed of this problem so to provide a work-around.

I contacted support and they told me to:

  1. Delete old courses manually
    There is no option to bulk delete yet.
    There seems to be no exact number of courses that causes the system to struggle, as server load also varies.
    Not optimal for us :( 
  2. Limit the amount of courses the browser loads
    The best solution proposed is the use of links to load a specific amount of courses:
    1. https://360.articulate.com/review/configure/?itemLimit=100
      to activate it for 100 courses for example - note that this setting will stay ON until changed
    2. https://360.articulate.com/review/configure/ 
      to turn it OFF and return it to load all courses

NOTES:  

The second link is not intuitive so it's important to understand that #1 turns it on for a specified amount and #2 turns it off.  Regardless of what the link says.

Also, both links will redirect to: https://360.articulate.com/review and there is no way to know which one is active, so what we did was created two shortcuts and renamed them 360 Review limit ON and 360 Review limit OFF

Hope this helps.

Jay Sadauskas

This happens to me all the time! It is so frustrating and even more so when stakeholders specifically mention how bad this is.

I am on Safari and can get about 60 seconds on a page before it automatically refreshes as it believes it is offline.

I have followed all threat instructions/cache etc. I am WFH so have checked port settings in the router and gone over all options including updates etc.

I am not expecting a response from Articulate, just adding to say this issue is ongoing for me.

Erika Shaffer

I've been meaning to say I really appreciated this information. I had been well aware that it was on the Articulate server end by the intermittent nature of the problem. It also seemed to happen at certain times of the day. Oddly, after months of dealing with it, I have not had the problem since you posted this, but if I do again, I will follow these steps. 

Luciana Piazza

Hello Matt,

Thanks for letting us know what you are experiencing. I understand how frustrating it can be to not have this load. I'm happy to help!

I'd like to double-check that your network is set up to allow connections to Articulate 360's endpoints. We are currently not seeing any connectivity issues with the Review 360 tool. 

Are you able to view any other courses in Review 360? As my colleagues mentioned earlier:

  • If only a select number of courses do not load, then the issue becomes project specific
  • If all courses are affected, then it is most likely network restrictions that are causing the loading issues.

In both cases, we suggest reaching out to our support team for the next steps of troubleshooting.

Let us know your findings and we can go from there!

Joe Tansengco

Hi Mat, 

Looks like you're running into network related issues. As what my colleague Luciana suggested, reach out to your network admin to have them add Articulate's endpoints to your organization's allowlist. Doing so will allow all Articulate 360 applications to work properly. If the behavior persists, please open a case with our support team so we can take a closer look at what's happening.