Error Message when upload published Rise file to SuccessFactors LMS

Jan 24, 2020

Has anyone been able to import a published Rise SCORM 1.2 to SuccessFactors LMS?

I have created a Rise eLearning module, published it for LMS (SCORM 1.2) and attempted to import the .zip to Successfactors LMS. However, I keep getting this error: An error was detected: getzipFile(filename,uploadID,addXMLFilesOnly) error occured while retrieving the file from db. I have researched on SuccessFactors Help portal and they recommend removing the </IOM> from the manifest file and re-zipping. However, I cannot find any </IOM> reference in the manifest file. 

58 Replies
Jizell Assaf

Hello!

In reference to what Simone is saying, I am facing the same issue. Prior to March 2020 I had no issues importing the zip files to the Success Factors LMS. Since then I've had to unzip and rezip every single module I publish. This goes beyond it being an inconvenience, it affects productivity as our team develops a significant amount of courses. Thanks! 

Alyssa Gomez

Hi everyone,

Our team has been working to nail down why Rise 360 zipped SCORM packages don't upload successfully for you in SuccessFactors. I know this has been a frustration for a while now, and we want to do all we can to resolve it. We've even partnered with administrators at SuccessFactors for testing, and they haven't been able to reproduce the error yet. We'd love to get your help. 

The zipped file linked below is a Rise 360 template (ADA Compliance for Employees) exported as SCORM 1.2. I did not unzip/rezip this package after it was exported. 

Can you please try uploading the package linked below to your SuccessFactors account and let me know if it uploads successfully? Here's what I see from my account. 

I'll be standing by! Thank you! 

File download link: ada-compliance-for-managers-scorm12-DV3mV27U.zip

Dana Collins

Hi Aylssa,

I attempted to load the zip file you provided to our SF LMS, but it was not successful. I received the error "An error was detected: getzipFile(filename,uploadID,addXMLFilesOnly) error occured while retrieving the file from db".  I have it on video and a screen shot.

Richard Waggoner

We just started experiencing the same error message.  Our SCORM files are created in a custom application built in ColdFusion.  We just upgraded our Cold Fusion engine and are now receiving the same error message (An error was detected: getzipFile(filename, uploadID,addXMLFilesOnly) error occured while retrieving the file from db.  )

I was able to use Windows add to compressed folder to rezip the contents and then upload to SuccessFactors.

Alyssa Gomez

Hi Dana! We've uncovered a new clue that might help us finally nail down why this issue is happening.

We are working with a customer in a support case who was seeing the exact same issue you were seeing -- every Rise 360 course export would result in an error when uploaded to SuccessFactors. 

However, when the course was exported from a personal computer outside of the network, there was no error! We found that the the security software on their network added extra metadata to the exported Rise 360 courses, and that caused an error in SuccessFactors. 

Here's how you can help:

Please export any Rise 360 course from a personal computer outside of your work network, and upload that file to SuccessFactors from the same personal computer.  You can try the same process with the file I shared here. Let me know how that goes! 

Dana Collins

Hi Alyssa, I will speak with our IT Security team, but we are not allowed to access Successfactors from non-company (non-network) computers. So, this may not be a solution for us.

Are you able to remove whatever is adding the metadata to the file in Rise? I'm asking since this does not occur with Storyline or Studio, it seems that the issue is still on the Articulate side?

 

Thanks,

Dana

Stephen Wilhite

Tested last night, and I was able to export a SCORM 1.2 package from Rise on my personal device and then upload successfully into SuccessFactors from my work computer the next day. Also, I verified that the package exported at home differed in size (slightly smaller) from one exported at work, so something is definitely being added.

Next step is to speak with my contacts on our cybersecurity team and learning operations team to see if anything can be done about this issue, as the solution of exporting from a personal device isn't much better (if at all) from the previous solution.

One question I have is why is this issue only impacting SuccessFactors users? If the metadata is being added by our security software, shouldn't it affect more LMSs? Maybe not? I also share Dana's consternation about this issue only affecting Rise and not other Articulate apps, though I suspect that the explanation for that is that Storyline is a desktop app and Rise is a Web app.