23 Replies
Hannah Lim

I'm having this same problem. I followed all the instructions at the link Allison provided, even making sure I ticked all the font languages in Google Fonts, but the macrons are still displaying very untidily (see attachment). 

Could you please us know how to get around this? Many thanks.

peter graham

Hi again, I've found success in uploading the Vreyma font (https://www.fontzillion.com/fonts/casady-greene/vremya) to Rise - it's a pretty good match (see attached pic).

It seems a little buggy - as you type the letter 'K' appears when you press the space-bar, but that disappears as you type. But, cos I'm doing a whole course in te reo Māori, I'll take it as a fix for now!

Cheers

Hannah Lim

Kia ora, Peter - many thanks for this! The Vremya font, though a bit default-font looking, is as close as I've gotten to anything that matches the macrons, so that's great. The K bug remains a problem, as you've mentioned, but this is a satisfactory workaround for me for now. More advances on this from Articulate would definitely be welcome though!  

Hannah Lim

A friend has helped me find a very satisfactory solution to this. Follow the steps Allison links to above, except that when you get to the part of converting from .ttf to .woff in Font Squirrel, instead of leaving the conversion type at Optimal, tick Expert instead. When you do this, more options will appear. Scroll down to the Subsetting section and select Custom Subsetting, where more options will appear. Under Unicode tables, you will be able to select a whole range of Latin scripts. I basically selected them all except for the Currency symbols. Once you’ve done this, go ahead and download the converted font from Font Squirrel, upload them into Rise as a custom font as per Allison’s instructions. This has worked beautifully for me (see attached image) and I’d love to know if it works out for you too! 

Hannah Lim

Hi Peter, this might be because macrons aren’t included in the extended Latin set for Lato. You can do a quick check for macron support in Google Fonts by picking Custom from the dropdown menu at the top and typing ‘Māori’ in the search box. You’ll be able to quickly see which fonts support macrons (see attached image). I used Open Sans for my course. Is this an option for you? 

Vicki Finlay

Hi Everyone

Great discussion - I now find myself in this situation.  We have a specific font  set for our business, of which none are supported (Thanks Hannah!) - I am about to go to my marketing and IT Team to come up with a resolution that they will be happy with and will enable us to use the macron in our courses.  

Hannah Lim

Kia ora Vicki, I had a similar discussion with our marketing team, who were fortunately very understanding of the need to use suitable and engaging-looking fonts in our online courses, even when these departed from the brand fonts. I found that using organisation images and brand colours throughout did help the course retain the look and feel of our organisation brand. All the best with your course! :)

Aukalen M

Interesting post.  I have come across the same issue for a course in Vietnamese. 

The problem we have is that although we can upload custom WOFF fonts with all the characters needed, they only apply to Heading and body but not to all the player text.

Player text still uses Lato.  We also tried uploading all latin characters to Lato WOFF font but they still look bad.

I guess there isn't a way to change player fonts, is there?

Roda Roditelji u akciji

I've tried all the work-arounds in this thread, and none of them have worked for Slavic diacritic letters (čšćđž specifically). When I'm editing they look fine (not perfect, but passable) but in the preview (reader), they are in a different font. It's really, really, frustrating.

Any info from Articulate Support on this?

Alyssa Gomez

Hi Daniela! 

If you already followed these steps for getting non-Latin characters to display correctly and you're still having trouble, please open a case with our Support Team

Include the Share URL so our engineers can get a better look at how the Slavic diacritic letters appear in your course. Thanks in advance!

Paul Tottle

I've spent a few hours trying to resolve problems with macrons. Different to the ones above. Thanks to Articulate support here's what we found...

  1. The instructions suggested using FontSquirrel. Their process stripped out some language macrons. So try Transfonter.
  2. Use FontDrop to check your new woff files to see if they have the extended set. You can type the macron and see it appears.
  3. When naming a custom font in Rise, don't include spaces. There is no error message about this.