Changing text in object does not change it in all states

Sep 08, 2017

I have created a text object with seven states:

  • Normal
  • Hover
  • Visited
  • Selected
  • Correct
  • Incorrect
  • Disabled

These are all "off the shelf" states. My client has asked to change the text in the text object and when I make the change, it changes the text in all of the states except "Disabled". Note that each state has its own text color, border, and background, but that shouldn't matter. If it works to change some states, it should change them all.

Any clues as to why this is happening? It is the exact same text in all states.

11 Replies
Crystal Horn

Hey Steve...just to show you what I'm seeing in Storyline 360, I was able to make changes in the slide to the Normal state and have my Disabled state also reflect those changes.

What version of Storyline are you using?  Also, did you recreate the text object in the Disabled state at all?  

Thanks for reaching out!

Steve Covello

What you are demonstrating in the above post is exactly what is NOT happening in my project.

Attached is the file, trimmed down to the one frame in question. Nevermind any of the interaction - just focus on the text within each of the 8 boxes. When you change the text, the Disabled state does not change. This was created in SL2 but then upgraded to 360.

Matthew Bibby

These kinds of issues tend to happen if you've somehow broken the connection between the normal and the disabled states.

States are weird. If you do something like cut and paste the disabled state, you'll run into this kind of issue. I think even creating a new state rather than copying the normal state might be to blame (although I could be wrong about this, it's been a while since I tested it).

 

Pedro Gutierrez

I have the issue in which I am changing the text content from one state to another within the same textbox object, let's call it text 1. I set a trigger so that once another text, let's call it text 2, ends on the timeline, the state for text 1 should change to a second state that contains the new text. I've uploaded to Review360, thinking maybe it's an issue with the Preview function, but the issue persists. Is there any knowledge around solving this issue so that the text state with different content shows when triggered?

Ren Gomez

Hi Pedro,

Have you tried importing your file into a blank project to see if you get the same result? You can do this by opening up a new project and going to File->Import->Storyline. This will confirm there are no specific issues with your project file.

Are you comfortable with sharing your .story file for testing? You can share it publicly here, or privately with our support engineers. We'll delete it when we nail down the cause of the issue!

Ren Gomez

Hi Pedro,

Thanks for following-up and sharing your file. I do see some issues with the text display, though I believe it may have something to do with the animation.

I recreated the caption with a float-in animation. After previewing, I no longer saw the issue, so I'd start with recreating it first and see what result you get!

Conor Striegel

This happened to me today as well. I'm using an existing storyline-file to create a template for our organization. When I change the text in the "Normal" state, the word changes in the other (all custom) states. This doesn't work when I change the text in the (custom) Initial state or any other for that matter.

I added a shape as a note for my colleagues to remind them to change the 'Normal' instead of the Initial state.

Darren McNeill

It seems that if you create basic text, and then create the other states that auto populate with the base text, all of the text states will change together outside the Edit states option, if nothing is added.

As soon as you apply any changes to the text in a State, such as changing the Hover state text to just green, when you click on the text box on the slide outside of the Edit States option, and change the font size, only the text states that have not been changed will update to the new size.

So it seems that the moment you edit or format a state, the link breaks.