New in Storyline 360: Text Autofit Enhancements

We know how important it is for all learners to easily access and read the text in your courses, which is why we’re excited about the improvements we’ve made to the text-authoring experience in Storyline 360. With the text autofit improvements we’ve just released, you have new ways to manage text elements, more control over your text, and easier ways to make your text accessible. Here’s a quick summary of these improvements. 

Greater control over text

Three new text autofit options help you preserve your preferred font size and prevent text from automatically shrinking.  Now you can choose from “expand width,” “expand height,” and “fixed size” options. Read more about each of these autofit options and see the difference between the old and new approaches in this article.

More precision over the size of your text box 

Before, when you tried to resize a text box to your preferred size, it would automatically default to the height of the first line of text. With the new text autofit enhancements, you can now easily set the precise size of your text box regardless of the amount of text.

Having more precision also means you have a more accurate view of how your text will appear in the published output.

Faster workflow for a smoother experience

Now, with a single click, you can quickly toggle between different autofit options to accomplish more in less time.

Improved readability across browsers

Since accessible text is HTML text, it can display differently across browsers. With text autofit improvements, now you can easily adjust the text elements and remove scroll bars before learners see them.

We hope you’ll love the enhanced authoring speed and flexibility and greater control that comes with these new text autofit improvements. To learn even more, check out Storyline 360: Text Autofit Improvements and Accessible Text Features in Storyline 360.

60 Replies
Julia Mays

This is proving to be a disastrous time waster.  When I create quiz questions, every single "Correct" or "Incorrect" slide has scroll bars for both the "Correct"/"Incorrect" text field and the "Continue" button.  I  am having to manually adjust every single layer slide, either by dragging the handles or downsizing the text.  Opening the Properties window to adjust settings doesn't help.  

I can't roll back without losing significant work now.  Please give us an ETA on  the fix for this bug.

 

 

Trace Platt

Hi, Bret: I am using 1280x720. 

I am also seeing odd behavior when I manually resize either of the quiz feedback layer's Continue button. It flickers rapidly when I point the mouse to it.

Steps to reproduce:

  1. Create a question (I tested both T/F and MC).
  2. In Slide Layers, select the Correct layer and manually resize the Continue button to remove the vertical scroll bar.
  3. Click Preview and select This Slide.
  4. In preview, answer the question correctly and click SUBMIT.
  5. Point your mouse at the bottom of the Continue button.

Expected result: Button turns grey and mouse arrow turns into a hand cursor.
Actual result: Button resizes (gets smaller/reverts to initial default size?) and mouse arrow turns into a hand cursor. When you point the mouse to a specific region at the bottom of the button, the button flickers rapidly. (Move your mouse around the bottom of the button until it triggers.)

 

 

Leslie McKerchie

Hello everyone!

Great news!  We just released another update for Articulate 360 and you can read all of the details in the release notes.

The item you'll be interested in is:

Enhanced: The built-in widescreen (16:9) slide size is bigger—960x540—giving you more room to work and resulting in fewer unexpected scroll bars in text objects.

Just launch the Articulate 360 desktop app on your computer and click the Update button for Storyline 360. Details here.

Please let us know if you have any questions, either here or by reaching out to our Support Engineers directly.

Kathryn Farrelly

OK guys, THIS is not an improvement.  THIS is a nightmare that has now derailed our entire teams' projects.  If you guys haven't updated your Articulates yet, DONT do it until this feature is removed.  Why would the default be to add a scrollbar?  If I wanted so much text on the slide that I needed a scrollbar to go through it, I'd just insert my text box into a scrolling panel. This makes absolutely no sense whatsoever.  There are a million annoying problems you could be focusing your energy and talents fixing, and instead you have changed the default setting to something that we need only once in a blue moon?  i'm sorry but whoever came up with this idea should be fired. auto fit nightmare

Ren Gomez

Hi Kathryn,

Thank you for providing that screenshot, and I'm sorry these scrollbars are appearing all over your course! I'd like to get our support team to take a closer look at your file and help alleviate these issues. 

I've started a case on your behalf with our team, so you should be getting an email soon with an upload link. Please share your .story file with us, and our team will get right on it!

Ren Gomez

Hi Everyone,

Thank you for taking the time to share how the new Text Autofit Improvements have affected your work. We hear you, and we want to apologize for the frustrations and re-work this has caused!

We introduced this feature as part of our continued focus on designing accessible courses. This means you’re building a course that’s better for everyone, and this feature brings new, better ways of doing that.

When a project is upgraded to use text autofit enhancements, unexpected scroll bars sometimes appear. These scrollbars are due to text areas having extra lines, text, or other elements that overflow the bounds or margins of the shape.

We’re investigating these issues and will update everyone as we have news to share. In the meantime, here are some helpful tips to avoid these unwanted scroll bars:

  • Remove blank lines at the end of the text box: Check that the end of your text is indeed the end; otherwise, Storyline will assume that an extra line needs to be read, and a scroll bar will appear.
  • Remove extra margin space in the text within shapes: Extra margin space can cause text to overflow the bounds of the shape. Remove that extra margin space by right-clicking on the shape and formatting the Text Box to remove unnecessary margins.

If you run into any other snags, please let us know. You can connect with our Support Team here.

Kathryn Farrelly

Accessibility features are all well and good, but you should have designed a mechanism to turn the feature on and off. It's hugely cumbersome to the vast majority of your users and we don't want it. There are so many improvements you could be investing time in, including other accessibility features. Please don't keep trying to convince us that this is somehow a feature we should want. Instead, get rid of it or make it an option you can turn on instead of the default. This email response doesn't really demonstrate that you've accurately heard the feedback you're getting about this feature.

Kate Farrelly
AGPA, Training & Program Policy
Victim Compensation Board
p.916.491.3624 c. 415.235.5452 f.916.491.6423
kathryn.farrelly@victims.ca.gov
[CalVCB 2016 - color]

Tracy Windsor

Has this issue been resolved yet? I'm having the same issue where I can't open in a previous version. I used to use the 'Use Modern Text' feature to fix all my kerning issues when using Arial, but that went away and I started using Display Accessible Text by Default -- sure wish there was an undo for that. I can't rollback to an older version due to the issue mentioned above Jeremy :( I personally do not ever want scrollbars in my text boxes unless I put them there.

Julia Mays

Ren, can we get an update on a fix for this?  We are roughly 45 days into the problem.

You indicated that your team is working on this issue.  ARE you working on an option for us to turn off the Text Autofit feature?  Right now, my team is holding at the April 27 update with no intention of moving forward until your team indicates that this "enhancement" either adapts 100% to the text boxes we create, without manual checking every box for any extra margin or line issues, or we have the option to just turn it off. 

In our case, we've found no extra lines or margin problems.  As Kathryn Farrelly's screen shot above shows, the scroll bars are very short...just indicating that the bottoms of the text boxes are being cut off and not that an entire second line of blank text is the culprit.  This is our issue.  EVERY SINGLE TEXT BOX....even the ones generated by Storyline in quiz layers...has a short scroll bar.

Please give us the option to just turn this off.  Then everyone can move forward.  

Julia Mays

Talent Systems, Orlando Health

Simon Taghioff

Hi everyone,

We wanted to update you on what we’re doing to address your concerns about recent text autofit enhancements.

While text autofit delivers necessary enhancements that ensure all learners can access and read the text in your courses, we’ve heard from many of you that it has negatively impacted your authoring experience in Storyline 360. When a project is upgraded to use text autofit enhancements, unexpected scroll bars sometimes appear. These scroll bars are due to text areas having extra lines, text, or other elements that overflow the bounds or margins of the shape. They always existed but are now made obvious by the scrollbars. We realize that making these autofit enhancements active by default has resulted in extra work for some of you, and we’re sorry for the inconvenience and frustration we’ve caused.

There’s work underway to refine the feature, and we’ve recently released an update that increases the default widescreen slide size to 960 x 540, giving you more space to work with and alleviating some of the unexpected scroll bars. In the coming weeks, we’ll also release an update that temporarily disables the default autofit feature while we make more improvements.

Our accessibility work is a journey, and we’re bound to face a few uphill climbs and detours. Thank you for being our partner on this journey. We’re grateful to have your feedback to learn and grow from.

Simon Taghioff
Product Manager, Articulate 360

Darrin Hayes

I like what I'm seeing with the Auto Fit settings at least in authoring mode; haven't tested out published view yet. But am wondering if this then replaces need to manually add scrolling text boxes if working with large text items that will need to scroll? aka on the published size are the two approaches identical as far as how extended scrolling text is handled if bounded inside a text box?

Ren Gomez

Hi Darrin and Julia,

Darrin - Thanks for sharing your feedback on the text autofit feature! To confirm, this wouldn't replace a scrolling panel but solely focuses on text-based elements to help make them readable and accessible to all learners. Plus, there are fewer steps needed if all you want is a text panel!

If you need other items, such as data entry boxes or images, included with the text, it'll make more sense to use a scrolling panel and use the Expand Height option on the text box to avoid having two scroll bars.

Julia - As Simon just shared, we’ll also release an update that temporarily disables the default autofit feature while we make more improvements.

Since you're not experiencing the same issues with extra lines or margins, I'd love to have our engineers take a closer look at your file and do some testing to help us improve the text autofit feature. Be on the lookout for an email from me with next steps, as we'd really appreciate the help!

Thank you both!

Julia Mays

Thank you for the quick response!  I'm happy to help within my bandwidth, if I can.  I appreciate your acknowledge of both the frustration and the need for the option to turn the feature off.  I'm sure there is value in the new auto fit function and I'll look forward to exploring it more once It's under user control.