After Quiz/Course completed but opens to question #15 when relaunching the course.

Jul 07, 2023

When relaunching the course after completing the course, the course is expected to start from Slide 1, however, the course starts on quiz question #15 .

I tried deleting this question, copy/pasted the questions into a new SL file, and tried multiple redundant triggers to fool the system, but the results are the same - user is started back at quiz question #15 when relaunching the course AFTER COMPLETING the course. 

The quiz questions are shuffled which is the only complicated setting. Anyone one else having this issue? Anyone know how to fix this?

7 Replies
John Morgan

Hi Ed,

Great question! I understand that when re-opening your course it doesn't start on its opening slide. I’m happy to work with you to figure out why this is happening!  I have a few follow-up questions regarding the situation so I can understand what you are experiencing a little better.

  • Is this happening with more than one file or is this the only one?
  • Are you working from a shared drive? If so, I recommend saving your files on your local drive before creating, editing, and publishing them. This will help minimize any unexpected behavior.
  • Is your course just a quiz or is there other content as well? If the course is just a quiz, check if question #16 is locked to the top of the group. If it is, it will have a little icon above the question number. Here's a picture of that icon in the Draw Questions from Bank window.

If it is locked to the top of the group, follow these steps to unlock it.

  1. Open the Draw Questions from Bank window by double-clicking on your Draw from Question Bank Slide
  2. Click the Lock Question button
  3. Click Remove Lock in the drop-down menu.

If that doesn't fix things up, would you be willing to share your file here or with our support engineers privately in a support case so we can troubleshoot the issue?

Thanks for reaching out and I look forward to your response!

Ed Gen

The course is mostly a quiz but none of the questions are locked. I tried copy/pasting the questions into a fresh new file but it did not fix it.

I even tried to upload the course onto SCORM Cloud and the results are the same.

Attached is the SCORM file. Your help would be truly appreciated.

Steve Gannon

This is a tricky one, Ed. First, I'm assuming the issue you're referring to is the case where the user gets to the Results slide but then closes the course window rather than click your "Finish" or "Restart Course" button. I tested this on SCORM Cloud and it seems to resume properly if I click the Finish/Restart button and then close the course window from the title slide.

I may be mistaken but I don't believe Storyline's resume feature can resume to a Results slide, so it would naturally resume to the slide just before it, which isn't necessarily the last quiz question  but instead whatever question slide is drawn randomly. (Again, I may be incorrect about this but that's what I'm surmising is happening.) Perhaps one way around this is to have the Results slide appear just for a second while you submit the results and then auto-advance to a closing slide (a non-Results slide) that shows the results exactly as they appear in the actual Results slide so that the visual transition is seamless.

Unrelated, I noticed on the Success layer of the Results slide that you are submitting the results slide twice: once when the slide starts and then again when the user clicks the Finish button. I would delete the latter trigger.

Another thing I noticed is that when the user clicks the Finish button on the Success layer, you have triggers to restart the course, jump to the first slide, and then exit. Restarting and jumping to the first slide are redundant (and in fact I don't think the jump and exit triggers will fire since the restart trigger is encountered first). Perhaps you could set the properties of the first slide to "Reset to initial state" and toggle a custom variable to exit the first slide if that variable is true, having set it to true on the Success layer of the Results slide, but toggle it back to false just before you exit on the first slide (rereading that, it's a bit confusing but if you think about it, you'll probably grasp what I'm getting at). 

Lastly (and this is totally unrelated to the issue you're having), the Previous button is activated in the slide properties of Questions 15-20. This shouldn't hurt anything based on your setup but I would go ahead and uncheck the Previous button/swipe settings on those questions.


Ed Gen

Thanks for your response Steve.

The issues is definitely not the RESTART COURSE button. 

The issue is when a user wants to relaunch the course after passing the quiz and receives a pass/complete status. Once the user tries to relaunch, the course relaunches at question #15. All settings were checked so it really does not make sense.

By the way, I updated this discussion title and description on this issue to make it clear.



Jürgen Schoenemeyer

a have tested the course on scorm cloud and the resume question for me is #16

if you open a support case - in the attachment is a version easier to test

  • the correct answers are marked (x[original number])
  • menu is active

I will do some tests - perhaps I will find the problem

Jürgen Schoenemeyer

some more tests -> sometime is question slot #15, sometimes #16

here a peak after complete/passes (Scorm 1.2)

  • start is on question #16
  • question #1 ... #15 there you can see the former (correct) input
  • question #16 ... #24 former input lost !!!

-> the resume string with the former data - delivered by the LMS - seemes to be damaged

now a test with with Scorm 2004.3, again a peak

=> everything ok

  • starts with "Assessment Result"
  • question #1 ... #24 there you can see the former (correct) input


result: storyline stores the course state extremely inefficiently, the first 15-16 questions seems to need more than 4096 bytes

in Scorm you have only

  • 4096 byte (Scorm 1.2)
  • 4000 byte (Scorm 2004 2nd)
  • 64000 byte (Scorm 2004 3rd, 4th)

=> you have to use Scorm 2004 3rd or 4th Edition