SL 360 Object can't be selected or moved.

I had a crazy SL 360 bug a couple of weeks ago in which the audio for slide N would play some arbitrary audio from some other slide.

I created a new project, imported all the slides, problem gone.

Today I have a SL 360 that has some objects on-screen, not locked, that cannot be selected or moved.  I've submitted a case (01048186), and I tried the old-create a new .story, import the entire slide.  Doesn't fix it.

I had no issues this severe with SL2.

Sam

12 Replies
Ashley Terwilliger-Pollard

Hi Sam,

Thanks for reporting it here in addition to going to our Support Engineers. I see that Jonathan was trying to figure out how the initial on screen button was created as that is where the issue was presented - but since you weren't the original author of the .story file it wasn't something as easy to track down? 

If you want to share the file here perhaps others in the community may know more about how that custom button was created? 

John Say

Hi Sam!  I got to take a look at the problematic file with the problem button and it looks like the actual area of the button is set to be very small and is off to the corner of the picture and text.  That's why you can click on the button if you hover your mouse cursor to the bottom right of the button.  Not sure what the original author did to do this but the good news is that you can fix this. 

To fix it, you can create a new state then use the new state to adjust the area or size of the button.  You can also move the picture and text objects in the normal state to be in the right area as the button.  I made a quick peek of how I fixed it on my end.  Hope this helps!

https://360.articulate.com/review/content/09265ce5-9da7-4784-a360-838a220d746b/review

Sam Carter

Hi John,

Thank you for your video post.  I appreciate that there are workarounds to this, among them I could re-create the object to make it selectable.

Let me pose the issue with SL360 another way: Let's try to select the object using the click-and-drag method.  Click the upper-left outside of the slide, drag to the lower-right outside of the slide. All objects on-screen should be selected yet nothing is selected.  

This seems to be something SL360 should address (to me anyway).

Still, I appreciate the workarounds.

Sam

John Say

Hi Sam, 

I tried the click and drag method with the unedited version of your sample file and I was able to select the 2 buttons.  I clicked at the top left corner outside of the slide and dragged towards the bottom right side of the slide.  Your 2 buttons do get selected.  I verified this by pressing the delete button after selecting the objects on the slide.    The buttons don't get the dots at the corners that usually appear on buttons that are made using the insert > button/shape feature but if you look at the timeline, the 2 buttons do turn blue.   

https://360.articulate.com/review/content/4cdb5417-f1ef-483d-a518-ae0caec2638d/review

 

John Say

Hi Sam, 

I was able to figure out how to create a button that would have the same issue as yours. 

1) Insert a regular button via the Insert > Button feature. 
2) Edit the button's normal state and delete the shape on that state. 
3) Copy in an image and/or text into the Normal state and make sure that they are placed just above or away from where the original shape was located. 

After that, you can only click on the button in the area where the original shape was located.   It's as if the shape in the normal state defines the button's clickable area.  I also made a screen recording of how to replicate the problematic button: https://360.articulate.com/review/content/e5181869-5c83-4797-9e06-ea1146b639d3/review

I will send the steps and the video to our Quality Assurance so that they can investigate it on their end.  While these kind of buttons are not common, I do agree that it may be a bug and it also makes it hard to work on buttons.  

John

 

Ashley Terwilliger-Pollard

Hi Douglas,

Thanks for checking in on this issue. It's still open with our team, but is only reproducible after following some very specific steps: 

  1. Insert objects in a new slide (ex. image and text)
  2. Insert a button in the slide
  3. Edit the normal state of the button
  4. Delete the shape of the button
  5. Copy the image and text and paste it in the normal state of the button
  6. Position the image and text somewhere in the upper left corner of the button
  7. Click Done editing states

When you follow those steps, then no adjustment handles appear and the button cannot be selected. Does that match what you see? 

Tom Randell

We have a course that was built by someone else and has this exact same issue.

We're opting to go through and manually recreate the buttons because even with the "fix" shown in the videos above there's a more fundamental problem.

When you tab to both the "broken" and the "fixed" versions of those buttons, and then hit Return to select them, none of the triggers fire which is a show stopper for accessible content.

Has anyone else noticed that? Or is that a different issue entirely? I suspect it's the same issue as it's only happening to the one's with this issue.

Vincent Scoma

Hey Tom,

Thank you for reaching out and sharing those details! The behavior you are seeing is more than likely the result of how the button was setup since it sounds like it is happening only on those courses.

If you need our help to take a look at your file, we're always more than happy to help!  You can share files in this thread here and click on Add Attachment, or you can send them privately to our Support Engineers. We'll let you know our findings and will delete it after having a closer look.