Textbox Overflow Handling - Scrollbar not Saved with the File

Aug 26, 2021


I like the new feature of the Scrollbars of Textboxes by overflow.
I have only one problem. If I select the "Add Scroll Bars" an Publish the Version has a scrollbar, but this Setting will not saved in the .story file.

On Reopen the Storyline File, it is back to "Allow text to overflow" without Scroll Bar.

11 Replies
Ren Gomez

Hi Jens,

Thanks for reaching out and sharing your experience. Our team recently spotted this issue as well in Storyline 360 Update 55 where:

Projects with text and shapes that have text autofit enabled and set to "Add scroll bars" will not save the feature upon re-opening in Update 55. It will change to "Allow text to overflow."

We also noticed the same behavior occur for files saved in a previous version opened in Update 55. 

I'm sorry you're running into this! We're working on it and will let you know when we have any news to share on a fix.  

Ren Gomez

Hi Jens,

Great news! Our team released a hotfix update to Storyline 360 to address the issue where scroll bars were removed from all fixed-size objects in projects where text autofit improvements were already enabled.  

Now, the option to add scroll bars will remain in place as expected once you save and re-open your Storyline file. Just launch the Articulate 360 desktop app on your computer and click the Update button for each application. Details here.

Jennifer Clarke

Hi Lauren,

Thanks for the response. I guess I didn't explain properly. I had set up 2 buttons using shapes and set them to overflow. They were fine in previewing and Review while I was working on that file in that session. It's after reopening the story file that they reverted to scroll bars. It hasn't happened every time, but several times. I even deleted and recreated them and it still happened. I'd used a trapezoid for this particular button and have now changed them to just a plain rectangle, so we'll see what happens then.

My real wish is to have them default to overflow. I would rarely need/ want a scroll bar.

Thanks again for doing the test.



Becca Levan

Hey there, J!

I'm not having luck recreating what you describe with shapes set to overflow. I do not see a scroll bar even after reopening the file. 

Could I have you run a quick repair of Storyline since you mention this isn't consistent? If that doesn't fix things, connect with us in a support case so we can investigate. It would be helpful if you could include a recording of the issue!

Amy Thornton

I am experiencing a similar problem to Jennifer. Regardless of what textbox settings I choose, scroll bars always appear.

Changing the settings makes no difference - I NEVER want a scroll bar to appear, I want text to overflow OR box height to expand. But regardless of what settings I choose, a scroll bar is added when accessible text mode is on. This is awful for designing, as there is no scroll bar visible when editing, but in preview, suddenly every text box or shape (including buttons!) has a scroll bar.

The settings 'overflow' and 'expand height' seem to be ignored and a scroll bar added.

I have tried creating new projects, checking updates, recreating objects, changing margin settings - everything I can think of, and nothing has worked. If 'accessible text' is on, all objects with text suddenly get scroll bars. This is not a practical workflow - I can't preview every single object to test for scrolling because they don't appear when designing and when there are supposed to be settings to prevent this situation.

I cannot find anyone else having this issue. Am I missing something or interpreting the behaviour incorrectly? Appreciate any thoughts!

Jürgen Schoenemeyer

yes 'accessible text' + Scroller is broken, here is an example


it depends on the line spacing of the text - it's not a new error (just testet with the version from January 2022)

it does not matter if old or new project text


Amy Thornton

Thank you so much for the reply. I had been struggling to find any information on this issue, which seems strange when it's a known issue.

This 'solution' is interesting, although not consistent for me. I tried changing the line spacing for the text on two buttons (being only one line of text, I can work around whatever the line spacing needs to be), and it worked for one button, but not the other! At least I have some options to work with now.

I guess I will have to continue with the incredibly inefficient manual adjustments and text boxes that create orphans unexpectedly. Fingers crossed this error gets fixed in the next update!