Translation XLIFF format


In Storyline you can export the text to .doc or xlilff format.

.doc format is working fine when importing back again

if i export to xliff and i do not change the file but instead i import it back again i get "invalid xliff format"

why? i have not change file?

is it not possible to work with the xliff format?



44 Replies
Robert Eriksson

Hi again

 I can now import the file but the problem is not solved please that text will not change in storyline

The tags was wrong

i replaced > with >

Furthermore the degree celsius sign is exported wrong in the xliff file

so now i import the file again but the changes i make in the exported file does not appear when i import the file back again...

what can i do? switch to .doc? i prefer xliff because it much smarter when working with translations...



Bryan Tregunna

In readiness for a series of translations and realising that I have not done this before I thought I'd test it. I have a rather large Story file that takes a few minutes to export. I have simply changed a few words and saved it with a new file name.  Importing from Word works fine, but when I import the xliff file it states Import successful almost immediately and no changes made. 

Translating seems so straightforward that it surely cannot be operator error.  So do I have a similar issue to Robert?

Christine Hendrickson

Hi Bryan,

The first thing I would check is the location of the file. Make sure all the files you're working with are local. If you try to export, edit, or publish from project files on an external source, you may run into issues. Work on your local drive (your C: drive). Working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other unexpected behavior. You should also make sure the directory path to your project files and your published output is less than 260 characters (for example C:\Articulate). Avoid using special characters, accents or symbols in your file names.

Additional information regarding "Naming Files, Paths, and Namespaces" in Windows operating systems can be found in the following Microsoft article.

If you've confirmed all the files are local, we'd be happy to take a closer look at what's happening. 


Christine Hendrickson

Hi Bryan

To double-check the process you're using to import the xliff file, please take a look at this tutorial and the below Screencast:

You may also want to check to make sure there are no characters in the translated text that may be causing issues. Are you able to import any other xliff files? 

I have only seen a handful of reports regarding xliff files, most seem to be file or system specific, so it may be best to have our technical department test the files, if the suggestions above don't resolve the problem.

Thanks Bryan,


Bryan Tregunna

Christine, I'm sure I'll get there eventually! 

When I export and select file type as xliff.  I would expect the default of .doc to change, but it doesn't.

So, I should leave this as .doc, do I (and not manually change the file extension)? My thought is that the translation company are expecting .xliff files and sending a doc file would lead to confusion (as indeed I have!)


Christine Hendrickson

Good morning Bryan,

I think I see at least a little something that's causing a problem there. The file name when you're saving shouldn't be ".doc", you're right. Do you have the correct option set for "Save as type", though. The name doesn't need to have an extension on it. If you do that, it may cause some confusion (as you can see ) and some issues. Try either removing the ".doc" from the file name, or add ".xliff" in its place. 

So, it would look something like this:

Try that out and let me know if it makes a difference.


Christine Hendrickson

Hi Michael

In Bryan's case, the following solution seemed to fix the problem:

To make your translation (.XLIFF) file work with your .STORY file, you 
simply have to do the following: 

1) Open your Storyline exported .XLIFF in your translation/text editing software. 
2) Look for these or similar codes/tags below. Usually they're found after </source>: 

< target state="new" xml:lang="de-DE"/ > (without the spaces)

3) Replace it with these: 

< target >place your translated text here< /target >   (without the spaces)

Note where you need to place your new text/translation. 

4) Save your changes. 
5) Import your edited .XLIFF file into Storyline (Articulate icon->Translation->Import). 

If that doesn't work for you, mind if we take a look at the file



Michael Grady

Actually, my problem is when trying to export to a .xliff file.  Storyline generates an Error Report.  It must have something to do with the specific project because I have recently exported>.xliff with a very simple project (I sent the link to you earlier).  I'll attach the file from the link you included on your message above.

Christine Hendrickson

Thanks very much, Michael!

I see we got the case (#00323373). I'll take a look and if I can't find the issue, I'll be sure to follow along to see if our support team is able to find the cause of the problem.

I did take a quick look at your earlier post - you did a great job :)

Thanks again,


Christine Hendrickson

Good morning Michael,

I've been watching the support case for updates, but looks like the last response from Cleo may have resolved the issue for you. Just wanted to check in with you and make sure everything's running smoothly now. If you're still having any trouble with this, just let us know.


Ashley Terwilliger-Pollard

Hi Raymond,

I looked into Michael's case, and saw Cleo shared his troubleshooting steps was to systematically import the slides per scene from the old file. After each scene import, he then exported the translation to .XLIFF. It seems that there were two particular scenes that were causing a crash, and causing a corruption issue that once it's been imported into Storyline could not be removed. So Cleo suggested that Michael work with those specific scenes to see what was causing the corruption. 

Cynthia Paré

Hi everyone! 

I know it's an old thread and I should probably create a new one (because I couldn't find one that answers my question).

I'm having trouble importing the XLIFF file back into our Storyline Project (360). I don't think the issue is on our translator side, because I just tried importing the export right from Storyline and I always get the same issue, this popup : 


then this one, but nothing is going on :

What are we doing wrong? We tried on 3 different computers and we always get the same result. We are supposed to be able to fast track our process using these files, but now they are no good for us... Will we have to ask our translator to repeat the process with the .doc files (extra charge for us) or is there a way to get the XLIFF to work?

Thanks for the help!