Report.html not showing student answer after resuming course

Hi,

I have 2 issues here:

Issue 1:

The sequence below does not show student answer at report.html at 2nd visit and so on.

1. At 1st visit of quiz completion up until result slide > click on PRINT button > report.html appear with student's answers > EXIT course

2. At 2nd visit which resuming back to last left off > At result slide > click on PRINT button > report.html appear but student's answers column is empty.

Any suggestion to allow student answer to maintain there at report.html no matter how resuming tries attempted?

Issue 2:

My client is facing the same problem as the post here: (https://community.articulate.com/discussions/articulate-storyline/retrieving-data-for-lms-in-scorm-report) whereby report.html only show half of the questions & student's answer column.

Any solutions to this? 

Any workaround for the above two issues are welcome. Even if there is a need to include javascript, I can ask for my programmer for advice.

Many thanks!

11 Replies
Crystal Horn

Hello there, Emalyn.  I was able to replicate what you're experiencing in Storyline 2 but not in Storyline 360.  Could you just verify in which version you're working?  When I resumed on the results slide, I had no answers in the report.  When I resumed halfway through the quiz, only the questions I answered in the current session were recorded in the report.

Our QA team is aware this behavior in Storyline 2, so I'm going to add your experience to their report and see where we are on that.  Thanks so much for bringing this issue up!  I didn't see a workaround listed outside of forcing your users to start the course over if they exit.  I can see where you might not want to limit their ability to sign in and out of your course as they need, so I apologize that this feature isn't working as expected.

We will be sure to update this discussion with news from our QA team when we can.

Crystal Horn

Hi again-  just to provide a bit more information here.  I wasn't able to reproduce this behavior with Storyline 360's HTML5 output, specifically.  I found the same behavior with the Flash output, however.  Articulate 360 has a completely rebuilt HTML5 engine, and now that Print results is supported with HTML5 in 360, those factors might be contributing to the reason why Print Results is able to hang on to that information better.

So it looks like this is specific to the Flash output, which is good for us to know when investigating, but I thought I'd share that with you as well!  Thanks again.

Alyssa Gomez

Hi Libby!

We've seen a problem in Storyline 360's Print Results page, specifically when the learner leaves the course in the middle of the quiz. When the learner returns to finish the quiz then clicks "Print Results," only the answers from the recent session are shown. Does that seem to match what you're seeing?

Libby Doran

Continue incomplete attempt  (after exiting) > resume from results slide > Blank

Continue incomplete attempt (after exiting) > retry from results slide > Answers are filled in

Resume completed attempt (after exiting) > takes me to the results slide where I left off > answers are blank.

Does that help?

Katie Riggio

Hi, Vyoma. Thanks for checking in, and sorry you're running into this!

Although I don't have an update to share just yet, I promise to keep this discussion updated as soon as new information is available. Here's a glimpse into how we tackle bugs like this one!

In the meantime, we're happy to have a closer look at your setup to see what approaches we can offer. If you're able to share the .story file, please use this private upload link.

Lewis Masling

I’ve experienced the same issue whereby when users return partway through a series of Essay questions, they only see the answers they entered after returning displayed when clicking the Print Answers and not their answers from their first session (despite the resume function saving the answers entered from their first session).

I figured a workaround for this would be to ‘review’ their answers.

So on the final page I have a button to Print Answers, I have now disabled this button and added a new button called Review Answers with a trigger to jump to first slide. The user is then forced to submit their answers once again (they cannot edit their answers) in one session. When they get to the final page, Review Answers in now disabled and Print Answers enabled, clicking Print Answers will display the Report.html page with all the user’s answers as they have submitted them during this one session.

I know it’s not ideal to have the user click through their learning again (adds to the narrative that elearning is click click click?) especially if your course has lots of questions, but it does work. 

I hope this makes sense and helps out until Articulate can find a fix for this issue.