Text to speech adding the word "Dot" to end of audio file.

Apr 30, 2018

I pasted in a block of text and ran the text to speech option. It works well until the last sentence where it adds the word "Dot" to the audio clip. If I take the last period out, it still adds "Dot". If I delete a couple of sentences back, the word "Dot" disappears.

Anyone else have this happen?

23 Replies
Bob O'Donnell

My guess is there was a hiccup in the text or the program. I just went back and cleared all the text out, dropped it into notepad and then hand typed the text. Also made a new story with the old text. Maybe it has something to do with the amount. I have no clue at this point.

Trevor Peglowski

Sometimes Articulate can get buggy. I remember on one learning I was working on, I had text animating in by paragraph, and for some reason when a new paragraph came in, the last line of the previous paragraph would ALSO animate in again, and appear thicker. Had to delete and redo the text box. 

Adam Braun

Hi Bob,

I had the same experience with a particularly long block of text -- I could get the behavior to stop if I took away enough of the text, but removing any of the content permanently wasn't really an option. So, my guess is that it has something to do with length of text.

But, you can use the audio editor (click the speaker icon on your slide, go to Audio Tools on the top-bar when it appears) and manually edit out the last couple of seconds where the "dot" appears.

Ashley Terwilliger-Pollard

Hi Bob,

Pasting into Notepad is a good recommendation to strip out any unnecessary and invisible formatting, which could be contributing to what you're hearing with the text to speech. It's not something I've heard of other folks running into yet, have you seen this on a lot of files, or this is the first time? 

Bob O'Donnell

I always copy and paste from Notepad. Learned that lesson years ago. It may have something to do with the length of the text. If you trim out a few sentences, the "Dot" goes away.

I posted my story file a couple of replies up Ashley... feel free to play with it. I think its a small glitch in the program. I've cut and pasted from Notepad, typed directly in the text to speech window, etc. It still exports with the word "Dot".

Bob

Benita Tong

I had a coworker run into this problem yesterday. His workaround was to break up the paragraph (e.g., put half of it on a new line in the text entry or to paragraph break each sentence onto a new line) and text-to-speech will no longer say "dot." While not an ideal solution, it works for now. It seems like it's being caused by an odd paragraph character limit.

I've attached a file where I tested the paragraph character limit with lorem ipsum filler text.

Jill Freeman

Hi Alyssa. I just submitted a support ticket and enclosed my SL file with the "DOT" narration. It happens to me quite a bit. The "DOT" is not only at the end of the file, it can be anywhere in the paragraph.  I also receive the "Something went wrong" message when working with TTS.  Hope they can fix this! It is slowing me down!

 

 

Benita Tong

Hi Jill,

In case this helps, the best way currently to get around the text-to-speech adding the word "dot" is to break up the text into paragraphs when generating the text-to-speech.

I found the character limit for a paragraph to be ~952 (no spaces)/1,115 (with spaces). By 978 (no spaces)/1,144 (with spaces), the spoken word "dot" appears.

Ren Gomez

Hi Heinee,

Thanks for checking in. I'm sorry that you ran into the issue where you hear the word "dot" at the end of your paragraph.
 
It is currently in the early stages of review based on our How We Tackle Bugs article. To help you plan, it's unlikely to be fixed in the next couple of updates.
 
For now, have you tried the workaround Ashley mentioned above about adding a carriage return to see if that helps the issue? We'll pop back in here when there's any progress to share.
Katie Riggio

Good morning, Susan!

I'm sorry you're affected by this bug. 

We narrowed the cause down to the character length. If the text exceeds 1000 characters, then the word "dot" is read. We'll update you as soon as we know more!

For now, one way to prevent "dot" from being read is to include a carriage return in strings of text that exceed a character count of 1000.

If that doesn't help, we'd love to troubleshoot the affected file. Simply use this link to open a case, and we'll take it from there!

Scott Suter

I had the same problem. Using the sound editing tool is a finicky, and fine art, but it worked. Thanks for the advice. I used word.docx to edit, copy and paste the text to AS 360. I'll check the outline view for any hidden code, but this is a good solution until the bug is addressed. Thank you

Jose Tansengco

Hello Everyone!

I have some great news to share. We just released another update for Storyline 360. In Update 74, we’ve included important fixes and new features.

One of the bugs that was fixed was an issue where "the Text-to-Speech feature was adding audible 'dot' to generated audio if single line of text exceeds 1000ish characters".

To take advantage of this update, launch the Articulate 360 desktop app on your computer and click the Update button next to Storyline 360. You'll find our step-by-step instructions here.

Please let me know if you need additional help!