Inserting template gets stuck every time?

Jan 03, 2020

I have a course where i have created block templates for reuse throughout the course. This worked one or two times, but now when I chose to add a block and pick my template from the block library, it inserts a "inserting template" section into the course and never finishes.

broken feature?

Funny thing is, I can preview the course and the content shows up. I can go and edit other pages and then come back to this page and sure enough, it's still "inserting template". Block templates don't work for me. What can I do?

115 Replies
Pete Theodore

Heather, see my post on the previous page. Until they fix this, we can remove stuck templates by deleting them just like any other content block. The delete button is actually there, it's just invisible. Move your mouse to the very top right of the block (where the delete button normally is) and click to delete.

Crystal Horn

Hi folks - we have a new development. Are you double-clicking to add your block templates? Adding block templates to a lesson only requires a single click. We've seen that double-clicking on the template may be trying to insert 2 of that template, and causes the interminable loading.

Let me know what you think!

Karl Muller

Hi Sandra,

As discovered by Pete Theodore, the delete button is still there but it's not visible for some reason.

As shown in the image below, when the block insert fails, move the cursor to the top-right corner of the block. When the cursor changes to the hand icon, click and it will delete the block.

Karl Muller

Hi Amy,

This method (link below) does work, I just tried a few minutes ago. Move the cursor to the top right corner of the stuck block, and move the mouse slightly until it changes to the hand cursor. Then click to delete.