ERROR - LMS Initialize Failed on Quiz Marker SCORM 2004

Hi,

I've got users experiencing a SCORM error with some content build in Quiz Marker 09.

I can't reproduce the error myself but I've managed to get a debug log from one of the users having the issue.  Can anyone help me interpret the results to identify the problem, as I'm not sure what I'm looking for?

As but i am able to run my presentation content successfully with my LMS, and getting the required response back, along with user tracking.

Please help me out for this, i try a lot to figure it out,
below is the error which i get on debug of that content.

0:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - AICCComm - Trying to create XMLHttpRequest in JavaScript1.5
1:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - AICCComm - Entered browser conditional
2:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - AICCComm - Creating object
3:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - AICCComm - intReCheckLoadedInterval=250
4:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - AICCComm - intReCheckAttemptsBeforeTimeout=240
5:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - AICCComm - IFrameLoaded
6:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - AICCComm - In GetAICCURL
7:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - GetQueryStringValue Element 'AICC_URL' Not Found, Returning: empty string
8:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - AICCComm - Querystring value =
9:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - AICCComm - GetAICCURL returning:
10:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - AICCComm - In DetectPreferredCommMethod, checking XMLHTTP
11:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - AICCComm - Checking IFrame
12:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - AICCComm - blnCanUseXMLHTTP=true
13:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - AICCComm - blnCanUseIFrame=true
14:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - ----------------------------------------
15:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - ----------------------------------------
16:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - In Start - Version: 3.3 Last Modified=11/19/2012 10:39:08
17:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - Browser Info (Netscape 5.0 (Windows))
18:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - URL: http://localhost:41412/Quiz_2004_2/index_lms.html
19:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - ----------------------------------------
20:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - ----------------------------------------
21:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - In ClearErrorInfo
22:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - GetQueryStringValue Element 'StandAlone' Not Found, Returning: empty string
23:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - GetQueryStringValue Element 'ShowDebug' Not Found, Returning: empty string
24:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - strStandAlone= strShowInteractiveDebug=
25:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - Standard From Configuration File - SCORM2004
26:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - Using Standard From Configuration File - SCORM2004
27:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - In LMSStandardAPI strStandard=SCORM2004
28:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - Calling Standard Initialize
29:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - In SCORM2004_Initialize
30:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - In SCORM2004_ClearErrorInfo
31:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - Grabbing API
32:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - In SCORM2004_GrabAPI
33:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - Searching with Rustici Software algorithm
34:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - Grab API, returning, found API = false
35:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - Unable to acquire SCORM API:
36:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - SCORM2004_objAPI=undefined
37:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - In InitializeExecuted, blnSuccess=false, strErrorMessage=Error - unable to acquire LMS API, content may not play properly and results may not be recorded. Please contact technical support.
38:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - ERROR - LMS Initialize Failed
39:Tue Nov 20 2012 08:47:16 GMT+0530 (India Standard Time) - In DisplayError, strMessage=Error - unable to acquire LMS API, content may not play properly and results may not be recorded. Please contact technical support.

1 Reply
Christine Hendrickson

Hi Shiv. Welcome to E-Learning Heroes!

This looks like something that may be occurring on the LMS, itself. Since you're unable to reproduce the issue, you may want to contact the support for your LMS and provide that error log. 

Having said that, has your user tried accessing the course in a different browser? I do see in the log that they're using Netscape 5.0, the latest stable release was version 9.. and that was in 2008. It may help to have them try in Mozilla Firefox, Google Chrome or Internet Explorer. 

Here's some additional information:

If you receive an "Unable to acquire LMS API" error when launching Articulate content in your LMS, this may be caused by the version of Java that you have installed.

Some LMS’s use a Java API object to load content. Since content created in Articulate does not require Java, please do the following:

*  Contact your LMS provider and ensure that your installed version of Java is compatible with the version of the LMS you are using.
*  Ensure that you have published your content properly as described in the following article:
http://www.articulate.com/blog/publish-to-lms-with-studio-09/

If this issue persists, make the following modification to your player template, and test your content again:

1)  Open your presentation in PowerPoint.

2)  Go to Articulate > Player Templates.
3)  Select the "Other" tab.
4)  Deselect (uncheck) "Launch presentation in new window".
5)  Close the Player Template manager, and save the change when prompted.
6)  Publish your presentation for LMS using the newly saved player template, and test the content in your LMS