Hyperlinks in Quizmaker feedback not working

I have several quizzes that contain hyperlinks to Khan Academy in the feedback for an incorrect answer on each question. I thought it was all working correctly, but I am getting reports now that most of the links are not clickable. I tested it and sure enough - the first few questions work fine. After that, the links appear to be links but they are not clickable. I went back in to Quizmaker to look at the questions, but it is now behaving erratically. If I right-click on a hyperlink and choose Hyperlink, the URL appears to be empty, but if I paste a URL in and click Save, it is gone when I go back to look at it again.

If I click on More to open the feedback form, I can see the hyperlink in the URL field. Clicking the Test button goes to the proper web page. Then I try to Preview the question and the link is not clickable.

Some of the other questions are set up exactly the same way, but their links work just fine. Others might have two links, and one works but the other is not clickable.

Is this a known bug? Has anyone else encountered this problem?

You can see it in action if you go to this quiz and use the question drop-down to skip ahead to question number 8: http://blogs.jccc.edu/math/math-placement-info/algebra-compass-review-topics/. Choose an incorrect answer (the last option is incorrect, for instance) and then try to click on the link in the feedback.

7 Replies
Justin Wilcox

Hi Tracy.

I am guessing you have a read/write permissions issue related to the location of your quiz or where you are specifically publishing the quiz to. If your .QUIZ file is located on a network drive, move it to your C: drive. Working on a network drive can cause erratic behavior. You should also make sure you are publishing to your C: drive as well. In addition, make sure your directory paths are shorter than 256 characters. So for example:

C:\Users\Justin Wilcox\Documents\My Articulate Projects this could be where you keep your .QUIZ file and also where you publish to.

Tracy Newman

My working directory (and also where I publish to) is my D: drive, which is a second internal drive on my machine:

D:\Documents\My Articulate Projects\COMPASS preparation

Do you think it can be causing a problem because it's not the C: drive? All I have on my C: drive are programs - all data lives on the D: drive, where my Documents folder resides.

Tracy Newman

I copied my directory to the C: drive, opened the quiz file, and I previewed one of the problem questions with the same result - the link is not clickable. I deleted the link and then put it back in, with the same result.

What's so baffling is that it works fine for some of the questions but not for others.