Inserting a .swf file into quizmaker.

Ihave an issue with quizmaker as it keeps crashing when I am trying to insert a .swf file into a quiz. I have created the .swf in powerpoint and used an add in to publish as a swf file.

I also saw a tutorial where jeanette shopwed how to create a "hint" video in powerpoint and then embed the video in quizmaker but I cant find it. Can anyone help please?

14 Replies
Louise Greenhoff

Thanks Peter - that was the link I was looking for!

Also I still have the issue with inserting a .swf file into quizmaker. I have created a basic animation and published the slide as a swf but quizmaker keeps crashing when I browse and insert the file.

I am not using presenter to create the swf but another add in convertor I have in powerpoint - is this the reason it crashes?

Thanks!

Peter Anderson

Have you been able to publish other .swf files successfully, and only this particular one is giving you trouble? If that's the case, this article may help you find a solution by reviewing the best practices for Flash:

http://www.articulate.com/support/presenter09/kb/?p=76

Good luck, and please let me know if Quizmaker continues to crash. Thanks!

Louise Greenhoff

Thanks i'll have a look at that.

I only seem to have problems when using ispring to publish the .swf  from powerpoint.

When using presenter to publish the .swf file it works fine for the same .swf file.

I did find a "bodge job" by publishing the quiz and then swapping and renaming the .swf file as if I was inserting an engage imteraction and that worked fine.

Thanks for your help.

Tracy Parish

Okay.....I'm so frustrated.  I inserted an engage interaction (.swf) into a quiz and it worked and was publishing/running successfully.  I had to make a change to some part of it and now when I republish the files the interaction is no longer being picked up.  I do all the tricky little behind the scenes stuff (moving the engage_content folder into the correct quiz content, etc).  But still no.

I'm wondering if it has something to do with the fact that the "video.....swf" file in the actual quiz is now coming out labelled

video_~1 instead of "video....long stream of numbers......swf"???

(it does not pay to go on vacation)

Peter Anderson

Hey Louise, 

iSpring uses Actionscript 3.0 which is not supported by Articulate. Articulate software generates Flash 6 output. For this reason, Articulate software only supports Flash movies created using ActionScript 2.0 or earlier. 


If you would like to submit a feature request for ActionScript 3.0 support, you may do so here: 
http://www.articulate.com/support/contact/feature/

In the meantime, you can incorporate ActionScript 3.0 Flash movies into your Articulate Presenter presentations using the Web Object feature as demonstrated in this video tutorial:

https://player.vimeo.com/video/143914206


For more information, regarding ActionScript compatibility, please see: 
http://tinyurl.com/638l9t

Peter Anderson

And Tracy, 

It sounds like you may be experiencing a file-in-use issue. Whenever a ~1 is shown, this would indicate the file is in use. Can you try restarting your system and inserting the same Engage file into a different quiz; this will help determine if the other quiz has somehow locked the file. Let me know what happens. Thanks!

David Burton

Tracy,

It sounds as if your system may have been compromised in one way or another. The tilde (~) naming convention is used in DOS environments and will typically add the ~1 after the sixth character of a long filename (greater then 8 characters). With that said, are you noticing other system folders or file names unrelated to Articulate that are displaying this similar naming convention?