Adding number variables question

I'd looked at Jeanette's Adding number variables tutorial and, as I often do, tried to figure it out on my own before reading through the tutorial. My "resolution" does work, but I evaluated the variables in a different way, and I want to be sure it's valid for future reference, particularly since this is lesson that assigns points.

So, this is how the jump to slide condition is set up in the tutorial:

  1. Click the green plus sign to add a condition.
  2. In the If field, select Choice from the menu.
  3. Set the Operator to ==Equal to.
  4. Set Type to Value.
  5. Enter 10 for Value and click OK.

But I did this (I'd named my choices)

  1. Click the green plus sign to add a condition.
  2. In the If field, select Caption 1 Refer to HR from the menu.
  3. Set the Operator to ==Equal to.
  4. Set State to Visited.
  5. OK.

And I copied/pasted onto others and adjusted accordingly.

It works OK in terms of going adding the points correctly and going to the correct slides. But, in the long run would it work?

The original was not set up as a quiz, but I assume it could have been and, had there been several quiz slides, the points/percent would have been evaluated at the end. If so, would my "resolution" have worked?

5 Replies
David Anderson

Hi Becky,

What  you're describing would totally work on the slide level except that I would evaluate selected states and not visited states. Learners could click (visit) each choice before clicking submit. That would set all captions to visited.

In the context of this one example, your described method is a better solution than the variables I used in the tutorial. That's because you're only evaluating the learner's choice on a single slide.

But this example was from a larger course where points were tracked over multiple slides. That's where the variable is the better choice.

Rebecca Fleisch Cordeiro

Thanks for the explanation, David, and the clarification of selected vs. visited. That question was also brewing in the back of my mind. And clearly you knew that!

David, although I subscribed to this post and another where I'd asked a question, I've not received a message in my comcast account. There's nothing in the spam folder. This is a new issue...can't track a specific day (sorry). Any suggestions?