Audio is corrupted after editing text-to-speech

Every time I try to edit something in the text-to-speech text box (after first generation of the audio), I get corrupted audio, with something like a weird echo. The solution is to delete the whole audio and create a new TTS audio. Of, course, a huge waste of time.

Is this a known issue? Are you working on it? 

Thanks

22 Replies
Ashley Terwilliger-Pollard

Hi Marcos,

It's not an issue I see noted as a bug, so I'd like to investigate further with you! 

First, can you check the following: 

  • Are you on the latest update of Storyline 360 - Storyline 360, build 3.24.17733.0? You can check by going to the "Help" Tab -> "About Articulate Storyline".
  • When working on project files, do you follow the guidelines here to prevent corruption?
  • Is this happening in every file, or one specific file?

I gave this a quick test, and adding in some text to speech and then editing it, but I didn't hear any changes in the audio quality. Could you walk me through your steps exactly so I can try replicating?

Laurie Barnett

Ashley, I am having the same problem as Marcos. I'm following the guidelines to prevent corruption and I'm on the latest build of Storyline 360. This does not happen every time I edit the text-to-speech and return to editing the closed captions, but it happened to me in 2 or 3 of about 10 slides today (so far). 

Although I can delete the audio and start all over again, it's aggravating when you've already updated the closed captioning for 2 minutes of a 2.5 minute audio piece and have to start all over again!

Patti Blasingame

Hello. This problem happens to me all the time on large and small projects. I have the latest version of 360, save my files, etc. It has been a constant thing for over a year. It is frustrating and time consuming.

Here's what happens... after one or two edits to the Text to Speech item in the edit window, the audio item on the timeline fades out/grays out, and will not play sound no matter what I try. 

The workaround:

1. Hover over the Text to Speech item on the Timeline, then, right click and select Text to Speech to open the Edit window

2. COPY your original text (close the edit window)

3, Create a NEW text to speech item by going to Insert > Audio > Text to Speech, then PASTE your original text in the new TTP edit window

4. Select Insert (SAVE)

5. Then click on the old (audio) item on the timeline and delete it.  

I realize this adds steps, but it is better than completely losing your text... particularly when you have worked so hard tweaking the sound.

If there is a way to prevent this problem, I'm listening!

Thanks. 

Thor Melicher

I’m not sure if this will help but I did write an application that may streamline your process just a bit.  It’s a bit of a workaround though as you’ll have to go to the source that Storyline uses, Amazon Polly voices. 

Here’s what you do: 

  1. Get an Amazon Polly account (yes, there is some cost involved but doesn’t seem that prohibitive) (https://aws.amazon.com/polly/)
  2. Save your scripts as separate files (MS-Word or Text)
  3. Download HeroVoice TTS from the Microsoft Windows Store (fully functioning 15-day free trial)
  4. Encode your files with HeroVoice TTS – apply a global setting for speed and even comma duration so your files are consistent.
  5. Select the voice you want – these are the same as you’ll find in Storyline today including Neural voices (which aren’t currently available in Storyline)
  6. Load each audio file into Storyline
Angela Ericksen

I have this happen all the time if I edit too much.  It's to the extent that if a change doesn't add value I refuse to do it.  I either get an echo sound, but more often a garbled sound.  I am using version 3.57.26476.0.  This has occurred in every version I have used for the last year to year and a half.

Leslie McKerchie

Hi, Carol and Angela (welcome to E-Learning Heroes too, Angela 😊)!

Thanks for reaching out and sharing what you are experiencing. I do not see where any of the folks above sent this to our team to take a look.

I'd like you to share your project file privately with our support engineers to investigate what's happening with your permission. Please share the steps to replicate the issue as well. It will be deleted when troubleshooting is complete.

Angela Ericksen

Slide 6.3 On all changes updated text to speech without updating closed captions as it does it more often when doing it this way.

Text to speech:
In summary, employees are responsible to adhere to all appropriate and proper use and maintenance procedures, as presented during training as well as those established by the manufacturer.
Supervisors play an important role in ensuring compliance of the Respiratory Protection Program, and are expected to evaluate employees’ adherence to proper use and maintenance procedures.
Manufacturer’s instructions for use, maintenance, cleaning and care, and warnings regarding the assigned respirator’s limitations must be read and observed at all times.
Employees must not wear respirators into atmospheres containing contaminants or levels that are not compatible with their assigned respirator.
Employees must keep track of their assigned respirators so that another person does not use it.
All agency approved respirators must be purchased by the guidelines established in the Respirator Protection Program.

Changes:

1. Duplicated and inserted” Manufacturer’s instructions for use, maintenance, cleaning and care, and warnings regarding the assigned respirator’s limitations must be read and observed at all times.” So it reads twice.

2. Added the closed caption and saved.

3. Went back in and changed CC, box 3

4. In the 2nd manufactures line changed the word regarding to about.

5. Made change in the close caption

6. Line 2 supervisors line added the word can. Updated closed caption

7. Second manufacture line removed the word assigned. Removed from CC

8. [cid:image003.jpg@01D82251.37010A20] Added word assigned back in with a comma

9. Removed comma

10. Went into CC to edit. This screen showed for a long time. Had to hit exit. Did this twice as cc never loaded. Went up to slide 6.2

11. Went into storyline and deleted extra center slides to reduce file size.

12. Went back to 6.3 to edit cc.

13. CC still wouldn’t load had to exit.

14. Saved file

15. Went back to 6.3 to edit cc.

16. CC still wouldn’t load had to exit.

17. Went into text to speech added comma on manufacture second line behind the word warnings.

18. Went into CC it opened. Added comma to cc.

19. Went into text to speech deleted duplicated manufacture line.

20. Added coma after the word atmospheres and then quickly went into CC. Slide 6.3 now has garbled text to speech. You can hear it when editing CC, previewing slide, or when published, but not when just previewing the audio file.

· Three other noted issues.

1. Spell check in notes section. You cannot just easliy rick click on word, select corrected word and have it change.

2. Colors on slide change regardles od slide master. I can’t get my deck to replicate, but my co-worker copied on this email might have an example of this.

3. New scroll box feature. Many times you can’t see scroll bar until you go into preview mode. Randomly adds to some titles and not other, even if those slides are using the same slide master.

Regards,
Angela Ericksen
ISH Training Program Manager

Angela Ericksen

Good Morning,

Attached is another example of the garbled text to speech that just happened to me this morning, while working on the file. I had edited the text to speech 4-5 times changing sentences and correcting the CC. Then the CC refused to open and I kept receiving a message that it couldn’t open. I saved, went into another slide and then went back to slide 1.4. CC still would work. Closed file and Articulate. Re-opened and CC’s worked so I finished my work. Went to preview slide 1.4 and heard garbled text to speech.

Regards,
Angela Ericksen
ISH Training Program Manager

Maria Costa-Stienstra

Hi, Angela.

Thank you for the steps and the additional details!

I wasn't able to find a support case with your .story file. Did you share it with our engineers so we can help investigate? 

If you haven't done that yet, you can use this private link to upload the file

I also wanted to add a quick note: it looks like your signature with contact information came through when you replied via email. You can remove it by clicking 'Edit' below your response. Here's a quick Peek 360 video if you need help.