button beep and highlight

I'm simulating a button press on a touchscreen for a project i've created.  I created a trigger upon button press the button trigger plays a small beep sound and highlights the button pressed. 

This only works on the same slide or same layer or transition between layers.  this effect DOES NOT work for me when changing to another slide.   

I already have a work around in mind but i'd like other ideas because i feel this should just work! 

(my work around is to show an additional layer right after the button press to get my beep and button highlight, that addtional layer will be a duplicate of the next slide.  that layer will have a Trigger to jump to next slide with a very short timeline to appear to the user that they are already on the next slide.  However this will be very time consuming for me to do.  any other ideas?)

11 Replies
Ashley Terwilliger

Hi Randy,

Is it possible to share your .story file here with us? This way we could take a look at your trigger order and see if there is anything else that is preventing it from playing. If you can't share the .story file with us here, you could also take some screenshot of your trigger panel set up, and I could start with that. 

Ashley Terwilliger

Hi Randy,

Is it possible the trigger that was advancing them to the next layer was above that which allowed them to click to advance? You'll want to keep in mind that triggers will be fired from the top of the trigger panel down. You'll also want to check your slide properties, as you can set to automatically advance or advance by user click.