Button malfunction - only part of the button is clickable

Dec 08, 2015

Hi,

I have some buttons that are malfunctioning. On some buttons, only part of the button is clickable. When a learner hovers over the malfunctioning button in certain areas, the cursor stays as an arrow and does not turn into the hand, signifying clickability. If a learner doesn't realize this and clicks when the cursor is only an arrow, nothing happens, even though they are clicking on the button. The story file previews perfectly, but when published we have this issue. A work around could be to change the hover state to a different color, so that the learner has another more obvious clue where the object is clickable. However, that doesn't address the root problem of the malfunctioning button. This was originally built in Storyline 1, then updated to Storyline 2. Both versions have the same problem.

Has anyone else had this issue?cares.unc.edu/Preview/OC_button_malfunction/story.html

25 Replies
Monica Jackson

I'm encountering the same issue. Three buttons on a slide do not appear to be clickable unless the learner hovers over a specific area of the button (upper left portion of the button). I've deleted the buttons and rebuilt them. The problem still occurs sporadically. What was the solution to this issue? Using Storyline 3 and updated the software yesterday, hoping to eliminate the issue, but the issue persists.

Alyssa Gomez

Hey Monica, thanks for reaching out! 

That certainly sounds odd. What Windows Display setting are you using? Is the scale set to 100%?

If so, I'd love to take a closer look at your file to try and nail down the cause of this problem. You can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.

Randy Hill

Most of the time that I see user's having that issue is because they are trying to use a group as a button (most people do not know that almost all shapes can have text added to them and you don't have to add a text box over the object). This causes the hover to act funky sometimes. Or, you have something in your timeline that is above it, possibly part of a text box. It keeps the button from being fully accessible. 

Paul Tottle

I've just had a similar problem on a complex diagram. I've had this one before. I sat and watched learners and the problems they were encountering. If they clicked a button and nothing happened their behaviour immediately changed and they went searching for other solutions on the screen. Even though the instructions were clear. After clicking lots of other things, they came back to the same button. They expected (based on other interactions) that clicking is reliable, so they were very unlikely to try different parts of the button.

My solution: I found that the arrow object has a very wide area of influence. If an arrow is near a button (e.g. 10px away) the cursor will turn from a hand to a pointer and the button stops operating. The solution was to move the arrow further away and bring the button into the foreground.

I've previously reported problems with arrows having a disproportional influence, but it seems I'm a lone voice. 

Soma Lukácsházi

I have the same problem. My buttons are malfunctioning in a specific line (where they should be) on my slide. If I put them somewhere else they are ok. If I put them back to their original place, they are working wrong again. These are simple text boxes which should be buttons. They used to work well, but not anyomre... Nay idea please?

Walt Hamilton

There is a know issue with them being in the lower part of the slide under certain circumstances.

On the other hand this sounds like it could be the problem Paul experienced, that they are(partially)  covered by some invisible object. How many pixels do you have to move them to activate them?

Soma Lukácsházi

Hi,

Thanks for the reply.
I have checked several times and there is no invisible object at all.

Interestingly the malfunction happens when I remove the Player natiogation
button. If they are also there, my own created buttons work properly too
(they are clickable properly).

Since I didn't need the Player navigation buttons (because of having my own
ones), I wanted to delete them. However, as soon as I deactivated them (the
ticks from the chekcbox), my own created buttons started to work wrong,
which means I cannot click on them or hover them directly.

Has anybody experienced this before?

Christina Williams

Currently dealing with this issue of malfunctioning buttons with one specific learner. They can't click any of the custom buttons that are in the course when they come up. No one else is having this issue, so it seems isolated, but have tried everything with no success. 

They are on the most up-to-date version of Chrome and using a Windows PC. Even tried sending them a link to the Review 360 version to see if it was MAYBE something in the LMS, but nope, still having the same issue. 

Alex Premselaar

I have had this issue... this morning actually -- where buttons in certain spots are not clickable. No matter if they are in front, alone, grouped, etc. These particular spots are always the corners of the player. How I solved this was to change my player from Classic to Modern. Which isn't ideal since I've been having issues with photo clarity within Storyline, and the modern player is supposedly the best for that... But now people can click buttons!

Is this similar to what you're experiencing?