buttons not working in preview

All of a sudden when I preview a slide the buttons to layers or other slides are not working. If I preview a scene they work. WHAT's going on with SL3??? Help please!

Well, I just discovered if I insert a new shape and give it a trigger to show a layer THAT works. This is beyond frustrating. Does this mean I will have to replace EVERY shape and button to get it to work?

I'm wondering if this is related to having to divide out my original file in order to export for translation and then importing into the divided file?

PLEASE get the translation bugs fixed!

24 Replies
Sylvia Wright

Leslie, I think I have it figured out. It used to be when clicking on buttons that went to other slides a message would come up saying the slide wasn't available, but now nothing happens. The buttons just don't work in preview except in a scene. I'm still checking things. If I get stuck I'll definitely connect here. Mega thanks!

Sylvia Wright

Good Morning Leslie, I'm having the button issue again. I cannot get a button to display a layer. I decided to import the faulty slide into the Articulate test 2 file I uploaded for another issue and when I did that the button worked Ugh. Really frustrating. I've tried deleting the shape and putting in a button, but it doesn't work.

I tried putting a clear shape from another object on another layer that did work over the rectangle and I have discovered the problem. The whole bottom end of the slide layer is a dead zone. I moved the original rectangle (button) up on the slide and it worked fine.  I recall something about this in the past, but I don't recall what the remedy is. I'll see if I can find it.

Leslie, here is the link to the original "buttons not working" dialog and apparently there is a bug.  https://community.articulate.com/discussions/articulate-storyline/buttons-not-working

 

Daniel Berlin

Hi. 

Just today started having this same issue in Storyline 3.

NO buttons work in slide preview and project preview, as of this morning (worked perfectly fine until now)! They seem to work ok when project is published. Perhaps uninstalling and re-installing Storyline 3 might help?

Has there been a solution to this matter?

Thanks,

Daniel.

Leslie McKerchie

Hi Daniel,

The issue reported here was specific to objects on the bottom of the slide near the player, and the issue only happens when the slide is previewed separately.

If you're having an issue with the overall preview and all buttons, it sounds like you may be experiencing a different issue.

I'm curious if the issue happens in any course you are working on or just this particular one?

  • If you cannot re-create the issue in a new course, I would advise you to import the file into a new one and proceed.
  • If it's happening in any/all files, you should conduct a repair of your software.
Leslie McKerchie

Hello Josh and welcome to E-Learning Heroes. 😊

Thank you for letting us know that you've experienced this issue recently as well. It sounds like you may be seeing something slightly different than has been reported here.

I'd like you to share your project file with our support engineers to investigate what's happening with your permission. You can share it privately by uploading it here. It will be deleted when troubleshooting is complete.

Nora Regis

I am also having this issue. I added a Pause button (pause timeline of this slide when user clicks) and a play button (resume timeline when user clicks) to a single slide (my third slide in the project). When I load Preview the slide, neither even register as buttons. When I preview the scene, the buttons in the middle of the first two slides work, but the new slide buttons on the third slide still don't work. In addition to these two slide specific buttons not working, the buttons also do not work on my little nav bar on the bottom (which is part of the slide master). 

I created a new blank story file with simply these two buttons on the slide and it worked as expected in Preview this slide. 

Nora Regis

I reverted to an earlier version of my storyline file from before I added the slide-specific pause/play buttons and previewed a scene, and none of the buttons in my slide master nav bar that show layers are working. They were before. I uninstalled and reinstalled storyline and that didn't solve my problem either. 

Lauren Connelly

Hello Nora!

Thank you for sharing these troubleshooting steps with us! I see that you've reached out to our Support Engineers and working with my teammate, Jan. He has logged this issue as a software bug and linked your case so we can update you when a fix is released. Jan is still available in your support case if you need anything!

Fred Good

I'm having this issue today (SL3). I'm using my own PREV/NEXT buttons on my slides, and they do not function when previewing one slide. I have to preview the entire course just to check if the state on one button is being changed properly by my variables. What a big waste of time! It used to just pop up an error message saying it couldn't go to the link, which was perfect. Maybe moving to 360 will solve the issue...