Caching Issue

A peer and I have discovered a caching problem, but I'm not sure if this is a result of a Flash issue or a Storyline issue. Both of us have published a module, uploaded it to different servers and then accessed the module via a link from a HTML launching page. That is all fine and good until the module has been edited.

After editing the module, it is republished, and then pushed out to the server using the same folder structure. When each of us has tested our module by accessing it in a web browser, it looked perfect. When another user tested the module, she somehow accessed a previous version, combined with very garbled, unreadable text/characters. This was peculiar because when I pushed it to the server using my FTP client, I actually deleted the previous folder and all it's contents. Somehow, our tester was still accessing a previous version combined with completely garbled and unreadable text. She restarted her machine and deleted her temporary internet files but reported the same issue.

Both my peer and I are experiencing the same issue, but we have the same tester. We are located in the US and the tester is located in Germany. Not sure if this has to do with anything, but thought I would include it just in case.

Why is this happening? The only fix that works is to publish to a completely new folder on the server each time. But this cacheing issue shouldn't be occurring. 

Is this a Flash issue or a Storyline issue?

20 Replies
Dennis Hall

If the CTRL+F5 solution does not work, your server may a "no cache" setting to be turned on. Enabling this setting will vary from server to server so consult a Web-Server specialist to enable it.

If the server is an LMS, caching is supposed to be turned on, and the only way I have ever cleared the issue (without getting into the server software itselft) was to unregister the user from the course, republish the course and re-register the user again.

Dennis Hall

Hi Lisa:

If the no cache setting is turned on it should not save session data for the users, so, yes this would help. If your server is a PHP server, there are many methods of setting this "nocache setting" (including putting code in your starting html file.

I must reiterate, however, this is not something you want to do. Get a server specialist.

For Phil and the Articulate gang...

I'm not sure why your LMS only caches for 24 hours, unless you mean active cache (i.e. cache in live memory).

One of the jobs of an LMS is to store a users cookies (collected via javascript between the Articulate course and the LMS) into the database (known as session storage or session caching). This way when the user logs in again, and launches the course again, the LMS will retrieve the data from storage and serve the user with the last data automatically saved on exit (hense asking them "Do you want to continue where you left off?").

I hope this helps everyone.

Best Regards

Phil Mayor

I have no idea, for four years now if I view a scorm, then update it I see the old scorm for 24 hours 

our network guys promise me they do not cache us, the server guys say there is no cache, the NHS N3 people are not sure if there is a cache, but somewhere there is. 

Interesting off the N3 there is no problem

Drew Pruitt

Just experienced this same issue using Microsoft IIS 7 servers on Windows platform.  We deleted old files in parent folder  on server and republished course.  Not until we cleared local cache in  local browser did the issue go away for end users.    

We update courses fairly regulary so this may present an issue with our regulartory courses that are viewed by thousands of employees. 

Philip Siwinski

Hi everyone, 

I wish to get back to the topic of caching issues. Did anyone find a solution?

I wish there were a solution at the "Publishing for LMS" level.

"Another option would be to change the LMS reporting information (such as title or identifier) when republishing your Articulate content, so it's not using the same information as the original course." Articulate - Old Version of Content Is Displayed After Updating Published Files

T
hat doesn't work for me.

I can't get anything to force the browser to get the updated version of a SCORM course. Is there any option to insert manually :-( some code in the output js or html files?

Many thanks

Ashley Terwilliger-Pollard

Hi Phillippe,

If you're publishing with a different file name, title, etc. and then uploading that into your LMS, that should give you a new version of the course. Are you able to try clearing out the browser cache as well to see if that assists? Have you checked with your LMS team regarding this issue? 

Philip Siwinski

Hi Ashley, thanks for your answer.

The issue is totally about the browser cache. Clearing it force the browser to get the latest version of the course. But the problem seems to be very hard to get thousand of non-technical users to clear their browser's cache... I'm looking for a workaround.

I have the same issue after having changed the name, title, and identifier of the course...

Is there any other solution than clearing the browser?

I'm also getting in touch with the LMS provider. Thanks.

Ashley Terwilliger-Pollard

Hi Cynthia,

I don't know of a standard resource to point you too on how to clear a cache - but I did a quick web search and found these two that may offer you a starting point: 

Hope that helps you get started! Have you asked your LMS team if there is a way to ensure it loads a new version? 

Ashley Terwilliger-Pollard

Hi Lein,

There isn't a feature in Storyline to clear the browser cache and ensure that the latest version of a course will load. If this is becoming problematic in your environment, I'd look instead at publishing a new version of the course and uploading that to your server/LMS separately from the earlier instance. That would allow learners to have a brand new link to access the new course, and they shouldn't run into any caching issues from the server.